
84     Linux Format March 2009

Tutorial First Steps 

Andy 
Channelle
Andy seems to 
have been taking 
his first steps in 
free software 
forever, and has 
been interested in 
technology since 
the advent of the 
Dragon 32.

Our 
expert

it can be used effectively for similar types of work as long as 
you aren't too ambitious.

In this tutorial, we’re going to create a simple flash card 
applet with a series of pages, then put them together in a 
non-linear fashion. We’ll also add a few external links and set 
up a trigger to play a sound file. We’re using OpenOffice.org 
version 2.4 for the purposes of compatibility, but the process 
is identical if you’re using a more recent edition.

Structure and content
The project begins with a blank presentation, so when you 
launch the application – Applications > Office > OOo Impress 
or similar – click straight through the Presentation wizard 
without changing any of the values. Once you hit the final 
Create button, you’ll be presented with the normal Impress 
interface. This has a toolbar and menu bar at the top, a Slides 
panel down the left-hand edge, where you can select and 
manage slides, and an editing pane on the right where various 
options can be defined. To keep things simple we’ll use the 
basic white slides, but it’s possible to begin with one of the 
many templates available on the internet (Impress can work 
with Powerpoint templates) or create your own.

In the Slides pane, right-click any blank space and select 
New Slide. Do this twice more, so you have four slides in the 
pane. These can be selected by clicking each one, and the 
main work area will then display the selected slide. Note that 
by default the slides are named “Slide 1”, “Slide 2” and so on. 
It's often worthwhile renaming them; to do this right-click a 
slide, select Rename Slide and input a new name. We’ve 
called our slides “Introduction”, “Question 1”, “Q1-Right 
Answer” and “Q1-Wrong Answer”, which gives us a logical 
progression through the slides. 

With the structure in place, add a text box to the 
introduction slide using the Text tool, which you can access 

Impress: Create    e
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Impress can do more than just display pretty pictures.  
Andy Channelle guides you into a realm of interactivity...

I
mpress is the presentation element of the OpenOffice.org 
productivity suite. At its most basic, it’s used to create a 
series of slides which are displayed in a linear fashion. 

However, it’s also possible to build non-linear productions 
with Impress for use in kiosk presentations (where the user 
advances the slides themselves) or a product catalogue. It 
could even be used to make a talking book style presentation, 
where the user triggers events such as animations, sounds or 
opening a new page. Impress may not have the same facilities 
as Flash, Director or many other authoring environments, but 

Last month We showed you how to be stylish with Scribus templates.

 It's best to design the structure of the presentation 
before thinking too much about content.

 You can link to any other element in the presentation, 
including notes pages and sound files.
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via the T icon in the Draw toolbar at the window’s base. Click 
and drag a frame to the page, then add text. This can be 
formatted as normal using the Formatting toolbar.

It's easy to jazz this opening up with a picture too. Add one 
by selecting Insert > Picture > From File... and then navigating 
to your chosen picture. This can be moved around and 
resized using the handles that appear when an image is 
selected. We’re going to use text for the interactive elements, 
but the same process could be applied to graphics.

Now add a second text frame and type ‘Start’ in the frame. 
This is going to be the link that launches the whole 
production; when the user clicks on this word it should take 
them to the first question on the second slide. Select the 
piece of text (it will be highlighted once selected) and then go 
to Slideshow > Interaction in the menu bar. Use the drop-
down list in the resulting dialog box to select Go To Page Or 
Object, which changes the display to show all the pages and 
their associated notes. Select Question 1 from the list and 
click OK. You can test whether everything is working by 
selecting the first slide, then running the slideshow (hit F5 or 
go to Slide Show > Slide Show) and clicking the Start text. 
The show should advance on to the next slide. Press Escape 
to return to the editing interface.

With that first link created, you can begin adding the rest 
of the content to the other slides. On the first question slide 
we’ve added a textbox with a French phrase and two images 
representing potential answers. The first is a picture of ice 
cream (CC Mujitra), the second some pizza (CC The Pizza 
Review). Remember to hold the Shift key when resizing an 
image to retain its proportions.

One of these images represents the correct answer, so 
select that image, then go to Slide Show > Interaction and link 
the image to Q1-Right Answer slide. Similarly, the incorrect 
picture should be linked to Q1-Wrong Answer. Again, test 
whether everything works correctly by running the slideshow 
and clicking through the various links. With that done, add 
some appropriate content to the answer pages and also set 

up a link to the next question on both pages. This is how the 
progression through the entire applet is created.

Now we want to add a sound file to the question page. In 
this case it will read out the question phrase, but it could be 
used to include any kind of audio. To do this, select the slide 
and then Insert > Movie and Sound before navigating to the 
WAV or MP3 file you want to include. Select it and you’ll see a 
speaker icon added to the page. This can be resized, and 
we’ve made it so small that it isn't visible. Adding a piece of 
video can be done in a similar way and the result can be 
repositioned or resized just like an image.

Going outside the app
The final piece of content will be a link to a web page which, 
when clicked, opens inside the system’s default browser. 
There are quite a few uses for this; in a sales presentation it 
could link to an order page on your company’s website or a 
contact form. Here, we’re using it to link to a YouTube video to 
reinforce the answer and provide a reward.

First create a text box and add a piece of text to be the 
link. Now highlight the text and select Insert > Hyperlink to 
launch the Configuration dialog. Make sure Internet is 
selected from the options on the left, then put the URL for the 
link into the target bar. In the Further Settings section, change 
the Frame option to Blank to ensure the page opens in a new 
browser window or tab and set the Form to Text, or Button. If 
you select the latter, use the Text space below the option to 
define the word(s) used for the button. Finally, click Apply and 
Close, then test the production again.  

With the show completed you may want to export it for 
wider use. If you’re sure your audience has access to 
OpenOffice.org, then the native format is best. You could also 
use the Powerpoint format, which has the advantages of 
being widely used and embedding the content into the file 
itself. The third option is to use Impress's HTML output 
wizard, which should result in a folder full of files that can be 
played back on almost any computer. Note that our attempts 
to output to Flash didn’t work as expected and all of the 
interaction elements were lost.  LXF

e    engaging slides

Find templates 
to use in your 
presentations at 
www.smalldata 
problem.org/
ooextras.

Too much audio in 
presentations can 
be annoying. Try to 
use it sparingly!

Quick
tips

Quick
tips

 Exporting to 
Flash wasn’t as 
reliable as the 
native format, 
Powerpoint or 
converting the 
file to HTML.

 Links can be created using either a piece of text or a 
button that will be embedded in the slide.
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“It’s better to select music 
with high tones and 
staccato delivery.”
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M any people are reluctant to spend 79p on a 
downloadable single, but will pay £3 per month for 
access to a couple of songs to use as ringtones on 

their mobile phones. Thankfully, you can avoid the cost with 
some free software and your own music library. In this 
tutorial, we’ll show you how to kill two Byrds with one Joss 
Stone by taking a normal music track and editing it into a 
personalised ringtone.

We’ll begin by installing the latest edition of Audacity, one 
of the best free software music programs available, which 

we'll use to 
trim the music 
track to an 
appropriate 
length and 
convert it to 
MP3 format 

for use with your phone. If you’re using Ubuntu, Fedora or 
SUSE, the software will be available via your normal package 
manager; just try searching for ‘Audacity’. We’re using 1.3.4 
Beta here, simply because this is the version that ships with 
Ubuntu Hardy, but as this tutorial only involves basic editing, 
the procedure is the same in other versions of the program.

In addition to the application itself, you’ll probably also 
need to install the Lame encoder in order to read and write 
MP3 files in Audacity. If Lame doesn’t appear in your package 
manager, there are links and instructions for installing the 
encoder on the Audacity website. This is also where you 
should go if you want to download the latest development 
version of Audacity instead of the most recent stable variant.

With your chosen version of Audacity and the Lame 
encoder ready, your first job is to select the tune to edit.  

Audacity: Make    a
Personalise your mobile using a snatch of your favourite tune. 

Some songs suit becoming ringtones better than others, so 
think about which is the most fitting. For example, Barber’s 
Adagio for Strings won’t cut through the background noise in 
a busy shopping centre as effectively as Survivor’s Eye of the 
Tiger. It's better to select music with high tones, staccato 
delivery and immediate starts for this project, rather than use 
a song with deep bass tones and lengthy notes. Fortunately, 
one of the advantages of using audio editing software is that 
we don’t have to use the first part of the tune if it's unsuitable 
– instead we can be more selective. This is especially 
important when creating an SMS alert, as these need to 
feature short, sharp sounds to grab attention. Bear in mind 
that they shouldn’t really last more than a few seconds.

Making waves
The interface of Audacity is fairly intuitive. Below the menu 
bar is a set of transport controls that control playback and 
recording, a toolbox containing six tools and a selection of 
other tools and monitors. We’ll explore these briefly as we 
work. Below these lies the Waveform window, where most of 
your editing will be performed, and then at the base of the 
window is a section where selections can be made 
numerically, which offers fine control.

The toolbox contains six options which are used in the 
editing process. From top left, clockwise, the tools are: 

 Selection tool This is used to select areas of the waveform 
to keep or discard. Once a selection is made, it can be copied, 
cut and pasted as with any normal selection of data. We’ll be 
using this and the Trim tool (Edit > Trim) to select the audio 
for this project. 

 Envelope tool Used to change the volume or pan (left/
right) values over time without having to manually alter the 
controls as the track plays. We’ll use this to fade in the audio. 

 Draw tool Designed to repair clicks and distortion in 
waveforms. This is quite an advanced tool, so we won’t be 
using it here.

 Multitool Provides rapid access via various clicks to all  
the other tools. 
 Timeshift tool Used to cue up the different tracks used  

in a production. 
 Zoom tool Moves in or out of the waveform to expose 

more or less information about the track. It's most useful 
when editing a particular section of the waveform.

To the right of the toolbox are the input and output 
monitors, and these can be initiated by clicking the small 
downward arrow below the L/R meters and then Start 
Monitoring. To the right of these you’ll see the playback and 
record level sliders and a series of buttons to perform 
standard cut, paste and zoom tasks.

Now you know what everything does, you’re ready to get 
creative with your music…

 Audacity can import audio from a number of different formats, but the most 
useful export format for this job is MP3.

LXF116.tut_begin   86 20/1/09   10:17:41 am



March 2009 Linux Format     87

 First Steps Tutorial

 Audacity 1.2.6

Next month Build a family tree with Gramps and a mindmap with Freemind.

1  Import the song
Audacity supports various formats including 
WAV, OGG and MP3. Select File > Open and 
use the file browser to locate your audio file. 
Once loaded, use the Zoom tool to take a look 
at the waveform, and the horizontal scrollbars 
to navigate its length. Push the Play button to 
hear the track. The playback meters should 
be animated. If not, click the Meter arrow and 
select Enable Meter.

4  Normalise the levels
Most modern music has consistent amplitude 
across the entire track, but this may not be the 
case if you’re using a song recorded before the 
digital age. To get consistent levels, select the 
track using the mouse and go into Effects > 
Normalise. Set the Normalise maximum 
amplitude between -0.3 and -0.0. 

2  Select a section
By default, playback will begin at the start of 
the track. Use the Selection tool to select a 
region of the waveform to be the ringtone. The 
section will be highlighted, and clicking Play 
will now play back just the current selection. 
You can use the mouse to drag either end of 
the selection back or forward, using the Zoom 
tool for precise adjustments. Hit Shift+Play to 
loop the playback around the selection.

5  Save the fi le
Before going any further, you should save the 
file (File > Save Project As…) using Audacity’s 
native format. This will keep your original file 
safe and allow you to return to the project later 
to make adjustments. If you need to transfer 
the project to another computer at any stage, 
remember to transfer both the AUP file and 
the _data folder that accompanies it.

3  Trim the clip
With the selection made, use Edit > Trim to 
remove everything outside it. You can now 
use the Timeshift tool to move the entire 
waveform to the start of the track. If you don't, 
you may end up with some silence at the start 
of your ringtone. It’s always better to trim too 
little initially rather than too much, because 
shaving off a bit more later is relatively easy.

6  Export the MP3
MP3 files are commonly used for audio 
playback on mobiles, so we'll use that format 
for the final output. To do this, go to File > 
Export to launch the file browser. In the lower-
right of the window, change the file format to 
MP3 Files, navigate to the required location, 
name the file and then hit Save. Now transfer 
the track to your phone as you would with any 
music file and set it as the ringtone.  LXF

e    a ringtone
Step by step: Prepare a song for your mobile
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