The place to post if you need help or advice

Moderators: ChriThor, LXF moderators


Postby Davido02 » Sun Jun 26, 2005 8:15 pm

Has anyone tried to install the Gallipoli game from the DVD from LXF69 yet? I tried it on a lazy sunday afternoon but during the istallation it reported that I needed ClanLib so I duly went off and downloaded ClanLib-0.7.8 During the make install I can see messgae flicking by saying to link this and to that but too quickly to take a note of them. Is there a logfile for these messages somewhere? In config.log I noted the following

ACLOCAL='${SHELL} /home/david/ClanLib-0.7.8/missing --run aclocal-1.7'
AMTAR='${SHELL} /home/david/ClanLib-0.7.8/missing --run tar'
AUTOCONF='${SHELL} /home/david/ClanLib-0.7.8/missing --run autoconf'
AUTOHEADER='${SHELL} /home/david/ClanLib-0.7.8/missing --run autoheader'
AUTOMAKE='${SHELL} /home/david/ClanLib-0.7.8/missing --run automake-1.7'

Are these telling me things that need to go into a makefile or something and if so how do I do that?
Posts: 31
Joined: Sun Jun 26, 2005 7:54 pm

RE: Gallipoli

Postby jjmac » Mon Jun 27, 2005 12:33 am

]$ make 2>&1 |tee zmake-<date>out

]# make install 2>&1 |tee zmake-<date>-out

Aside from config.log, that will log the two operations.

If you look through youy makefile(s) for a variable named 'DESTDIR=' it can be used to cause the install process to be done under a directory pointed to by the variable. It just allows you to view what will be installed and where, if you so desired. Not all makefile(s) include it though.

So, did you compile/install the lib. Looks like it may be looking for that path for some reason. Do you need to configure the lib.


The FVWM wm -=- -=-

Somebody stole my air guitar, It happened just the other day,
But it's ok, 'cause i've got a spare ...
LXF regular
Posts: 1999
Joined: Fri Apr 08, 2005 1:32 am
Location: Sydney, Australia

Return to Help!

Who is online

Users browsing this forum: Bing [Bot] and 1 guest