Samba Netbios Name Resoluion Problem

The place to post if you need help or advice

Moderators: ChriThor, LXF moderators

Samba Netbios Name Resoluion Problem

Postby humbletech99 » Fri Jun 03, 2005 11:01 am

I've got a Samba server on Fedora Core 3 which is fine to browse to and works ok, so I decided to try a debian server as well, I set up a very simple Debian stable system and samba, and the storage share is working fine, but I can't browse to it? I can open the share by ip address, so it seems to be a Netbios problem. I don't understand because I've been going over and over the smb.conf and comparing the two. The only difference is that Debian is using domain authentication and I used SWAT on it instead of hand editing like I did on Fedora. The smb.conf is shown below:

# Samba config file created using SWAT
# from (
# Date: 2005/06/01 17:38:23

# Global parameters
browseable = yes
workgroup = MYDOMAIN
server string = %h server
security = DOMAIN
encrypt passwords = Yes
obey pam restrictions = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
domain master = False
dns proxy = No
invalid users = root
admin users = hari
socket options = TCP_NODELAY

comment = All Printers
path = /tmp
create mask = 0700
printable = Yes
browseable = No

browseable = yes
public = yes
comment = Storage
path = /STORAGE
valid users = me
read only = No

Also, on Fedora, I've noticed, I can't ping any windows systems by hostname either, although they can ping me by hostname. Both systems have nmbd and smbd running. Both these machines have their hostnames set as well as other general networking settings(ip,gw,netmask,broadcast etc). I must have missed something. Anyone help?
Posts: 71
Joined: Fri Jun 03, 2005 10:56 am

RE: Samba Netbios Name Resoluion Problem

Postby Nigel » Fri Jun 03, 2005 1:34 pm

I notice you haven't got it set to be the DOMAIN MASTER. Presumably you have another (Windows ?) machine that performs this function. Does that machine know about your Debian box ? Try putting it's name and IP address into the hosts file on the Domain Master (don't know if this will work, but it shouldn't cause any harm & is worth a try...)
Hope this helps,

LXF regular
Posts: 1141
Joined: Fri Apr 08, 2005 8:03 pm
Location: Gloucestershire, UK

RE: Samba Netbios Name Resoluion Problem

Postby youlikeicecream » Fri Jun 03, 2005 2:21 pm

You could try joining the domain. that would register your computer in the Domain whether it is running a server or not. I used " net ads join -w myworkgroupordomain" and that did the trick in Mandriva2005LE, havent tried in Kubuntu. Did not get this working in Redhat 9. - Good Luck
LXF regular
Posts: 721
Joined: Fri Jun 03, 2005 11:40 am
Location: Oxford

Postby humbletech99 » Mon Jun 06, 2005 9:32 am

It's already a member of the domain, and as seen in smb.conf, I'm already using domain authentication which works fine, a little slow to authenticate initially, but it works.

The problem is that I can't even ping the debian box by name and I can't find out why.

The fedora box i've got works fine, but there is barely any difference between the configs, apart from using domain authentication on debian and user authentication on fedora.
Posts: 71
Joined: Fri Jun 03, 2005 10:56 am

Postby M0PHP » Mon Jun 06, 2005 10:05 am

First try adding "netbios name = SambaServer" into the global section of smb.conf where SambaServer is the hostname of the server. Also on the client's side when you can ping by IP address but not by name - try adding the hostname to the /etc/hosts file and see if that cures it, and see what /etc/resolv.conf says about DNS.
LXF regular
Posts: 737
Joined: Wed Apr 06, 2005 7:40 am
Location: Bishop Auckland, County Durham, UK

Postby Guest » Tue Jun 07, 2005 9:43 am

Tried all that. Didn't work.

I've now fixed it. I changed the socket options by adding two parameters for SO*BUF options and that seemed to fix it. That was one of the last tiny differences between my Fedora and Debian configs.

Thanks for your help, it really helped me troubleshoot. I appreciate it. :)

Return to Help!

Who is online

Users browsing this forum: No registered users and 1 guest