Wireless internet through access point

For discussing Linux compatible (or not) devices

Moderators: ChriThor, LXF moderators

Wireless internet through access point

Postby guy13 » Thu Aug 10, 2006 8:53 pm

Hello ladies and gentlemen,

Can anyone shed some light on the following problem?

Last week I've had wireless internet installed on a desktop running XP. Friday I went out and bought me a Wireless LAN PC Card for my laptop (multiboot XP, Gentoo 2005.0, SuSE 10.1, Mandriva and Ubuntu) and I've been struggling ever since to get online with it.

My setup:
Laptop: Toshiba Satellite 1410-604
Wireless Access Point: D-Link AirPlus G+ DWL-2000AP+ Access Point (it's an AP, not a router... some people on a local forum suggested that would be the problem and the solution was chucking out a brand new € 99,- AP and buying a router instead. I'm sort of hoping someone here has a cheaper idea.)
Wireless PC Card: Topcop Skyr@cer Pro PC Card 3054 (identified as Global Sun AR5212 802.11abg NIC by Yast) with Atheros chip (seems to work fine after downloading and installing madwifi)
Distro for this purpose: SuSE 10.1

The NIC works apparently since I'm able to reach the AP with the static configuration IP and make changes in the AP's setup. However when I switch to dynamic IP I don't get a valid IP. Enabling the AP to function as a DHCP-server doesn't help: my linux box then gets an IP from the AP's range whereas my windows box gets an IP from a totally different range. Finally today I went back to the shop where I bought the NIC and was told to reset the modem. After doing that I got a valid IP on my laptop. I was able to ping the ISP's name server's IP but neither Firefox nor Konqueror could get online. What's more my windows box wasn't able to make a connection any more either. I then took a giant leap of faith as there was one more setting on the AP that I hadn't yet tried to alter: it has itself a static IP which can be set do dynamic. It seemed a logical thing for the AP to have a dynamic IP and then to work as a DHCP-server. However, it wouldn't allow me to set it's IP to dynamic while it was set as DHCP-server and of course as soon as I switched it to having a dynamic IP for itself I couldn't reach it anymore when it turned out that this was in fact not the solution to my problem. After a lot of swearing and sweating and resetting both modem and AP I'm now back at the situation where I have a (sometimes dodgy) connection on my windows box and no connection on my linux laptop.

This is the output of dmesg after hotplugging the NIC:

pccard: card ejected from slot 0
pccard: CardBus card inserted into slot 0
PCI: Enabling device 0000:03:00.0 (0000 -> 0002)
ACPI: PCI Interrupt 0000:03:00.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
wifi0: mac 7.9 phy 4.5 radio 5.6
wifi0: Use hw queue 1 for WME_AC_BE traffic
wifi0: Use hw queue 0 for WME_AC_BK traffic
wifi0: Use hw queue 2 for WME_AC_VI traffic
wifi0: Use hw queue 3 for WME_AC_VO traffic
wifi0: Use hw queue 8 for CAB traffic
wifi0: Use hw queue 9 for beacons
wifi0: Atheros 5212: mem=0x24000000, irq=11
ath0: no IPv6 routers present

The last line sounds like an error message to me. Should I somehow install IPv6 routers? If so: how?

The output of ifstatus ath0 reads like this:

ath0 device: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
ath0 configuration: wlan-id-00:03:2f:29:39:4c
ath0 dhcpcd is still waiting for data
ath0 is up
11: ath0: <BROADCAST,MULTICAST,NOTRAILERS,UP> mtu 1500 qdisc noqueue
link/ether 00:03:2f:29:39:4c brd ff:ff:ff:ff:ff:ff
inet6 fe80::203:2fff:fe29:394c/64 scope link
valid_lft forever preferred_lft forever

ath0 IEEE 802.11g ESSID:"wifi42" Nickname:"linux"
Mode:Managed Frequency:2.437 GHz Access Point: 00:15:E9:10:BE:04
Bit Rate:12 Mb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:4158-5133-39 Security mode:open
Power Management:off
Link Quality=18/94 Signal level=-77 dBm Noise level=-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Any help is wellcome. D-Link devices are quoted in many places as working fine with Linux (even though the company's own website claims the OS is not supported) so I'm hoping there's a way to make AP and NIC play together nicely.

Thanks in advance,

Posts: 59
Joined: Wed Apr 13, 2005 7:39 pm
Location: Belgium

RE: Wireless internet through access point

Postby wyliecoyoteuk » Fri Aug 11, 2006 7:11 pm

I have a similar issue, my AP does not pass through DHCP replies.
(to linux, anyway)
I have had this issue oon 3 different APs.
Workaround, set IP address and gateway, DNS manually.

IP address outside the DHCP scope, in the same subnet, e.g. IP address=, gateway =, DNS= (if you are using XP with Intenet connection sharing, is the only valid internal IP address for the ICS PC).
Make sure that there is no firewall blocking the internal address.

Of course, how it is set up makes a lot of difference.
What exactly do you mean by "wireless internet" on the desktop machine? is it connected to a wirelss card and an ADSL modem with bridging set up for example?

It might help to disable IPv6, as that seems to be cause of the problem.
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
User avatar
LXF regular
Posts: 3525
Joined: Sun Apr 10, 2005 10:41 pm
Location: Birmingham, UK

Postby guy13 » Sat Aug 12, 2006 8:52 am

Thanks for the reply, wyliecoyoteuk. Unfortunately I'm afraid my whole quest may have been in vain.

I went back to the shop where I bought the NIC and they told me that I should first enable the AP as DHCP-server and then reset the modem and all should work fine. This again didn't give the necessary result. I then called the ISP's help desk and was told that with my installation (contrary to what the man who sold me the subscription had told me and what the installing technician had confirmed) it is probably impossible to get an IP which is then split up for different computers. I don't see why so I'm gonna give your suggestion one last go. (The helpdesk said that all I could do by resetting the modem is transfer the one IP address from the desktop to my laptop. That's what I have been able to do: 84.197.-.- on my laptop and on the desktop but then neither allows me to surf.)

As for your question: "wireless internet installed on a desktop" is the most basic broadband (512Mbps) through a Motorola Surfboard cable modem (SB5101) which then goes wireless through an Access Point. It comes with an "internet for everyone" inintiative of the government (cheap computer, cheap subscription - right -, tax deduction...).

About your work around, do you mean: set the AP as DHCP-server and then give my laptop a static address (e.g. If this is the case then I assume the desktop should be or something similar? Should gateway and DNS-server both be Isn't the DNS-server supposed to be an external address? I'll try a few combinations and let you know what happens.

Finally, are you sure I have to disable IPv6? It's just that the startup scripts always say at some point that IPv6 is being disabled already. It looked to me that I should somehow enable it but I don't know where or how.
Posts: 59
Joined: Wed Apr 13, 2005 7:39 pm
Location: Belgium

Postby linas_lietus » Thu Aug 31, 2006 7:20 am

Hey there - have you sorted out?

I might help you to proceed, if you still need it.

Essentially, I would second for getting rid of ipv6 firsthand: came over your post while trying to recall procedure to disabling it myself, as it well helped me before, and after yesterdays kernel update I have to review setup of additional modules for my madwifi wireless driver, which shows interface with ipv6 and tries to get trough with it (not sure it equally tries for ip). That´s where dual boot helps ;-)

As to your problem, you should ensure your desktop and laptop both are going to participate on the same subnetwork, i.e. something like 192.168.0.x - you can assign addresses manually, or better set DHCP range of addresses (pick some high end interval like 200-250), but not forget, that wireless is passing walls etc., so later think again about security aspect. Make sure both computers are set to ackquire dynamic address (dhcp). If you are able to ping, but not get trough with internet names - this should be DNS issue, and you either have to configure AP DHCP to inform about proper DNS servers your DHCP clients, or stuff both computers with DNS of your ISP. AP itself better be configured with static IP, that can get to your modem, though in theory, DHCP client part of it also should grab address, but occasionally I hear clients NOT being possible to grab address from otherwise working network with some AP device.

As to linux/windows compatibility: TCP/IP level should be absolutely independent to OS, just have driver for your wireless clients. If AP has web configuration interface - it can be both used AND tuned from wherever.

Let me know, if you need further help and your situation, or post here your findings, as other people might also be poking how your case was set.

Posts: 1
Joined: Thu Aug 31, 2006 7:05 am

Postby guy13 » Thu Aug 31, 2006 3:25 pm

Thanks for your reply.

No, I haven't sorted it out yet and I would like to get it working so thanks for offering your assistance. However I'm leaving on holiday tomorrow so I don't have time to tinker tonight. I will get back to you when I'm back home on 20 September (and probably after trying your suggestions).

Catch you later,

Posts: 59
Joined: Wed Apr 13, 2005 7:39 pm
Location: Belgium

Postby wyliecoyoteuk » Fri Sep 01, 2006 7:57 pm

Sorry not to reply sooner, been on holiday.
If you are using a surfboard, you will need a router of some sort.
You have a choice:
Buy a router which will do the NAT, DHCP, etc for you, they cost from about 50 euros, and connect your surfboard and AP to that.
Or, set up one iof your PCs as a NAT router. this is free, but that PC will need to be switched on and connected to the surfboard for your other machine to connect, and you will need 2 network cards, one to connect to the outside world, and one to connect to your internal network.
Windows PCs will do it with ICS (Internet connection Sharing) Linux PCs will do it through NAT routing.
It is theoretically possible to do this with one network card, But I could never get it to work satisfactorily.
The problem is that the cable modem is deliberately restricted and will only allow one MAC address (or network card) to connect at any given time.
A router allows that one connection to be shared, an AP does not, sorry.
Or, you could pay your Cable supplier an extra monthly fee to allow more than one connection.
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
User avatar
LXF regular
Posts: 3525
Joined: Sun Apr 10, 2005 10:41 pm
Location: Birmingham, UK

Postby tmerritt » Wed Sep 06, 2006 12:13 am

I've just experienced an 'oh my God' moment!

Kit = Packard Bell Chrom@ laptop - Netgear WPN511 card (connecting to a Netgear DG834PN router) - Zenwalk 2.8 using ndiswrapper.

I used these instructions until the dmesg section.

I had to copy the .sys file from /etc/ndiswrapper/netpn511 directory to the /etc/ndiswrapper/wpn511 directory.

Then this file
Translated instructions
shorter link

Sorry about long link.

Turned off my encryption,ran script, et voila - I'm on!
Hope this might be some help
Posts: 1
Joined: Wed Jul 26, 2006 11:58 am

Postby Rhakios » Wed Sep 06, 2006 6:38 pm

Bye, Rhakios
User avatar
Posts: 7634
Joined: Wed Apr 06, 2005 11:18 pm
Location: Midlands, UK

Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests