iwconfig not setting essid

The place to post if you need help or advice

Moderators: ChriThor, LXF moderators

iwconfig not setting essid

Postby gav » Sat Apr 09, 2005 11:33 pm


OK the problem is ive just upgraded my adsl wireless router to a D-LINK DSL-D604T, on setting up this router i set up the wireless essid and WEP key as per my previous WAP.
I'm running fedora core 3 on my acer laptop with a broadcom wireless card
with it also dual booting to XP.
When i boot to XP the wireless connection works just as it did before i chanegd my router, however when i boot to linux the wireless connection dosnt come up. nothing has changed on my linux config which is using ndiswrapper 0.9.
The problem seems tobe that the essid is not taking on iwconfig, ive tried adding it manually via iwconfig wlan0 essid <my_essid> but it never shows my_essid on the output of iwconfig wlan0.
i tired a iwlist wlan0 scanning and this does seem to detect the essid correctly,
i also ensured that iwconfig was using the right channel.
after all this the wlan0 still dosnt come up.

My point in short being that if my config hasnt changed and the connection works in windows, what could it be that linux dosnt like :/

Any help appreciated,
Posts: 1
Joined: Sat Apr 09, 2005 11:22 pm

RE: iwconfig not setting essid

Postby Guest » Sun Apr 10, 2005 7:32 am

ndiswrapper never worked with me on a broadcom driver - where i had a pcmia laptop belkin card and even when i inserted a card and installing the drivers it still didn't work. It would be greatful if Linuxformat could do a small article on it in the back page as i have tried to many times...

RE: iwconfig not setting essid

Postby marlight » Mon Apr 11, 2005 8:16 pm

It's been a while since I last had to fiddle with this, so I'm working from memory.

So, the WiFi was working before, but stopped when the router was changed.

I think that the answer may lie in "iwconfig key". You're probably using this (or it's alias "iwconfic enc") already to set the WEP key.

If memory serves, try doing a sequence of commands along the lines of:

iwconfig key open
iwconfig key InsertWEPKeyHere
iwconfig essid MYESSID

And this may just work out of the box.

On a distro related note, I've had hold of a couple of Acer laptops recently. I'm typing this in on a Travelmate 382tmi which has a Centrino ipw2200 wifi chip in it. I think the previous Acer was a Travelmate 2304, which had the Broadcom device in it. In both cases I installed Ubuntu (Warty on the 2304, Hoary on the 384), and the WiFi card worked out of the box.

If the earlier tip didn't solve your problem, maybe you could try booting the Ubuntu 5.04 Live CD and see how that configures the WiFi? The King Of HArdware Detecting Live CDs, Knoppix, may be another one that you could try. The idea being that you could see how the wifi gets configured without killing your FC3 installation.

Hope this helps...
Posts: 6
Joined: Mon Apr 11, 2005 7:52 pm

Return to Help!

Who is online

Users browsing this forum: No registered users and 1 guest