Simple user can't to access a NTFS plugdev-owned partition

The place to post if you need help or advice

Moderators: ChriThor, LXF moderators

Simple user can't to access a NTFS plugdev-owned partition

Postby oliver » Tue Aug 12, 2014 7:51 pm

Dear all,
Please note that French is my mother tongue, so I'll do my best here...

A new user (actually myself) created with a "Custom" account under Ubuntu 14.04 cannot access an NTFS partition (owner=root), even after having included this user in the Root and Sudo groups, while logged in as Administrator.

Unfortunately, Mayank Sharma's tutorial in LXF 187 p.68 doesn't help me. And Nick Peers's by the way superb tutorial on how to escape Windows (LXF 187 pp.33-39, largely inspired by a mail I previously sent to Matt I think) takes the perspective of a single-account system (not 2 accounts); so I'm puzzled.

I don't know Linux well, and all these concepts of accounts, permissions, etc, sound Greek to me. But LXF helps (sometimes ;-)

I have a fresh install of Windows 7 pro (because I have to) + a separate NTFS partition labelled as DATA. I am in the perspective of ONE person using ONE computer, but with (at least) TWO accounts on linux (admin, user) - or at least, that's what I try to do...
I made a DUAL BOOT system with Ubuntu 14.04 (which will be my everyday OS), and I would like the /home to be mounted on the NTFS "DATA" partition (=sda5). I would like that DATA partition to be "shared" by both Win7 and Ubuntu, alternatively, to store my datas (exactly the perspective of use I suggested in my email - thanks!)
I have made a fresh install of Ubuntu14.04. During the installation process, and *because* that DATA partition is sda5-NTFS-formatted (and has to be), the Ubuntu installer offered me to mount either /windows or /dos on it (not the nice "/home" option, unfortunately, as it does for an ext4 partition). I choosed /windows to be mounted on it.

We're told that it's dangerous to use an Administrator account on a daily basis. I thought that the account created during the installation process would be an administrator account (actually it turned out to be a 'Custom' account, as Ubuntu calls it - but then, where is the *default* admin account?!). I therefore (mis-)named it "administrator". Afterwards, I created a 2nd account while I was logged in with the misnamed "administrator" account. I called that 2nd account "oliver"; it's a Custom account. My idea was that I would use the 'restricted' oliver account for everyday use. But I realised quickly that, while logged in as oliver, I could not sudo anything, so impossible to sudo apt-get install anything (event when typing the administrator password!). Then I logged in as administrator to add oliver in the sudo Group. It worked out: as oliver, I can update/install, etc.

But there is a SECOND PROBLEM, and this one is very serious - (HELP! please):
logged in as 'oliver', I cannot access that DATA ntfs partition on which /windows is mounted: "you don't have the permissions...". So without acces to it, needless to say that I have not even *tried* the trick Accessing Your Documents (LXF187 p.37), in the same tutorial, which uses Ubuntu Tweak. I want 1rst have access to it before I go further.

To give you a little bit more input:
logged in as administrator, if I ls /dev/sda5 (=the DATA ntfs partition), I see that sda5 belongs to root. Naïvely, I included oliver in the root group. Then logged out the 2 accounts, then restarted(!) the laptop (to be shure). No change: oliver has no acces to /windows (=sda5, labelled as DATA).
Then I ls -l /windows (as administraor): I get:
drwxrwx--- root plugdev $RECYCLE.BIN // a Windows system directory
drwxrwx--- root plugdev System Volume Information // idem
(NB: that ntfs sda5 /windows partition is still empty: fresh install...).
I included oliver in the plugdev group: again, no change: oliver has no acces to /windows (=sda5, labelled as DATA) -- but wait! Maybe I have to log out first: I post this message first, then I come back with the result...

But I feel I am giving more and more permissions to oliver in order to make it able to what I need as an everyday user: is it normal? Is oliver still an 'average' user with restricted permissions (it's now memeber of the root, sudo, plugdev groups)?
Posts: 6
Joined: Fri Dec 20, 2013 10:34 pm

It works!

Postby oliver » Tue Aug 12, 2014 8:21 pm

I'm back:
I included oliver in the plugdev group, then logged out and RESTARTED THE SYSTEM: it works.
oliver now can access the /windows mounted on the NTFS sda5 partition.
But what an odyssey (for a newbie)!

And I had to give more and more permissions to oliver, which is now memeber of the following groups (non-comprehensive list): sudo, root, plugdev.
Should I exclude oliver from the root group (in which I included him in my despaired attempts to give him acces to /windows)?

I will now try the trick with Ubuntu Tweak to make the /home 'point' on the sda5 NTFS partition. But wait: /windows is *already* mounted on that sda5. is it a problem?

How can make administrator (= me with privileges) able to access to the directories of oliver (= me with restricted permissions, or supposed to be...), which will soon be on the NTFS partition (if the Ubuntu Tweak works)? Because if I have to make a screenshot logged in as administrator, I want to be able to paste it im my olivers's Document in order to share it afterwards with someone online: it is only as oliver (Custom account) that I connect to the Web, via a virtual machine...


Posts: 6
Joined: Fri Dec 20, 2013 10:34 pm

Return to Help!

Who is online

Users browsing this forum: No registered users and 4 guests