NAS Box Permissions Help [solved]

The place to post if you need help or advice

Moderators: ChriThor, LXF moderators

NAS Box Permissions Help [solved]

Postby Fat_Tuesday » Mon Aug 04, 2014 6:52 pm

Hi all, I'm having problems copying files on shares hosted on an Iomega Home Network thingy using Ubuntu 14.04. I can read them no problem but can't copy or paste the directories / files (but I can using Vista (the shame)). I'd rather stick with Ubuntu because I'm using fdupes to consolidate my poorly arranged archive.

The NAS box is set up with one User account, which doesn't prompt me for creds if I view files using Nautilus, but does if I use the web interface. I would use the web interface for everything if it wasn't very very slow (we're talking multi-GB sized directories).

Running ls -l on the main directory gives me this:

drwx------ 1 gadgebuntu gadgebuntu 0 Jun 20 2013 Adobe_2_Full_Dec_11

This *suggests* to me that I have Ownership to RWX but I get nowhere when I try. A few abortive attempts to chown, chmod and chgrp have been exactly that, permission denied even as root. As you can probably tell I'm clutching at straws.

I guess I'm missing something fundamental but don't know what. Would any of you be able to assist, please?

Last edited by Fat_Tuesday on Mon Sep 29, 2014 8:32 pm, edited 1 time in total.
Posts: 98
Joined: Mon Oct 09, 2006 12:14 pm

Postby Dutch_Master » Tue Aug 05, 2014 2:08 am

How are you accessing the shares, via NFS or Samba? Are the shares visible from the web? (that is, if you're not home, can you access them remotely?) If you can, lock your firewall (in the router, I assume) completely and start pumping your data to a separate disk for safekeeping. Once done, wipe the NAS and re-install a known safe image of the OS, 'cause you may have been hacked :o :(

If you can access the data, you can redirect it, via pipes if necessary, to another disk using the cat command.
Code: Select all
cat <filename> > /path/to/new/disk/<filename>

Mind, it's a bit messy and may not work for everything. Perhaps more useful is the dd command:
Code: Select all
dd if=/path/to/<filename> of=/part/to/new/disk/<filename>

It's usually used for copying bootable cdrom images to disk, but it works just as fine for individual files or directories.

All of the above commands are done on the NAS.

LXF regular
Posts: 2586
Joined: Tue Mar 27, 2007 1:49 am

Postby Fat_Tuesday » Tue Aug 05, 2014 6:00 pm

Hi DM, thanks for the response. As far as I'm aware, the NAS isn't outward facing, it's just available on the home network and not accessible from the www. Its cloud services are turned off and security is on. The home network sits behind a security-enabled bt home hub.

I'm connecting to the NAS either through the web interface on 192.168.x.x (which prompts for a login) or using Nautilus, which doesn't. Samba is installed on my system and NFS isn't as far as I can tell.

This isn't a show-stopper for me as Vista sees the shares and lets me RWX as I please, I just wish I could get 'buntu to do the same :-).
Posts: 98
Joined: Mon Oct 09, 2006 12:14 pm

Postby Rhakios » Tue Aug 05, 2014 9:21 pm

To be honest, the fact that Nautilus lets you view files without submitting any credentials (or apparently engaging in any special set-up procedure to allow you to do that) is good enough reason to suspect that you don't really have permission to modify the files.
However, I am not familiar with the Iomega Homedrive, so I can't really comment further.
Knowing what protocol Nautilus is using to access the files would be of some help.
Bye, Rhakios
User avatar
Posts: 7634
Joined: Wed Apr 06, 2005 11:18 pm
Location: Midlands, UK

Postby nelz » Tue Aug 05, 2014 9:41 pm

Did Nautilus ever ask for a password? It is conceivable that it gave it once and saved it for future use.

Can you access log files on the NAS? They may give a clue as to what is going on.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
Site admin
Posts: 9041
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby Fat_Tuesday » Wed Aug 06, 2014 6:26 pm

Ah well, I've done something but don't know what (the eternal lament of the Useless). Nautilus is now prompting me for a username and password to access the box but it's not being accepted when I put it in :-). I can still access it thru the web interface on Ubuntu and using win explorer on Vista.

As for whether Nautilus is using samba or not, how do I tell?

Anyway, I have a workaround albeit a slow one. Thanks for your help everyone!
Posts: 98
Joined: Mon Oct 09, 2006 12:14 pm

Re: NAS Box Permissions Help [Solved]

Postby Fat_Tuesday » Mon Sep 29, 2014 8:26 pm

It's been months but a hard disk wipe, the complete destruction of Vista and a fresh install of ubuntu led me to look at this again.

And I've cracked it - it only took half a bottle of wine, too!

Long story short, I found this site and with a fair amount of faffing about got access to all my shares using CIFS.

Hooray for knowledge and vino!!

Now all I need is a magic bullet to get photoshop elements 12 working under wine [grabs bottle].
Posts: 98
Joined: Mon Oct 09, 2006 12:14 pm

Return to Help!

Who is online

Users browsing this forum: Google [Bot] and 3 guests