rosa & e156g dongle

The place to post if you need help or advice

Moderators: ChriThor, LXF moderators

rosa & e156g dongle

Postby fatalbert » Fri Apr 11, 2014 10:14 pm

Hello. I want to use Rosa OS, but my only connection to the internet, is through a Huawei E156G mobile dongle from 3. Rosa just cannot "see" it. In network connections the "mobile connection" is greyed out, so I cannot set up a connection. I am a complete novice with Linux, & am self taught at Windows (sorry I'll try not to use that word again). Any help would be most gratefully received. (Too stressed out now, so trying to get some sleep). Thanks.
Posts: 3
Joined: Fri Apr 11, 2014 9:52 pm

Postby arochester » Sat Apr 12, 2014 8:54 am

So how are you connecting to the Internet now?

On the SUSE Forum there is a suggestion
The easiest thing is to do a network connect with ethernet, install the UMTSMON from software search and then try with wireless. No ethernet connect available? You may also download the rpm on a usb stick from software search and install it with yast once switched to Linux again. ... nnection-(

Can you get it on a USB stick? OK, Rosa is based on Mandriva which has a package manager called urpmi (not yast), but this uses .rpm too.
Posts: 82
Joined: Wed Oct 15, 2008 7:08 pm
Location: Scotland

Sorry but I don't understand

Postby fatalbert » Sat Apr 12, 2014 2:52 pm

Hello arochester. Thanks for replying to my question. I'm connected to the internet using the E156G, & Win 7. I just plug it in, click a couple of buttons & off it goes with Windows. I'm afraid I don't understand your instructions in your reply. Any instructions have to be dead simple, as I say, I know nothing about Linux, although I much prefer it to Windows. If only it was a case of just using a GUI & off you go.
Posts: 3
Joined: Fri Apr 11, 2014 9:52 pm

Postby towy71 » Sat Apr 12, 2014 7:17 pm

can you plug it inad run
Code: Select all
from a terminal?

If the dongle is recognised then follow the instructions from here looks really simple 8)

sorry there isn't a gui but it is normal for a proper OS :wink:
still looking for that door into summer
Posts: 4317
Joined: Wed Apr 06, 2005 2:11 pm
Location: wild West Wales

solution found

Postby fatalbert » Mon Apr 14, 2014 9:11 am

Thank you for your reply. I especially liked the reference to a "proper OS", very good.
Accidently, I've found another solution. I tried a newer dongle, the e3231(?), (I cant see without taking the back off, & then I lose the connection). Anyway, this dongle has all the drivers onboard, so isn't reliant on the OS, & so just connects to the net automatically. Only problem now is Rosa got half way through installing, & just stopped. Mint 13 installed instead. Many thanks to all who tried to help.
Posts: 3
Joined: Fri Apr 11, 2014 9:52 pm

Postby ferrari » Tue Apr 15, 2014 3:25 am

No, Linux drivers are not onboard. If it works at all, it is because Linux has the kernel drivers built-in. Usually there is some configuration required to connect though.
LXF regular
Posts: 174
Joined: Tue May 03, 2005 11:09 am

Return to Help!

Who is online

Users browsing this forum: Bing [Bot] and 3 guests