ASUS N70S Laptop trouble with Mint

The place to post if you need help or advice

Moderators: ChriThor, LXF moderators

ASUS N70S Laptop trouble with Mint

Postby Slip » Tue Mar 26, 2013 11:45 am

I've been using Linux for 14 years, and this is the first time in a long time I've needed help.

I have about a dozen computers all running Mint. The exception is my wife's ASUS N70S laptop. Last year when I left Mandriva in favor of Mint, I couldn't get her laptop to boot the Mint live CD, so I gave her OpenSuse 12.1 instead.

A few days ago after I did a routine update, the system wouldn't run X11, except in failsafe. I assumed it had upgraded the kernel, since it asked for a reboot, so I reinstalled the NVidia driver. This didn't work. I'd really rather she had Mint anyway, since the odd system is harder for me to admin.

So I tried Mint (14) again, and it still won't boot. Watching the messages, I see:
EISA: Cannot allocate resource for mainboard
EISA: Cannot allocate resource for EISA slot 1
(repeats for each slot through 8)
EISA: Detected 0 cards
(eleven more lines of messages, then:)
Key type encrypted registered

That last line is where it hangs.

I've tried various boot options, such as nomodeset, xforcevesa, nouveau.modeset=0, vga=0x314, vga=788 (separately of course), and still get the same result. I've also tried using some of the options from other distros that will boot successfully, but nothing works.

OpenSuse 12.2 from LXF164 boots up just fine, as do the following:
from LXF162: Mageia, PCLinuxOS, Arch64, Debian Live.

These all fail, most giving an immediate gray screen:
Fedora 18 (LXF169), then from LXF162: Fedora Live, Mint Cinnamon Live, CentOS, System Rescue CD (various options, all failed), Ubuntu Live; and Fuduntu from LXF168.

Is there something I can do to make Mint 14 KDE run on this machine? Any help will be greatly appreciated.
Posts: 7
Joined: Mon Feb 27, 2012 10:12 pm

Re: ASUS N70S Laptop trouble with Mint

Postby lchazl » Sat Sep 14, 2013 6:08 am

I have the same laptop (well N70sv) and had the same problem. I am one step further, I was reading and they said to log into the bios and disable your "New interface card"

I didn't have that option but I tried disabling all other devices until I narrowed it down to the Wireless LAN.

I disabled that and it let me into the Linux Mint logo screen fade in and then it gives the error "mount: could not find any free loop device"

And that's as far as I can go.
Posts: 2
Joined: Fri Sep 13, 2013 5:10 pm

Postby lchazl » Sat Sep 14, 2013 12:44 pm

Ok I did a few things, i updated my bios, changed my usb install to fat32, and chose for my booting all is working! Beauty.

I would say fat32 usb was the culprit in my opinion.
Posts: 2
Joined: Fri Sep 13, 2013 5:10 pm

Postby Slip » Sat Sep 14, 2013 9:31 pm

I've decided this ASUS N70S must have memory going bad in the GPU. I have only been able to get a very few Linux OSs to boot and/or install. It is currently running PC-Linux OS, somewhat successfully, although it displays strange video artifacts on a regular basis.

Overall, I would not recommend this laptop. It's been a pain, even when it was new.

It's okay with me if this thread is considered "closed".
Posts: 7
Joined: Mon Feb 27, 2012 10:12 pm

Return to Help!

Who is online

Users browsing this forum: No registered users and 1 guest