Fedora 18 cube dewsktop not flipping

The place to post if you need help or advice

Moderators: ChriThor, LXF moderators

Fedora 18 cube dewsktop not flipping

Postby stuarte9 » Tue Mar 05, 2013 4:58 pm


I downloaded the 32-bit Fedora 18 DVD iso from the official Fedora web site and installed it without any problem. However, the cube desktop wont animate.

I've checked System Settings/Desktop Effects and Desktop Cube & Desktop Cube Animation are both selected, but the cube just wont flip.

In Desktop Settings/Desktop Effects/Advanced (tab), the Compositing type is XRender and the Qt Graphics system is Native.

When I try to change Compositing type to OpenGL and click Apply, the system reverts back to XRender.

Do I need to install Compiz ?

If so, are there any particular plugins for Compiz that I should install as well ?

My PC uses an nVidia GForce fx5200 graphics card with 256MB onboard RAM.

System Information gives the following under Display Info.

Vendor: VMware Inc.
Model: Gallium 0.4 on llvmpipe (LLVM 0x301)
Driver: 2.1 Mesa 9.0.1

Prior to this I used Fedora 15. There, all that was necessary to flip the cube desktop was to move the mouse pointer to the edge of the screen. With F15, I was using the Nouveau NV34 driver and desktop flipping worked just fine.

Do I need to replace this VMware driver with the Nouveau driver ?

If so, how do I do that ?

Thanks in advance for any help you may be able to give with this.

Posts: 75
Joined: Mon Mar 08, 2010 5:03 pm
Location: Scotland

Postby dizwell » Wed Mar 20, 2013 2:59 am

If your system reports that it's using VMware hardware, than we can guess that you are running Fedora 18 in a virtual machine. Correct?

For a VMware virtual machine to be able to do desktop effects (including the desktop cube), the *host* machine needs to have proper 3D accelerated graphics installed and working. For example, if you were running VMware on a host machine that was itself running (say) Ubuntu, then unless you'd got desktop effects working in the *physical* Ubuntu installation, you would not be able to get a virtual machine running on it to do desktop effects.

So, what's your host operating system? And what are the desktop graphics like in it? Are desktop effects working on it?

In my experience, even though VMware has an option to allow a virtual machine to do 'Accelerate 3D Graphics' (under Settings -> Display when the VM has been highlighted and right-clicked), it seldom works for guests properly. Windows VMs, even on my Fedora 18 laptop that does have 3D acceleration working properly, for example, are never able to do Aero graphics and always return a graphics score of 1 (or don't allow an experience index to be calculated in the first place).
Posts: 61
Joined: Tue Aug 02, 2005 11:05 pm

Postby stuarte9 » Wed Mar 20, 2013 11:59 am

Hi Dizwell,

Thanks very much for the reply. No, I'm not using a VM of any kind. I performed a normal install direct to my HDD. It is this copy/version(?) that is not operating as it should.

I kind of expected to be using the Nouveau/NV34 driver for my (admittedly old, by today's standards) nVidia GForce FX5200 graphics card with 256 MB onboard RAM. This had absolutely no problem with desktop effects with my immediately previous version of Fedora, F15. That being the case, and as I run what I believe is a fairly standard desktop, I haven't had the need to upgrade the graphics card.

Do you know how to revert this installation to the Nouveau/NV34 driver or even the official nVidia driver?

Thanks again.

Best regards,

Posts: 75
Joined: Mon Mar 08, 2010 5:03 pm
Location: Scotland

Return to Help!

Who is online

Users browsing this forum: No registered users and 1 guest