-AGP- graphics card?

For discussing Linux compatible (or not) devices

Moderators: ChriThor, LXF moderators

Postby SiriusHardware » Tue Oct 23, 2012 6:32 pm

el chapulín wrote:You installed fglrx, so now you need to remove it as follows:

Code: Select all
# aptitude purge ~nfglrx

fglrx overwrites some core xserver files, in testing/unstable there are special packages which handle this, I can't remember if this has been implemented in squeeze. To be certain just reinstall the xserver, mesa and drm:

Code: Select all
# apt-get install --reinstall libgl1-mesa-dri libdrm-radeon1 libdrm2

Did you install the firmware? Check
Code: Select all
# apt-cache policy firmware-linux-nonfree

It should say "installed" and show you the version, if it says "(none)", install it.

Create an xorg.conf but first move any existing one to a backup file
Code: Select all
# mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

Code: Select all
# nano /etc/X11/xorg.conf

With these contents:

Code: Select all
Section "Device"
    Identifier  "card0"
    Driver      "radeon"

Section "DRI"
    Mode 0666

That last part will ensure users have permissions to access the DRI.

OK, from the above:
Uninstalled fglrx as instructed
Reinstalled the packages mentioned as described
The firmware was still installed
Made an xorg.conf (there was no existing xorg.conf)

Rebooted. Machine went straight into Debian desktop

Went to user terminal from desktop

result of 'glxinfo | grep render' from your earlier post is now

Code: Select all
direct rendering: yes
OpenGL renderer string: Mesa DRI R200 (RV280 5964)
20090101 x86/MMX+/3Dnow!+/ SSE TCL DRI2

glxgears also worked, reporting a rather ludicrous 400+ frames per second whilst rendering the gear animation in the default small window. When I expanded the window to full screen, it fell to a surprisingly consistent 60fps, which is the refresh rate of my screen, so there would be no point in exceeding that anyway.

All looked good - so I ran Oolite and noticed an immediate, enormous improvement. The only slowdown now is when the screen is entirely filled with planet surface and even then it's still more than 10-12 fps - not bad for a card which came out in the early noughties and a non-proprietary driver. Of course it helps that the 3D output from Oolite is authentically simple, just as in the game which inspired it.

So thanks for that, much appreciated - but I'd like to understand now what went wrong initially? I take it that installing fglrx (which no longer supports my card) also broke something that the Xorg driver needed in order to work? And would it never have worked anyway without the presence of an xorg.conf file? I wasn't aware I needed one until you brought it up.
Posts: 78
Joined: Tue Sep 25, 2012 6:41 pm


Return to Hardware

Who is online

Users browsing this forum: Bing [Bot] and 2 guests