No sound from Ububtu 11.10 and all derivatives

For discussing Linux compatible (or not) devices

Moderators: ChriThor, LXF moderators

No sound from Ububtu 11.10 and all derivatives

Postby kenmk » Wed Apr 11, 2012 3:03 pm

Sound is failing to work on any Live CD/Installation of Ubuntu 11.10 and all derivatives thereof.

It seems that the hardware detection is failing. I have an on-board sound card - Windows says AC97 from Realtec - and built-in speakers, but the only option on the Sound configuration that tries (and fails) to work is for headphones. There is another option which I think should work, but as soon as I try the Test Speakers option I am forced back to the headphone - no amplifier.

I have tried plugging in some amplified external speakers to the headphone socket - but still no sound.

The problem started after an in place update from Mint 11 to Mint 12. The mess this made was so severe that I had no sound from anything. Even a re-installation of XP had no sound until I added the original Compaq drivers!!!!!

Mint 11 is back and has sound with both on-board speakers and the external ones working.

The laptop is an old original Centrino machine from Compaq, a Presario B1800. Windows reports the sound card as a Realtec AC97 device.

How do I get recent Ubuntu releases to recognise this card properly?
Posts: 6
Joined: Sat Sep 27, 2008 9:11 am
Location: Rugby, UK


Postby kenmk » Tue Apr 17, 2012 6:43 pm

Since the first post I've installed the beta of Ubuntu 12.04. Something has changed, 'cos this has working sound. There must be some odd difference hidden away somewhere!!??
Posts: 6
Joined: Sat Sep 27, 2008 9:11 am
Location: Rugby, UK

Postby lok1950 » Tue Apr 17, 2012 8:00 pm

Likely in the kernel.

Enjoy the Choice :)
LXF regular
Posts: 1134
Joined: Tue May 31, 2005 5:31 am
Location: Ottawa

Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests