Fedora13 Adding access to parallel port

For discussing Linux compatible (or not) devices

Moderators: ChriThor, LXF moderators

Fedora13 Adding access to parallel port

Postby Cagere » Tue Jan 17, 2012 1:49 pm

Hi . I am trying to get an old parallel port printer (Canon BJC7000) to work on fedora13 but when I go into the add printer routine I am not offered an option to choose the parallel port. On another machine running fedora12 there is this option, but I need to get the printer working on the fed13 m/c.
Any suggestions welcome. Cagere
Posts: 50
Joined: Sat Jun 24, 2006 1:30 pm
Location: Norfolk UK

Postby ferrari » Thu Jan 19, 2012 10:52 pm

Yes, this will be because the 'lp' driver is no longer loaded by default at boot. Instead, for configuration purposes you can load it manually
Code: Select all
modprobe lp

You can make this persistent by following the advice here:

http://docs.fedoraproject.org/en-US/Fed ... stant.html

or alternatively

LXF regular
Posts: 174
Joined: Tue May 03, 2005 11:09 am

Postby Cagere » Wed Jan 25, 2012 3:02 pm

Hi Thanks Ferrari for your interest and any others who looked. I have solved the problem but am now having problem with a (Ferrari)red face. The motherboard in question was a fairly recent Asus M4N68T-m LE V2 which was in a machine purchased second hand via e-bay. It suddenly dawned on me that I hadn't checked the bios for any problems. Guess what! Both the parallel and serial ports were disabled(DUH). I suppose the previous owner was using a USB printer. Having sorted the printing problem I then set to configuring the machine for my 75 year old Sister in Law. Everything was working fine until yesterday morning when it complained of a keyboard error at boot time. This was followed on subsequent boots with an assortment of error messages.Eventually it did boot and looked fine so I left it running while I had breakfast. When I returned it had gone off and this time it didn't even start the fans etc. The only sign of life being the green standby warning LED. First thought was a power supply fault and as I had a spare I tried that with the same result. I checked the spare using an old M/Board and it was fine. So was the original, so I am now waiting for a replacement M/board. What Fun!!

Cagere in wildest Norfolk UK
Posts: 50
Joined: Sat Jun 24, 2006 1:30 pm
Location: Norfolk UK

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest