Broadcom card not working (Lenovo Ideamate)

For discussing Linux compatible (or not) devices

Moderators: ChriThor, LXF moderators

Broadcom card not working (Lenovo Ideamate)

Postby fede » Mon Aug 01, 2011 1:09 am

A while ago I bought a Lenovo Ideapd with a Broadcom wifi chip. At first, it would not play ball with Ubuntu 10.04, but after downloading the hybrid_wl driver and compiling the wl.ko module, things got on track. Afterwards, Broadcom apparently open sourced some (all?) drivers, so I was optimistic that things would be fine in future upgrades.

I skipped Ubuntu 10.10 for some reason, and last week moved to 11.04. Now the wifi chip works no more Evil or Very Mad

The messages in the (classic Gnome) network manager applet showed "device not ready" or "wireless is disabled by hardware switch". rfkill lists three devices, and it said that the brcmwl-0 one was soft- and hard- unblocked after the appropriate incantation, but that didn't help (the other entries are ideapad_wlan, unblocked, and acer-wireless, soft blocked, and hard unblocked - could never get both to be unblocked)

I tried the updated Broadcom driver, together with its patch for recent kernels, and it compiled all right, but the device is not ready, the led indicator blinks (or shuts off if I press the Fn-key to toggle wifi), and iwconfig lists eth1, as the wireless device, instead of wlan0, which makes me think the driver is not right.

Oh, yes, I had already downloaded the Broadcom drivers from the Ubuntu depositories, but they didn't work either. After installing the new hybrid_wl drivers I suspected there might be a conflict, so I uninstalled the sta, and bwl-cutter, stuff and, on reboot, the wifi indicator was steady, but it still did not work, and was still "wireless is disabled by hardware switch". Blocking/unblocking variously in rfkill, or more fiddling with the Fn switch, and it's back to indicator blinking or off (and still disabled by hardware switch, or device not ready).

I imagine that the solution should be devilishly easy (after all, it all worked with 10.04), but have no idea where to turn now. Any help?
LXF regular
Posts: 106
Joined: Thu Sep 01, 2005 3:23 am

Postby Dutch_Master » Mon Aug 01, 2011 3:04 am

Try unloading the module from the kernel with the rmmod command, then recompile the new driver and insert it with the insmod command. Did you do a
Code: Select all
make clean
before building the new module? If not, it might have been affected by stale config files from the previous build.

If it still fails, can you communicate with the blockdevice (wlan0, I see)?
Code: Select all
iwconfig wlan0
You may want to look at the dmesg log file when issuing commands to see what error messages get flung around. Open a 2nd root-terminal and copy/paste+enter
Code: Select all
dmesg | tail
to see the last 10 lines. (usually the most interesting. skip the " | tail" part if you need to see more)
LXF regular
Posts: 2592
Joined: Tue Mar 27, 2007 1:49 am

Postby fede » Sat Aug 06, 2011 9:48 pm

Thank you for your suggestions. I didn't have time to try things out until today, and here is what dmesg tells me when I try to mount the (closed source) Broadcom driver wl.ko:

[ 1891.089217] type=1400 audit(1312665317.995:23): apparmor="STATUS" operation="profile_replace" name="/usr/bin/evince-thumbnailer" pid=6121 comm="apparmor_parser"
[ 2136.940239] b43-pci-bridge 0000:02:00.0: PCI INT A disabled
[ 2434.509526] lib80211: common routines for IEEE802.11 drivers
[ 2434.509531] lib80211_crypt: registered algorithm 'NULL'
[ 2434.571999] wl: module license 'unspecified' taints kernel.
[ 2434.572041] Disabling lock debugging due to kernel taint
[ 2434.590509] wl 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 2434.590528] wl 0000:02:00.0: setting latency timer to 64
[ 2434.615521] lib80211_crypt: registered algorithm 'TKIP'
[ 2434.928020] eth1: Broadcom BCM4315 802.11 Hybrid Wireless Controller

Apparently, there is information about the license that is missing and the kernel balks. The module is still loaded, but it does not work.

Incidentally, going over dmesg at startup and looking for reactions to the b43 module doesn't seem to show any trouble (it quotes the 4312 model, rather than 4315, but I assume that the module would be the same), but it still does not work ("wireless is disabled", even though I checked "Enable wireless in Network Manager)

I am afraid I have no idea how this can be obviated
LXF regular
Posts: 106
Joined: Thu Sep 01, 2005 3:23 am

Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests