Touchscreen (wacom) and Debian

For discussing Linux compatible (or not) devices

Moderators: ChriThor, LXF moderators

Touchscreen (wacom) and Debian

Postby deane » Mon Mar 07, 2011 6:34 pm

I quite like my HP tm2 laptop - I had problems for ages with it getting hot, but after finally working out how to get the vgaswitcheroo to work in debian (mainly it was a case of putting the kernel modesetting variables in different places for both sets of drivers and then actually *loading* the damned drivers!) it runs rather cool now - cooler than windows 7, in fact.

Now I can almost abandon windows for regular use, except when using it as a touchscreen laptop.

Yes, the touchscreen works fine, but it lacks the finesse that the windows setup has. Touching it immediately classes as a tap, so there's no drag-scrolling. It's also not possible to right click by pressing and holding or pressing and right tapping.

I'm assuming there must be a set of variables somewhere in a config file for the X side of the wacom drivers, and possibly some add-on software the make the experience a little more polished?

Oh, and don't suggest going to Ubuntu - I've tried numerous recent versions and just prefer Debian.
Posts: 9
Joined: Sun Aug 01, 2010 9:03 pm

Postby Dutch_Master » Mon Mar 07, 2011 7:12 pm

You are aware that X doesn't support multi-touch events, are you?

As for the "touch = click" issue, did you try and change the repeat-delay settings? (how much time between to touch-events to be seen as separate taps)
LXF regular
Posts: 2592
Joined: Tue Mar 27, 2007 1:49 am

Postby deane » Mon Mar 07, 2011 8:46 pm

I wasn't aware that X couldn't do multitouch, but the X config file settings look promising.
Posts: 9
Joined: Sun Aug 01, 2010 9:03 pm

Postby deane » Mon Mar 07, 2011 10:18 pm

I've tried to tweak my xorg.conf, but it appears that my system is using /usr/share/X11/xorg.conf.d and contains 20-wacom.conf as below:
Code: Select all
Section "InputClass"
   Identifier "Wacom class"
# WALTOP needs a patched kernel driver, that isn't in mainline lk yet,
# so for now just let it fall through and be picked up by evdev instead.
#   MatchProduct "Wacom|WALTOP|WACOM"
   MatchProduct "Wacom|WACOM"
   MatchDevicePath "/dev/input/event*"
   Driver "wacom"

Section "InputClass"
   Identifier "Wacom serial class"
   MatchProduct "Serial Wacom Tablet"
   Driver "wacom"
   Option "ForceDevice" "ISDV4"

Section "InputClass"
        Identifier "Wacom serial class identifiers"
        MatchProduct "WACf|FUJ02e5|FUJ02e7"
        Driver "wacom"

# N-Trig Duosense Electromagnetic Digitizer
Section "InputClass"
   Identifier "Wacom N-Trig class"
   MatchProduct "HID 1b96:0001|N-Trig Pen"
   MatchDevicePath "/dev/input/event*"
   Driver "wacom"
   Option "Button2" "3"

xsetwacom set "touch" Gesture "on"

doesn't work, because my device appears as 'Finger' though referring to it with that also doesn't work, but I have tried with the ID number.
I can only assume that something like the following needs to go in somewhere, but not sure whether I should be creating an xorg.conf in /etc/X11 or what:
Code: Select all
# This section is for the TabletPC that supports touch
Section "InputDevice"
  Driver        "wacom"
  Identifier    "touch"
  Option        "Device"        "/dev/ttyS0"          # SERIAL ONLY
  Option        "Type"          "touch"
  #Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY

Section "ServerLayout"
  Identifier           "Default Layout"
  Screen               "Default Screen"
  InputDevice    "stylus"    "SendCoreEvents"
  InputDevice    "eraser"    "SendCoreEvents"
  InputDevice    "touch"     "SendCoreEvents"

The results of xinput list:

Code: Select all
⎡ Virtual core pointer                       id=2   [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
⎜   ↳ Wacom ISDv4 E3 Finger                      id=11   [slave  pointer  (2)]
⎜   ↳ Wacom ISDv4 E3 Pen eraser                  id=12   [slave  pointer  (2)]
⎜   ↳ Wacom ISDv4 E3 Pen                         id=13   [slave  pointer  (2)]
⎜   ↳ Wireless Keyboard/Mouse                    id=15   [slave  pointer  (2)]
⎜   ↳ PIXART USB OPTICAL MOUSE                   id=16   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                 id=19   [slave  pointer  (2)]
⎣ Virtual core keyboard                      id=3   [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                id=5   [slave  keyboard (3)]
    ↳ Power Button                               id=6   [slave  keyboard (3)]
    ↳ Video Bus                                  id=7   [slave  keyboard (3)]
    ↳ Video Bus                                  id=8   [slave  keyboard (3)]
    ↳ Power Button                               id=9   [slave  keyboard (3)]
    ↳ Sleep Button                               id=10   [slave  keyboard (3)]
    ↳ Wireless Keyboard/Mouse                    id=14   [slave  keyboard (3)]
    ↳ HP Webcam                                  id=17   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard               id=18   [slave  keyboard (3)]
    ↳ HP WMI hotkeys                             id=20   [slave  keyboard (3)]
    ↳ ACPI Virtual Keyboard Device               id=21   [slave  keyboard (3)]

Attempting to set gesture:
Code: Select all
xsetwacom set 11 Gesture "on"
Property 'Wacom Enable Touch Gesture' does not exist on device.

So not really sure what to do now...
Posts: 9
Joined: Sun Aug 01, 2010 9:03 pm

Postby nelz » Tue Mar 08, 2011 1:19 am

xorg.conf.d is replacing xorg.conf. Instead of one monolithic file with hundreds of settings, you now have a separate file for each section of the settings. The effect is exactly the same, but it is simpler to manage.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
Site admin
Posts: 9047
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest