Slackware disks and MySQL

Comments, suggestions and questions about Linux Format magazine and the coverdiscs

Moderators: ChriThor, LXF moderators

Slackware disks and MySQL

Postby Skrynesaver » Thu Sep 15, 2005 7:21 am

Hi all,
I'm sorry about the latness of this post but I have an old (PII) machine that I wanted to put to use and having used slackware with some success previously, I thought that it would be ideal for such an old machine. Indeed it was. However, (you just knew that was coming), every time I attempt to start up MySQL it bombs out, I was wondering if anyone else had this problem or if I'm doing something dumb!
Thanks in advance Skrynesaver
Posts: 2
Joined: Thu Sep 15, 2005 7:15 am

RE: Slackware disks and MySQL

Postby M-Saunders » Thu Sep 15, 2005 8:41 am

Which version of Slackware is that? You could try compiling MySQL from source, or get a newer Slackware release -- the hardware requirements haven't grown in years.

LXF regular
Posts: 2893
Joined: Mon Apr 11, 2005 12:14 pm

Slackware version etc..

Postby Skrynesaver » Thu Sep 15, 2005 8:48 am

Hi M,
thanks for the prompt response, I'm using the version on the coverdiscs a couple of months ago with the mysql server supplied on those discs. It should "just work"&tm; but doesn't seem to want to co-operate for me.
Posts: 2
Joined: Thu Sep 15, 2005 7:15 am

RE: Slackware version etc..

Postby nordle » Fri Sep 16, 2005 12:32 am

You could try PostgreSQL :)

Anyway, I got work in 6 hours so need sleep zzzzz, its probably a permissions thing, but if you do want to try source here's my basic guide. Doesn't take long, just tweak anything if you feel you'd prefer other directories etc etc

Otherwise we can check out the original errors later on if no-one gets back to you....

>mkdir /usr/local/mysql
>mkdir /usr/local/mysql/tmp
>mkdir /usr/local/mysql/src
>cp mysql-version-.tar.gz /usr/local/mysql/src
>cd /usr/local/mysql/src
>groupadd mysql
>useradd -g mysql mysql
>tar xvzf mysql-version.tar.gz
>cd mysql-VERSION
>CFLAGS="-O2 -march=i486 -mcpu=i686" CXXFLAGS="-O2 -march=i486 -mcpu=i686" ./configure --prefix=/usr/local/mysql --with-extra-charsets=complex --enable-thread-safe-client --enable-local-infile --enable-assembler --disable-shared --with-client-ldflags=-all-static --with-mysqld-ldflags=-all-static --with-unix-socket-path=/usr/local/mysql/tmp/mysql.sock --with-charset=latin1 --with-collation=latin1_bin

If ./configure fails for whatever reason, run:
>make distclean
Then re-run the ./configure with whatever changed parameters are needed to fix the issue.

>make install
>cp support-files/my-medium.cnf /etc/my.cnf
>cd /usr/local/mysql
>/usr/local/mysql/bin/mysql_install_db --user=mysql
>chown -R root .
>chown -R mysql var
>chown -R mysql tmp
>chgrp -R mysql .
>/usr/local/mysql/bin/mysqld_safe &
>/usr/local/mysql/bin/mysqladmin -u root password 'new_password'
>/usr/local/mysql/bin/mysqladmin -u root -h myhost password 'new-password' -p

Login with:
>/usr/local/mysql/bin/mysql -u root -p

Add the following to your shell start-up file, such as "users_home/.profile", "~/.bash_profile", "/etc/profile"
export PATH

Add the following to /etc/ so the libraries (such as c++ API) are available to other apps.
Then type ldconfig
I think, therefore I compile
LXF regular
Posts: 1501
Joined: Fri Apr 08, 2005 9:56 pm

RE: Slackware version etc..

Postby Erin » Fri Sep 16, 2005 7:38 am

What error message do you get? We can't help you if you don't give us a clue as into what to go on.

Just beneath my skin I'm screaming. Faithless::Insomnia.
Dual PIII 550 with Ubuntu [semi-bleeding].
User avatar
LXF regular
Posts: 141
Joined: Thu Apr 07, 2005 7:35 pm
Location: The Olde Smoke south of the River

Return to Magazine and coverdiscs

Who is online

Users browsing this forum: No registered users and 0 guests