Wireless Card Not working - Acer Travelmate

For discussing Linux compatible (or not) devices

Moderators: ChriThor, LXF moderators

Wireless Card Not working - Acer Travelmate

Postby greybeard99 » Tue Sep 07, 2010 7:21 pm

I have an Acer Travelmate 7510 dual booted with windows 7 and Ubunti 10.04. It contains a Broadcom 802.11g wireless card.

The wireless card is found automatically by windows 7 but not by Ubuntu. It cannot be switched on manually when in Ubuntu.

Can anyone help please! :shock: :!:
Posts: 4
Joined: Mon Jul 05, 2010 9:59 pm

Re: Wireless Card Not working - Acer Travelmate

Postby RedWillow » Tue Sep 07, 2010 7:42 pm

greybeard99 wrote:It contains a Broadcom 802.11g wireless card.

Ho hum - Broadcom. This is always a nuisance as licensing issues prevent the firmware and/or the proprietary driver from being included in a default install. Have a look here:

https://help.ubuntu.com/community/WifiD ... er/bcm43xx

There are several options to try: using the CD as a repository (the files you need are on the CD; connecting with an ethernet cable and seeing if 'Hardware Drivers' comes up with the goods; etc.

So that we can see which Broadcom wireless card you have, post the terminal output of:

Code: Select all
sudo lshw -C network

That will also give details of your ethernet nic. If that's a Broadcom too there are sometimes issues with the wireless driver interfering with the wired (or t'other way round).
LXF regular
Posts: 719
Joined: Thu May 29, 2008 1:05 pm

Postby loebus » Fri Sep 10, 2010 12:38 pm

I downloaded the windows drivers from the acer website, thankfully I've saved them to a memory stick, because the driver is no longer available, due to the laptop being discontinued(?), it's 7 years old and I used ndiswrapper to install.

Driver installed: neti2220
Using Ubuntu 9.10 on Acer Travelmate 2304
LXF regular
Posts: 165
Joined: Fri Apr 09, 2010 6:22 pm
Location: Here

Broadcom Card

Postby greybeard99 » Tue Sep 14, 2010 3:44 pm

Many thanks for your advice. Not quite solved yet but much nearer a solution. Apols for the delay in writing as I have been away.
Posts: 4
Joined: Mon Jul 05, 2010 9:59 pm

Postby PCNetSpec » Tue Sep 14, 2010 7:38 pm

Install the b43-fwcutter and ubuntu-restricted-extras packages either from synaptic
or with:
Code: Select all
sudo apt-get install b43-fwcutter ubuntu-restricted-extras

obviously you will need to be connected to the internet via an ethernet cable.

Then either log off and on again, or reboot.
WARNING: You are logged into reality as 'root'... logging in as 'insane' is the only safe option.
Linux in the UK
The Linux Community Forum
LXF regular
Posts: 631
Joined: Sun Feb 21, 2010 3:50 pm
Location: Cornwall UK

Postby fede » Thu Jul 21, 2011 10:33 pm

I guess I posted the following request for help in the wrong forum (the generic "Help" forum). I have to add to the following that I also tried all the suggestions I found here or on Ubuntuforums, and none worked :(
A while ago I bought a Lenovo Ideapd with a Broadcom wifi chip. At first, it would not play ball with Ubuntu 10.04, but after downloading the hybrid_wl driver and compiling the wl.ko module, things got on track. Afterwards, Broadcom apparently open sourced some (all?) drivers, so I was optimistic that things would be fine in future upgrades.

I skipped Ubuntu 10.10 for some reason, and last week moved to 11.04. Now the wifi chip works no more Evil or Very Mad

The messages in the (classic Gnome) network manager applet showed "device not ready" or "wireless is disabled by hardware switch". rfkill lists three devices, and it said that the brcmwl-0 one was soft- and hard- unblocked after the appropriate incantation, but that didn't help (the other entries are ideapad_wlan, unblocked, and acer-wireless, soft blocked, and hard unblocked - could never get both to be unblocked)

I tried the updated Broadcom driver, together with its patch for recent kernels, and it compiled all right, but the device is not ready, the led indicator blinks (or shuts off if I press the Fn-key to toggle wifi), and iwconfig lists eth1, as the wireless device, instead of wlan0, which makes me think the driver is not right.

Oh, yes, I had already downloaded the Broadcom drivers from the Ubuntu depositories, but they didn't work either. After installing the new hybrid_wl drivers I suspected there might be a conflict, so I uninstalled the sta, and bwl-cutter, stuff and, on reboot, the wifi indicator was steady, but it still did not work, and was still "wireless is disabled by hardware switch". Blocking/unblocking variously in rfkill, or more fiddling with the Fn switch, and it's back to indicator blinking or off (and still disabled by hardware switch, or device not ready).

I imagine that the solution should be devilishly easy (after all, it all worked with 10.04), but have no idea where to turn now. Any help?
LXF regular
Posts: 106
Joined: Thu Sep 01, 2005 3:23 am

Return to Hardware

Who is online

Users browsing this forum: No registered users and 0 guests