Compile GCC-4.0.1 from source! Help!

The place to post if you need help or advice

Moderators: ChriThor, LXF moderators

Compile GCC-4.0.1 from source! Help!

Postby newbie » Fri Sep 02, 2005 8:08 pm

I am trying to compile GCC-4.0.1 from source that i got from coverdisk in LF71. I have configure it with only: ./configure but then everything was fine, package compiled and passed the test aswell, but there was not gcc, only c++, g++ and several others. So when i tried gcc --version,it is still the old one from Debian Sarge 3.1. But other like c++, g++... is 4.01 after i made syslink.
I looked at the test result mailing list for GCC-4.0.1 and someone compiled sucessfully with this configuration: sr/configure --enable-thread --enble-nls --enable-language=c,c++,java.
Later on when i tried to recompile the package again with the same on from mailing list but i got error no language support like ada, f77. So i merely configure with enable-language=c,c++,java. After 2.30 hour pass, i got the error with "make" java language like [all-target-javalib] error 2.
So can anybody suggest anything because i am getting tired of this now and frustration.
Posts: 30
Joined: Fri Sep 02, 2005 7:55 pm

RE: Compile GCC-4.0.1 from source! Help!

Postby nelz » Fri Sep 02, 2005 9:10 pm

Code: Select all
./configure --help

Read the options and decide what you need instead of using someone else's settings. Do you need a Java compiler? If not, there's no point in trying to compile it with the java option.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
Site admin
Posts: 9046
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby newbie » Sat Sep 03, 2005 7:51 pm

Ok, point taken, i don't need a java compiler but can you explain what last thing for me? That is when the first time i compiled the GCC package with this option: ./configure, it was only thing i type in to configure. Is there any wrong with it. I have compiled successfully with this configuration but no "gcc" file output in /usr/local/bin
Posts: 30
Joined: Fri Sep 02, 2005 7:55 pm

Return to Help!

Who is online

Users browsing this forum: No registered users and 1 guest