Gentoo on dvd...[solved]

Comments, suggestions and questions about Linux Format magazine and the coverdiscs

Moderators: ChriThor, LXF moderators

Gentoo on dvd...[solved]

Postby stardis » Wed Aug 03, 2005 1:45 am

I have my system to the point where I can boot into it and login (LXF68-- just bought it at the bookstore a week ago). Where it says in the mag to boot into your new system and login AND then emerge x11 is confusing me (being a complete newbie). I don't know how to tell my system that the mirror is on the dvd or emerge the apps but get them from the dvd.

I haven't setup networking yet with my wirelessG pci card yet so I am installing everything from the dvd.

Everything seems to be working OK otherwise. I used the following to mount the dvd drive as "cdrom":
# mount /dev/cdroms/cdrom1

I can see what is on the dvd but I don't know how to emerge from the dvd while logged into my new Gentoo linux system.

Any help is greatly appreciated.
Last edited by stardis on Wed Aug 03, 2005 10:59 pm, edited 1 time in total.
Posts: 4
Joined: Wed Aug 03, 2005 1:21 am

RE: Gentoo on dvd...

Postby nelz » Wed Aug 03, 2005 7:34 am

You should have already taken care of this during the initial installation, when you did

Code: Select all
echo "local /mnt/cdrom/Distros/Gentoo/distfiles" >/mnt/gentoo/etc/portage/mirrors

That location is now /etc/portage/mirrors on your live system, which is where portage expects to find it. If you didn't run this during installation, do it now as

Code: Select all
echo "local /mnt/cdrom/Distros/Gentoo/distfiles" >/etc/portage/mirrors

You need to have the DVD mounted of course.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
Site admin
Posts: 9048
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

error message...

Postby stardis » Wed Aug 03, 2005 3:46 pm

Thanks for replying. When I booted the computer this morning, I did this:

# nano -w /etc/portage/mirrors
local /mnt/cdrom/Distros/Gentoo/distfiles

I then did this:

# ls /mnt/cdrom

and I could see everthing on the dvd.
so I tried the following code from the mag:

# emerge xorg-x11 -av
>>> emerge (1 of 9) media-libs/libpng-1.2.8 to /
!!! File system problem. (Bad Symlink?)
!!! Fetching may fail: [Errno 30] Read-only file system: ' /mnt/cdrom/cvs-src'
Local mirror has file: libpng1.2.8.tar.bz2
!!! libpng-1.2.8.tar.bz2 not found in /mnt/cdrom
!!! No write access to /mnt/cdrom
!!! File libpng-1.2.8.tar.bz2 isn't fetched but unable to get it.

I don't yet know enough about linux to understand the error message. My listing for the dvd reader in my /etc/fstab is:
"/dev/cdroms/cdrom1 /mnt/cdrom iso9660 defaults 0 0"

Thanks for your help with this.

Posts: 4
Joined: Wed Aug 03, 2005 1:21 am

update [solved]...

Postby stardis » Wed Aug 03, 2005 10:58 pm

Good news, nelz. I was able to get the emerge to start-- it is chugging away now. I typed "ls /etc*" to see what was there and decided to check the "/etc/make.conf.example". I then checked "/etc/make.conf"
and set:
PKGDIR=" /mnt/cdrom/Distros/Gentoo/distfiles"

The emerge worked after I did that.
Thanks for your help. LXF is at the top of my favorite mag lists.
Posts: 4
Joined: Wed Aug 03, 2005 1:21 am

Return to Magazine and coverdiscs

Who is online

Users browsing this forum: No registered users and 0 guests