USB Problem (Hotplug?)

The place to post if you need help or advice

Moderators: ChriThor, LXF moderators

USB Problem (Hotplug?)

Postby rlcoach » Mon Apr 25, 2005 6:10 pm

I am hoping some kind soul can help me fix my problem with installing and configuring Ubuntu. I am doing my best to switch from Windows XP after all the positive things I have heard about Linux however I am having massive teething issues that I cannot fix (tried all weekend) and if I cannot get past them it will mean I will have to return to Microsoft ☹

I have installed Ubuntu on my PC but am having major problems getting my USB devices to work. First of all I couldn’t install at all when I had my USB keyboard and mouse plugged in. I tried swapping their ps/2 equivalents and then the install went smoothly. However…………then when I plugged any usb devices in nothing would work. I tried changing from ACPI to ACM but this made no difference. Curiously though if I restart hotplug (sudo /etc/init.d/hotplug restart) once booted everything kicks into life and my usb devices are detected and work fine. Sadly this is not a long term solution as I cannot boot with my usb keyboard/mouse plugged in.

One more clue is that when hotplug starts in boot up it pauses for quite a long time.

Here are my system specs.

Medion Athlon XP 3200+ with 512mb RAM
nVidia GeForce FX5200
Pioneer DVD RW DVR-106D
Sony DVD Rom DDU1612
Seagate Barracuda ST3160021A (Ultra ATA/100)
Medion TV Tuner
Microsoft USB Digital Media Pro Keyboard
Logitech Wireless MX Laser mouse
Creatix Modem
Nevo F-419 19" TFT Monitor
Via Rhine II Fast Ethernet
Internal card reader

Any help would be greatly appreciated, I have run out of ideas.


p.s. And my sound doesn’t work either, but I figured that could wait until I fix the usb problem (if I can)

RE: USB Problem (Hotplug?)

Postby Gordon » Mon Apr 25, 2005 6:47 pm

Are your USB keyboaard and mouse plugged into USB ports or do they use little adaptors and plug into the ps/2 ports? I had a similar problem with SUSE 9.2. When I had a USB keyboard plugged into the USB port my system wouldn't boot since I got the "no keyboard" error during the POST (Power On Self Test) sequence of the BIOS. I found a small adaptor at Maplin Electronics which did the trick. The part is a "USB Adaptor AF/Mini Din 6pin M" the part number/order code to use at Maplin is A78AH. All you do is plug your USB keyboard into the adaptor, then plug the adaptor into the ps/2 keyboard socket and your USB keyboard should now work as normal bu through the ps/2 socket. My shiny new SUSE 9.3 system has no problem with this sort of setup. I have a Zippy Electroluminescent USB keyboard (again from Maplin) and a micro$oft USB trackball explorer thing for a mouse. They both use these adaptors.

Check the Maplin website and do a search on the order code. They are £4.99 each.

There may also be an option in your BIOS to detect and use a USB keyboard. If there is it may not be enabled by default and you could try changing the BIOS settings for the keyboard. This may not work though.
Violence is the last refuge of the incompetent
User avatar
LXF regular
Posts: 210
Joined: Thu Apr 07, 2005 5:01 pm
Location: Bradford, West Yorkshire

RE: USB Problem (Hotplug?)

Postby Ram » Tue Apr 26, 2005 1:33 pm

The adaptor should have been in the box with the KB and possibly with the mouse. From past experence M$ suppled the adaptors when I bought both of my Intellimice so I would assume they do will the KB.

If the KB is not recognised at boot it is most likely a BIOS issue.

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
LXF regular
Posts: 1691
Joined: Thu Apr 07, 2005 9:44 pm
Location: Guisborough

RE: USB Problem (Hotplug?)

Postby EchoBeach » Tue Jun 28, 2005 11:17 pm

I've been trying to install Ubuntu 5.04 - from the LXF68 DVD - without success. :(
In case it's relevant, my Ubuntu 5.04 Live CD recognises my USB Wireless keyboard and mouse OK on a P4 3GHz - no problem. :)
Posts: 34
Joined: Tue Jun 28, 2005 11:02 pm

RE: USB Problem (Hotplug?)

Postby nelz » Tue Jun 28, 2005 11:28 pm

I suggest you start a new topic, rather than tagging onto an old topic about hotplug. You're likely to get more views that way.

You should also give us something to work on. "without success" doesn't give much clue as to what is going wrong, beyond the fact that it has gone wrong. What did you do? What did you expect to happen? What happened? Was the problem booting from the CD, booting from the hard disk after installation or somewhere in between? If so, where?
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
Site admin
Posts: 9046
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

RE: USB Problem (Hotplug?)

Postby EchoBeach » Tue Jun 28, 2005 11:34 pm

Thanks nelz
I've just done that.
Posts: 34
Joined: Tue Jun 28, 2005 11:02 pm

RE: USB Problem (Hotplug?)

Postby Guest » Thu Jun 30, 2005 7:27 am

Im using Fedora Core 4 any my usb stuff work fine
logitech cordless keyboard mouse,
usb hdd /dev/sdb
sony camera /dev/sdc

question does the kernel support usb,,,, also check out usbview

Return to Help!

Who is online

Users browsing this forum: No registered users and 2 guests