Mono sound Creative SB Live 24 bit

The place to post if you need help or advice

Moderators: ChriThor, LXF moderators

RE: Mono sound from SB Live

Postby fairless » Sun May 22, 2005 6:57 pm

Good effort, but Knoppix did n't recognise the card, spotted that it was a Creative, but not supported :(

User avatar
Posts: 27
Joined: Sat May 07, 2005 12:31 am

RE: Mono sound from SB Live

Postby Nigel » Sun May 22, 2005 10:16 pm

Well, I've just about run out of ideas. I did a bit of googling, and found a couple of other people having problems with this board & sound (sorry, second one's in German)... ... did=325515 ... id=1825307

Is this a machine you've built yourself ? There were some threads on a couple of sites that claimed sound wouldn't work at all on this board unless you have a power supply that puts -5v on pin 20 of the connector, but then some other people disputed that - might be worth checking the specs of your PSU connector and the mobo.

Is there anything in the BIOS setup that allows you to set the mode that the sound is operating in ? If so, check out all the options - you never know !

Failing that, my advice is go get yourself a real Soundblaster and disable the onboard one. I know it's admitting defeat, but at least it moves you forward... and if a fix for the onboard one does eventually appear, you can move the real card to your next project machine :)
Hope this helps,

LXF regular
Posts: 1141
Joined: Fri Apr 08, 2005 8:03 pm
Location: Gloucestershire, UK

Re: RE: Mono sound from SB Live

Postby Guest » Sun Jun 05, 2005 8:35 pm

Nigel wrote:Hmmm... I have an Soundblaster Audigy in my home box and a Soundblaster pci 128 in the box at work, and both work fine under various versions of SuSE. The Audigy uses the emu10k1_gp module under SuSE 9.2 and I seem to remember that the pci128 uses something very similar (emu<something>). If you do an lsmod from a terminal prompt that will list all the modules you are running - do you have an emu<anything> listed, or is your driver actually reported as ca01056 ? If the latter, you might want to try telling the machine you have a different model SoundBlaster and see what happens.

RE: Re: RE: Mono sound from SB Live

Postby fairless » Wed Jun 15, 2005 4:04 pm

Hi Nigel, I've tried the emu10K and it does not work either. As far as I can tell from all the websites and other forums I've searched the ca0106 driver is the correct one for my kit, I just don't think it's working correctly for my config. Have n't found any other users with Mandrive 2005 LE on the same motherboard chipset. If there are any, they either have n't got a problem and therefore aren't looking at the forums, or they are living with it. Cheers, Neil
User avatar
Posts: 27
Joined: Sat May 07, 2005 12:31 am

RE: Mono sound from SB Live

Postby Guest » Sat Jun 18, 2005 8:30 am

Love is the law love under will.

Go to Control centre, sound, sound system turn off enable sound. Check Config your computer, system, enable/disable system services uncheck sound. Use Xine under 'master of the known universe' if you still have problems, make sure you remember original settings, but go through it and you should be able to get at least 5.1.
Make sure you have ca0106 as your sound controller/driver what ever we're meant to call it, and is this onboard or a pci if pci make sure you turn the bios sound driver off. Hope this helps.

There is no law beyond do what thou wilt.

RE: Mono sound from SB Live

Postby Guest » Sat Jun 25, 2005 10:29 pm

This seems to be an issue with any x86_64 system using a surround sound card. Many people have probs with the NForce audio chipset, the Creative cards, etc. This is an ALSA bug, not something wrong with the system. I have a system me and a friend built with an NFORCE 64-bit mobo with the intel AC'97 chipset, only left channel audio. Windows on the same system (multibooting) plays audio fine. In my research of this problem I was able to find a couple bugtracks in ALSA's bug tracker for this. I am not sure what version fixes it, or even if it's been developed yet. We're using SuSE 9.3 x86-64 edition, we've tried other x86_64 builds with similar results. Want to find a build that uses a sound system other than ALSA. 32-bit SuSE 9.2 works fine, so this is odd.

Guess this is what we deal with when using bleeding-edge hardware. Let's hope we can find a patch, new version, or that they are fixing ALSA now.


Return to Help!

Who is online

Users browsing this forum: No registered users and 2 guests