Had to give up Linux on laptop Intel 2200BG and WPA

For discussing Linux compatible (or not) devices

Moderators: ChriThor, LXF moderators

Had to give up Linux on laptop Intel 2200BG and WPA

Postby donoreo » Thu Aug 17, 2006 1:52 pm

I tried. I tried more than one distro even. I could not get the Intel 2200BG wireless to work reliably with WPA. It would connect, sometimes, but have a poor signal. Other times it would connect and then drop the connection.

Right now I am using the same laptop with XP on a different hard disk with no problem at all. Signal strength shows better and it has been connected for almost 24 hours straight now (this is in the same location as it was when running Linux).

My last attempts to get this to work was with Ubuntu 6.06 using network manager in gnome. As I said, it worked, but not reliably. What else can I try?

I have googled this exentensively, I tried some suggestions from here when we sort of hi-jacked a thread a couple of weeks ago.
User avatar
LXF regular
Posts: 788
Joined: Mon Apr 11, 2005 1:49 pm
Location: Toronto, Ontario, Canada

RE: Had to give up Linux on laptop Intel 2200BG and WPA

Postby spottedcat » Thu Aug 17, 2006 5:03 pm

donoreo, I came across this Ubuntu forums thread. It's about network-manager but it goes on for 7 pages so there might be something there to help you.

I'm sorry to hear you're having such trouble because, as I think I've mentioned, network-manager in Ubuntu Dapper, Suse 10.1 and Fedora 5 has been very reliable on my quad-booting Sony vaio laptop with Intel 2200BG wireless - and with WPA. I get a more stable connection than in Windows. One last thought, and I may have suggested this already, so sorry if I have. Network-manager cannot cope with a hidden SSID. I learnt this the hard way by disabling the SSID broadcast from my router. Network-manager got very confused. Oh dear, oh dear. It's not an experience I want to repeat. :(
LXF regular
Posts: 971
Joined: Mon Oct 31, 2005 3:14 pm
Location: UK

RE: Had to give up Linux on laptop Intel 2200BG and WPA

Postby wyliecoyoteuk » Wed Aug 23, 2006 8:44 pm

I have found problems with various wifi setups and the following, on BOTH windows and linux
DHCPclient does not work, have to set fixed IP-this is because not all APs pass DHCP requests.
WEP stops connection working
WPA stops connection working (just because WPA is available, doesn't mean the hardware supports it)
Enabling WPA stops network detection working.
ESSID or SSID is case sensitive.(oops)
speed negotiation does not work, or defaults to 11Mbit
Encryption slows network to a crawl if using more than one client card, or using different speed cards
There are many other issues, as a whole WIFI is not a mature technology, there are many vendors selling kit with varying degrees of compatability and compliance.
The same can be said of Bluetooth and USB.
I personally use MAC filtering on my home network, I think that that is probably sufficient in my environment.
My signal just reaches the bottom of the garden at home, at work, we use WEP, but within a steel clad building, they would need to press a laptop to one of the windows (sic) to connect,

As a general rule, buy all of your kit from the same manufacturer at the same time, and it should all work, but it may not, and there is no guarantee that 802.11 b will work with 802.11g or 802.11n for example.
I use wifi on my laptop at home with Suse 10.1, and at work with XP. trying to get multiple profiles on either is a nightmare, often just fails.
I need to connect to various wired and wifi networks, (sometimes 4 or more a day) and I just configure manually as required.
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
User avatar
LXF regular
Posts: 3525
Joined: Sun Apr 10, 2005 10:41 pm
Location: Birmingham, UK

Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests