how can I test why my net connection dies on any linux dist.

The place to post if you need help or advice

Moderators: ChriThor, LXF moderators

how can I test why my net connection dies on any linux dist.

Postby aveline » Fri Jun 03, 2005 5:24 am

Topic says it all really. I got the pcmcia card I use to work (finally) so it doesn't just die after 30secs on booting into DSL (DamnSmallLinux or any other distro for that matter as I installed MDK 9.2 earlier tonight with the same results). I did it by using the acpi=off switch. Well yay but it still dies after about 15 minutes of being online. I don't have a clue how to test this or how to figure out what is wrong. I've turned off in the bios all my power management, I'm booting with these cheat codes from a DSL LiveCD: dma noapic noapm acpi=off. I even tried the "Failsafe" boot up but again it didn't help.

From a term this is the info I can get on how it detects & which driver its loading:

# cardctl info
PRODID_2="CardBus Ethernet 10/100 + Modem 56"
PRODID_3="CBEM56G" <- thisis wrong, it should be RBEM56+G-100

While connected it shows thru ifconfig -a:
root@box:~# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:xx:xx:xx:xx:xx
inet addr: Bcast: Mask:
RX packets:536 errors:0 dropped:0 overruns:0 frame:0
TX packets:565 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:324889 (317.2 KiB) TX bytes:49821 (48.6 KiB)
Interrupt:11 Base address:0x4000 [To avoid an IRQ conflict I set my soundcards IRQ to be 10 hoping that may be the problem but it was not]

But when it disconnects ifconfig shows a slightly different stanza:

... Mask: BROADCAST RUNNING MULTICAST... <- the word "UP" is now missing after the Mask address.

The only thing I have seen online to possibly explain this odd behaviour is that Xircom (whos been bought by Intel incidentally & does NOT support their legacy cards really at all), said on their site that going thru a router plugged into a DSL modem doesn't work for some reason? I wondered if I plugged this directly into my switch if that would help or not? As it stands this is how my network works:

DSL Modem -> switch -> router ->laptop

The routers LEDS are lit in 2 places where it indicates that its using 10/100 mode and the top one just says it is supposedly still linked up (Its a linksys BEFSR41). Yet the middle LED where it should blink to show packets moving is just blank now. The last thing I've tried is to do a "ifconfig eth0 down up" and if i then do "ifconfig -a", it shows that its UP...router LEDs are all on again but when I try to ping somewhere I get "unknown host" errors.

I know this is long but I have been trying to solve this issue for some time now. Any help is appreciated.


RE: how can I test why my net connection dies on any linux d

Postby dandnsmith » Sat Jun 04, 2005 11:19 am

I really don't buy this 'going thru a router plugged into a DSL modem doesn't work for some reason'. Next they'll be saying that it has to be in the right quarter of the moon, but not on the 3rd Sunday of the month - either the thing functions as an ethernet interface or it doesn't.

Rant aside, the unknown host message sounds like something gets lost and not restored - either the routing table entry or the dns stuff.

You haven't said whether the router is 'just' a piece of hardware or is a computer, but you can go down the chain checking progressively with your pings.
Also you can print out the routing table before and after the failure - just use the route command.
Another thought - are you using DHCP to get the IP address for the interface, and does it get set after to a sensible value.
LXF regular
Posts: 322
Joined: Fri Apr 15, 2005 10:01 am
Location: Berks, UK

Return to Help!

Who is online

Users browsing this forum: No registered users and 2 guests