GRUB bootloader and SUSE 9.2

The place to post if you need help or advice

Moderators: ChriThor, LXF moderators

GRUB bootloader and SUSE 9.2

Postby paulfinn » Tue Apr 05, 2005 8:20 am

I installed Suse 9.2 from the coverdisc as an update of an installed 9.1 Professional on a dual-boot machine with WinXP Pro. Installation went fine but re-booting left me at the GRUB> prompt. Some research led me to try the following manual sequence:

root (hd1,1)
kernel /boot/vmlinuz-2.6.8-24-default root=/dev/hdh2

This ended with Linux unable to find the root partition, "kernel panic" [never see that in the Winworld] and lock up. Various rescue attempts all failed: using the repair option on the 9.2 disc; new install; using the 9.1 disc to repair 9.1; switched the bootloader to LILO - which boots Linux but wouldn't allow selection of any other option boot menu screen.

I'm open to any solution but have two questions:
1. Is it possible to install 9.2 and leave the existing boot loader untouched? The kernel file is the same and Yast offers the option to install without installing a bootloader. Of course, if Yast takes that to mean delete any existing bootloader, it's back to square one.
2. Is there any certain way to determine the root= path in the kernel load line? I noted "hdh2" as the path during a re-installation but this continues to be the stumbling point, so maybe it's wrong.


Postby Andy » Tue Apr 05, 2005 8:42 am


You can install SUSE 9.2 with LILO as the boot loader - I had a similar problem on my desktop machine which has a SATA drive. I have to admit that I just trashed the machine and installed FC3 over it so didn't get to do much digging about! :D

Try LILO and see how you get on - you should be able to choose it during installation instead of GRUB.

Best wishes,

User avatar
Posts: 90
Joined: Mon Apr 04, 2005 5:29 pm
Location: Trowbridge

Postby nelz » Tue Apr 05, 2005 6:48 pm

That hdh2 root setting is certainly wrong, it should be something like /dev/hda2 for a PATA IDE drive, although the number will vary. You can see your partitions by running the partitioning tool from YAST.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
Site admin
Posts: 9048
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby andychannelle » Tue Apr 05, 2005 8:04 pm

There's a pretty spiffy guide to GRUB here (never know, it might help):

I always had trouble with LILO on my old machine because the 'intelligent' Intel virus protection in the BIOS thought the bootloader was a virus. No problems with GRUB though.

Similarly, when I was dual-booting, I never had much success retaining something like Bootmagic when installing - even when I specified to keep the bootloader. It would always need extra messing about later.
LXF regular
Posts: 111
Joined: Mon Apr 04, 2005 4:08 pm

Postby Guest » Wed Apr 06, 2005 11:12 am

:| Thanks for the suggestions but -
Tried using LILO as the bootloader. Boots into Linux but nothing else, including Fail Safe.
have tried various parameters in root=/dev/hd?? -- including hdh2 -- which was what the Yast partition tool showed.
The Troubleshooters guide was where I found the command line sequence and I've also reviewed the full GRUB manual.
... and all roads still lead to kernel panic.

My Config

Postby HJDM » Thu Apr 07, 2005 6:48 pm

In installed 9.2 onto a machine which had 9.1 installed dual boot with windows XP. The installation was Boot Sector with NTLDR in it. A boot partion with GRUB, and 9.1 on one partion, 9.1 on the other. Boot sequence was Boot sector to windows to grub into linux. A little convoluted but it work dual boot fine. Installed 9.2 and despite being told, it changed the sequence to Boot sector to boot partion with grub, thence to operating system of choice. The following is an extract from the file /boot/grub/menu.lst

kernel (hd0,1)/vmlinuz root=/dev/hd4 vga=0x314 selinux=0 splash=silent resume=/dev/hd3 desktop elevator=as

show opts
initrd (hd0,1)/initrd

I don't know if this helps
Posts: 2
Joined: Thu Apr 07, 2005 5:46 pm

RE: My Config

Postby Guest » Fri Apr 08, 2005 3:56 pm

My grub.conf from my main box:

default 0
timeout 30

title=Gentoo DVB
root (hd0,1)
kernel /bzImagedvb root=/dev/sda3

root (hd0,1)
kernel /bzImagenew root=/dev/sda3

map (hd1) (hd0)
map (hd0) (hd1)
root (hd1,0)
chainloader (hd1,0)+1

From another box i have:

timeout 30
default 0


title Gentoo Ati New
root (hd0,0)
kernel /boot/bzImageati root=/dev/hda3

title Gentoo
root (hd0,0)
kernel /boot/bzImageatinewest root=/dev/hda3

The first box has a SATA drive and the second box has an IDE drive


Postby Nigel » Fri Apr 08, 2005 10:44 pm

Do you have a SATA hard drive ? If so, you may find that there is some drive mapping going on that means you have to treat it as /dev/sda* - try /dev/sda2. A clue to this will be the presence of a file called in /boot/grub (if you can get to it).

Another suggestion - try booting from a Knoppix CD - that's usually pretty good at figuring out what partitions you have got - find the one with /boot and see what Knoppix calls it...

Hope this helps,

LXF regular
Posts: 1141
Joined: Fri Apr 08, 2005 8:03 pm
Location: Gloucestershire, UK

Postby Guest » Sat Apr 09, 2005 10:28 am

If SuSE uses an initrd file to load modules before booting the kernel, you will need to pass this to grub as well.
If you don't you will get the kernel panic message.

Postby Nigel » Sat Apr 09, 2005 12:33 pm

That could explain it... my (working) /boot/grub/menu.lst contains this entry for booting SuSE 9.2 :

kernel (hd0,0)/vmlinuz root=/dev/sda3 vga=0x317 selinux=0 resume=/dev/sda2 desktop elevator=as showopts splash=none noapic acpi=off apm=off vga=normal
initrd (hd0,0)/initrd

(note there is no line break between "desktop" and "elevator" but initrd starts a new line. Each line is indented by 4 spaces, which get lost in posting :( )

Hope this helps,

LXF regular
Posts: 1141
Joined: Fri Apr 08, 2005 8:03 pm
Location: Gloucestershire, UK

Return to Help!

Who is online

Users browsing this forum: Google [Bot] and 3 guests