[Solved] PythonCard not working

Code junkies hangout here

Moderators: ChriThor, LXF moderators

[Solved] PythonCard not working

Postby stuarte9 » Sat Jun 14, 2014 2:25 pm

Hi all,

I've decided to try and learn some Python using a library book called "Beginning Python" by Peter Norton et al from Wrox Press (c) 2005.

The book advises that a package called PythonCard should be installed. I have downloaded the zip file, PythonCard-0.8.2.zip,

The archive's top level Readme.txt file states:-

"Place the "PythonCard" directory in your python directory or another directory on your PYTHONPATH. By default, the Windows installer and distutils installer will place PythonCard in your Python22\Lib\site-packages directory; the actual path will be different depending on your OS and version of Python."

I have placed the zip file into /usr/lib/python2.7/site-packages.

The Readme.txt file further states :-

"If you're running on a Unix/Linux system, you must unzip the release distribution with the -a option to convert the CR/LF line endings of each file to LF."

Using a terminal and after cd'ing into .../site-packages I unzipped the file into that directory using "unzip -a PythonCard-0.8.2.zip".

Lastly, the Readme.txt file also states :-

"PythonCard requires Python 2.3 or later and wxPython 2.5.2.x or later. wxPython is available at http://www.wxpython.org/"

Looking into .../site-packages I found that there was already a folder called "wx-2.9.4-gtk2" which already contained wxPython

On p.3 whilst "speaking" of codeEditor the book states:-

"Once it is installed on your system with PythonCard, on Linux or Unix-based systems, you can just type codeEditor in a terminal or shell window and it will start."

Well, no it doesn't. When I tried the system responded with :-

"If 'codeEditor' is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf codeEditor"

After a bit of investigation I tried :-

python /usr/lib/python2.7/site-packages/PythonCard-0.8.2/components/codeeditor.py
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/PythonCard-0.8.2/components/codeeditor.py", line 15, in <module>
from PythonCard import configuration, event, STCStyleEditor, widget
ImportError: No module named PythonCard

You can clearly see the result of that.

Has anyone managed to get this to work ?

Thanks in advance for any help that you can give with this.

Last edited by stuarte9 on Sat Jul 05, 2014 4:57 pm, edited 1 time in total.
Posts: 75
Joined: Mon Mar 08, 2010 5:03 pm
Location: Scotland

Postby stuarte9 » Sat Jul 05, 2014 4:56 pm

Hi all,

Just a quick note to say that I solved the problem, so no need to reply now.

Posts: 75
Joined: Mon Mar 08, 2010 5:03 pm
Location: Scotland

Return to Programming

Who is online

Users browsing this forum: No registered users and 0 guests