Mint software updates

The place to post if you need help or advice

Moderators: ChriThor, LXF moderators

Mint software updates

Postby fede » Sun Sep 08, 2013 11:23 pm

I could not resist the Mint desktop bundle that LXF provided, so I moved my desktop form Ubuntu to Mint/KDE (I would have otherwise installed Ubuntu 13.04 and quickly ditched Unity for KDE and/or Cinnamon).

However, there are a few problems with the updates, and I don't know where to fiddle to fix them:

1. I added some Ubuntu repositories to the basic list, and the GUI balks at some, stating that "upgrading form olivia to raring is not supported".

2. The same GUI refuses to update when a repository is "not trusted". Apparently, there is no option to override this block. In Ubuntu I would get around this by updating via Synaptic, but the "Updates" option is not present in the Mint version (why???)

Both issues are not crucial, since apt-get update/upgrade works, but it would be nice to have everything working right.

3. I occasionally use Opera as a browser, and so I put in the opera repository. This caused a broken package, since "No module named linuxmint" (message form dpkg). What is really annoying, however, is that the package is listed as installed (but not working), and any attempt to uninstall from Synaptic or apt-get fails with the same message. This also generates a bunch of error messages at any update - maybe it's not a big deal, but it would be nice to get opera working or, if that's not possible, to clean it away.

By the way, when I installed Mint I tried to use the dpkg --get-selections/--set-selections trick to save time in reinstalling my standard software, but that did not work because the packages in the list (generated from my previous Ubuntu 12.10 install) "are not in the database". More of an annoyance than anything else, but, still, it would have been nice if it had worked.

Thanks for any suggestion.
Posts: 99
Joined: Thu Sep 01, 2005 3:23 am

Back to Ubuntu - but what about dplg --get/set-selections?

Postby fede » Tue Sep 10, 2013 9:32 pm

Mint didn't work out (i am too lazy and not enough time to fix things), so I'm back on Ubuntu. The glitches are gone, except one: dpkg --set-selections using a file created before the upgrade with dpkg --get-selections returned the same error (all packages "are not in the database"), and so I had to reinstall stuff "by hand". Any info why this trick did not work (it used to)?

Posts: 99
Joined: Thu Sep 01, 2005 3:23 am

Return to Help!

Who is online

Users browsing this forum: No registered users and 1 guest