Switched from Nouveau to nVidia, Gnome problem [SOLVED]

The place to post if you need help or advice

Moderators: ChriThor, LXF moderators

Switched from Nouveau to nVidia, Gnome problem [SOLVED]

Postby splurben » Fri Sep 07, 2012 6:13 am

I'm running a Gentoo AMD64 System, kernel 3.5.3-gentoo

I am on Gnome 3, my shell version is

I was using Nouveau for my nVidia card but I got really tired of all the tearing on video so I switched back to the nVidia proprietary drivers (304.43).

The proprietary nVidia drivers are definitely installed and running.

During the switch Gnome 3 dropped into fallback mode and I cannot for the life of me find a way to restore full Gnome 3.

I have another Gentoo AMD64 system with the exact same video card [GeForce 8500 GT] and it's using Gnome 3 Shell without fallback.

I really like the clean Gnome 3 interface and keyboard integration it provides.

How the heck do I get Gnome to forget about fallback mode, I've tried tons of things, I've reinstalled Gnome, removed all the configuration files I can find or have located on various other posts relating to Gnome 3 and I'm just totally stumped.

Can anyone help with this? Please.
Posts: 2
Joined: Thu Nov 03, 2011 12:00 am
Location: Augusta, Western Australia

OpenGL Configuration

Postby splurben » Tue Sep 11, 2012 4:10 am

Although X11 was loading the nVidia proprietary driver, it wasn't sending OpenGL to nVidia card.

Solution (on Gentoo):
Code: Select all
#eselect opengl set nvidia

It is fair to note that I had already uninstalled Gnome completely from the computer and deleted ALL the Gnome configuration files in /ETC, /VAR/LIB, and my user directory ~/ before this as well. I don't know if that was needed but I hope it wasn't for the sake of anyone else that hits this problem 'cause it took for f-ing ever as I'm not a Gnome developer.
Posts: 2
Joined: Thu Nov 03, 2011 12:00 am
Location: Augusta, Western Australia

Postby nelz » Tue Sep 11, 2012 7:31 am

It sounds like you may have installed an update to xorg-server and that reset the opengl link back to x11. Alternatively, there have been ebuilds for software that needed the X11 opengl to build against, so they reset the link for the duration of the compile. An aborted compilation may leave the wrong link in place.

Edit: I've re-read your original post, it appears that you never selected the nvidia opengl option. The elog message after installing the nvidia driver should have told you to do this.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
Site admin
Posts: 9046
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Return to Help!

Who is online

Users browsing this forum: No registered users and 2 guests