iPhone 4S and Mandriva

For discussing Linux compatible (or not) devices

Moderators: ChriThor, LXF moderators

iPhone 4S and Mandriva

Postby tigeir » Sun Mar 04, 2012 7:01 pm

I bought an iPhone 4S on a whim.

When I plug it in to either of my Mandriva 2011 boxes it only allows access to the photos and videos. I cannot mount the filesystem nor sync with a media player.

It shows up when I run lsusb but ifuse says:
No device found, is it connected?
If it is make sure that your user has permissions to access the raw usb device.
If you're still having issues try unplugging the device and reconnecting it.

I can access other USB devices when they are plugged in.

I have Windows in a VM but it cannot see the iPhone - presumably until I can mount it.

I've updated all the recommended software to the latest versions in the MDV repos. libimobiledevice, ifuse, usbmuxd, gtkpod

I have tried various walkthroughs - none of them work because I am unable to mount.

Any help would be appreciated.
Posts: 11
Joined: Sun Mar 19, 2006 4:04 pm

Postby heiowge » Sun Mar 04, 2012 7:56 pm

I suspect Mandriva has trained the OS to ignore iPhones out of spite! :lol:
i5 4440 3.1Ghz, Asus H87M-E motherboard, 8GB DDR3, 2GB DDR5 nVidia card, 2x500GB Seagate hd, Coolermaster 750W PSU running Mint 17.1 MATE and Win7

HP mini, 1.66 Ghz Intel atom processor, 2 GB DDR3, 320 GB hd, Mint 17 MATE
LXF regular
Posts: 1919
Joined: Wed Feb 27, 2008 8:21 pm
Location: Cheshire, UK

Postby donoreo » Mon Mar 05, 2012 3:50 pm

I have not been able to get my 4S to show up in OpenSuse either.
I cannot deny anything that I did not say.
User avatar
LXF regular
Posts: 788
Joined: Mon Apr 11, 2005 1:49 pm
Location: Toronto, Ontario, Canada

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest