Page 2 of 2

PostPosted: Sat Nov 26, 2005 9:05 pm
by Rhakios
Actually, what I was hoping for was a description of the hardware you are using. Otherwise it's guesswork I'm afraid. Are you using an ADSL modem/router or cable modem, or what? Am I correct in surmisng that you connect to it via your network card?

PostPosted: Sat Nov 26, 2005 9:15 pm
by Gorky
1. It is a cable modem.

2. I have builtin network card on the motherboard.

Everything works smoothly in Windows XP side.

The only problem in Linux is that I can't go to the Internet.

The Openoffice wordprocessor works fine. I can work with script language on the shell. The GIMP works fine. I can format floppy disks.

[ A friend of mine suggested buying a new NIC card and put it inside. Would you believe changing the NIC? I don't think it will make any difference because things are working smoothly on Windows XP side.]

PostPosted: Sat Nov 26, 2005 9:40 pm
by Rhakios
I don't think changing your network card would be likely to make a difference if ifconfig is showing that you have a valid IP address.
I don't know if you reboot straight into Mandriva from Windows, but what you could try is shutting your computer down completely, giving the cable modem a chance to lose its network connection (five minutes should do), then boot up into Mandriva and see if it works. Check with ifconfig that you have a valid IP and check /etc/resolv.conf to see if you have your ISP's nameserver listed there.

PostPosted: Sat Nov 26, 2005 9:55 pm
by Gorky
When the computer starts, LILO comes and starts Mandriva. It gives me 30 seconds to change to Windows XP. So my default is Mandriva Linux.

The shutting down and wait for for 10 minutes option didn't work. I tried it several times.

However, you mentioned resolve.conf file in the 'etc' folder. I will look at it. A friend of mine came with a similar suggestion. He said the problem is in scripts pertaining to network card. I ha ve to do some changes there.
I looked at the 'etc' folder. I couldn't find anything to change there. There should be something related to the NIC. I found nothing.

I will look at the file you mentioned.

PostPosted: Sat Nov 26, 2005 10:14 pm
by Gorky
I checked the 'resolve.conf' file on the 'etc' folder.

# cat resolve.conf



Search localhost

The above 3 entries seem fine. What do you think?

PostPosted: Sat Nov 26, 2005 10:31 pm
by Rhakios
Indeed they do. It's a mystery to me how you can get an IP and nameservers via DHCP and still not be able to access the internet normally.

The only odd thing looks to me to be the bit that says "Search loclahost". Connecting direct to my router and getting everything via DHCPI just get:

[rhakios@atropos ~]$ cat /etc/resolv.conf

Well, there's something odd going on, it looks as though your network card, while configured, is not acting as the default gateway. I have no idea why and as I'm afraid that I'm not a network guru I can't tell what it is.

PostPosted: Sat Nov 26, 2005 10:45 pm
by Gorky
I will edit the file and remove the words 'search localhost' and try again. Now it is too late. I must sleep now as I have some plans to go to the gym tomorrow morning.

I have a bad habit of training 3 times a week at the gym.

I will do this tomorrow evening and post here. Thank you for today's support. Your support worth millions to me.

Good Night!

PostPosted: Sun Nov 27, 2005 11:52 am
by Rhakios
The only problem with that tactic might be that the contents of /etc/resolv.conf are supposed to be generated dynamically as your network comes up, so whatever you edit out now will only be back after the next boot.

PostPosted: Fri Jan 20, 2006 3:37 am
by alpheus
I was able to get out to the net by disabling my ethernet connection and used a dial up modem. Mandriva wants to use my ethernet/router for the primary DNS so Idisabled that as well. My ISP becomes the DNS. Mail; and firefox then respond to my modem connection. My situation is somewhat different as I must us dial up, no DSL out here. However I do have a LAN and want to use my ethernet for that. I just can't seem to do both atthe same time.

Using the system configuration tools/Netwrking let me get this far.