Abiword 3.0.2

The place to post if you need help or advice

Moderators: ChriThor, LXF moderators

Abiword 3.0.2

Postby fede » Fri Feb 24, 2017 3:35 am

I was excited to read the Abiword HotPicks review in in LXF 220, as it seemed to promise that the LaTeX equation editor was back (I used to rely on it quite a bit, until it disappeared from the more recent versions). The site seems to offer Ubuntu packages, but they are no later then 3.0.1 (which is what you get from the Ubuntu repositories anyway). The review (and the site) seemed to promise that compiling from source was trivial (just the usual ./configure && make && sudo make install), but the result was (after a list of things that did work)
------
gtk+-3.0 >= 3.0.8 gtk+-unix-print-3.0 librsvg-2.0 >= 2.16.0
x11) were not met:

No package 'fribidi' found
No package 'libgsf-1' found
No package 'wv-1.0' found
No package 'libxslt' found
No package 'cairo-pdf' found
No package 'cairo-ps' found
No package 'pangocairo' found
No package 'gtk+-3.0' found
No package 'gtk+-unix-print-3.0' found
No package 'librsvg-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DEPS_CFLAGS
and DEPS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
-----
So, it didn't get installed. No idea what these missing packages are, nor where one could find them (sudo apt-get install can't locate them). Any idea? Or we just need to wait until the official repos catch up?

Thanks
fede
LXF regular
 
Posts: 106
Joined: Thu Sep 01, 2005 3:23 am

Return to Help!

Who is online

Users browsing this forum: Exabot [Bot] and 5 guests