Page 1 of 1

Zenwalk 4.0 is out.

PostPosted: Mon Nov 20, 2006 9:18 pm
by spottedcat
Had a look at the Zenwalk first thing this morning and found that version 4.0 had just been released, so I downloaded it. I'm posting from it now and very pretty it looks too. Boots up quickly as well.

Only two minor issues with the installer. It was probably my mistake, but I managed to get 'Driver "vga" ' instead of 'Driver "i810" ' in xorg.conf and the xserver crashed. Quickly fixed though. I'll try installing it on my Intel graphics laptop later this week to see what, if anything, I did wrong. And I declined the offer of LILO. It doesn't have GRUB as an option, but I managed to get it booting from GRUB from another partition of this multiboot with the help of this page from their wiki.

I have next to no experience of the Xfce desktop, so I have a question. When using Gnome all I have to do to connect to my NAS fileserver is to select Places > Connect to Server, choose either ftp or Windows share, put in the server name or IP address, and an icon is placed on the desktop which I can click to get a Nautilus window. I can't find a similar thing in Xfce. I can access the fileserver with gFTP or from a browser but I can't open files directly into an application which is what I can do with a fileserver nautilus window in Gnome.

Is there an answer to this?

RE: Zenwalk 4.0 is out.

PostPosted: Tue Nov 21, 2006 8:38 am
by M0PHP
Yep, you edit the /etc/fstab file ;)

Something like this was suggested in their forums:

  1. Create the mount directory:
    Code: Select all
    # mkdir /mnt/server
  2. Edit /etc/fstab, and add the following line (*):
    Code: Select all
    //server/share /mnt/server smbfs noauto,users,username=<user>,password=<pass> 0 0
  3. Run:
    Code: Select all
    # mount /mnt/servershare
  4. Now you can browse the share with Thunar

* Don't forget to leave an empty line at the end of /etc/fstab or it will throw a wobbler :P

RE: Zenwalk 4.0 is out.

PostPosted: Tue Nov 21, 2006 10:52 pm
by spottedcat
Thanks for that MOPHP. Unfortunately, the fileserver is doing something peculiar and it didn't work. I've found that I can connect reliably to it using FTP in a Gnome distro from the Places menu, but the Windows Share protocol sometimes works in one distro but usually not in another. Goodness knows what's happening.

Also - I don't know whether this is new to Zenworks - there is an app called FuseSMBTool that tries to mount shares to /home/username/smb, even though there is no such directory unless one creates it oneself. :roll: That doesn't work either but I think the problem is on my fileserver. Not a big issue because FTP is quicker anyway.

I've now installed Zenworks on my laptop (with intel 915GM). This time it did offer me the i810 driver rather than vga (that wasn't my mistake after all), but I checked xorg.conf from Ubuntu on another partition before booting and the VertRefresh values and Display Modes were wrong. Again, easily remedied but a warning for others and clearly not a distro for the complete newcomer.

(It doesn't come with nano, pico or emacs. I had to use vi :()

Yes - know about the empty line. Learnt that from Stanton-Finley. :wink:

RE: Zenwalk 4.0 is out.

PostPosted: Wed Nov 22, 2006 8:51 am
by M0PHP
Ah right.. which fileserver is it? Do you not have the option of using NFS at all, which would be better for linux?

I've heard of that but never came across it.

I always find I have to modify Xorg.conf no matter which PC I install any distro on - sometimes I have to add the native resolution manually (mostly 1280x1024) and always need to change the Sync/Refresh values. I've now got all my monitor's settings written on Post-It notes so I'm not fishing around the manuals in the bottom of a drawer :lol:

Plus I end up making a balls-up of xorg.conf first time round as I can't really use vi that good.

You might want to pay a visit to for slackware installable software (including nano) ;)

Ah, good ;)

Re: RE: Zenwalk 4.0 is out.

PostPosted: Wed Nov 22, 2006 10:42 am
by spottedcat
M0PHP wrote:Ah right.. which fileserver is it?

This cheap and nasty one. :oops:

M0PHP wrote:Do you not have the option of using NFS at all, which would be better for linux?

Er... no. :)

M0PHP wrote:I always find I have to modify Xorg.conf no matter which PC I install any distro on - sometimes I have to add the native resolution manually (mostly 1280x1024) and always need to change the Sync/Refresh values.

Well - Fedora, Ubuntu and SuSE have never failed me yet on different machines - even on my 1280x800 laptop which is a resolution some people experience problems with. Probably a BIOS issue which, fortunately, I don't have. In case you missed it, you might be interested in this thread. As Rhakios says, how does Fedora do it?

M0PHP wrote:You might want to pay a visit to for slackware installable software (including nano)

Thanks for the tip, and thanks for your interest.

Not only have I not used Xfce before, I've never used a Slackware based distro before. Feeling a bit at sea - you see. ;)

RE: Re: RE: Zenwalk 4.0 is out.

PostPosted: Wed Nov 22, 2006 1:03 pm
by M0PHP
AAhh one of those ethernet disk enclosures :) I'm willing to bet that it has some sort of embedded *nix OS on it as well :cry:

I'm relatively new to slackware-* distros as well, I do miss the apt-get of debian/ubuntu; but zenwalk is just so much quicker than xubuntu.

Zenwalk 4.0.

PostPosted: Sun Nov 26, 2006 4:24 pm
by spottedcat
A bit of an update - might be useful to someone.

I managed to get ipw2200 wireless working, but not with the wifi-radar app that comes with the distro. I put the version 3.0 ipw2200 firmware in /lib/firmware and wifi-radar could see both my network and those of my neighbours, but although I could put a WPA passkey in, it wouldn't connect. So instead I used this howto and I'm posting from Zenwalk wirelessly now. I put the 'wpa-supplicant..' and 'dhcpcd..' start lines in /etc/rc.d/rc.local and now the thing connects at bootup without me having to do anything else.

And the connection is solid. I was downloading something this morning, there was a sudden hailstorm, a very bright flash outside and a nearly-immediate loud crack of thunder. The lights on the router all went out and the download stopped. :( Fortunately I have surge protectors in the right places. Anyway, after a little while, the lights on the router came on one by one as it re-established an adsl connection and then the laptop reconnected to the router without me having to do anything at all. :) I doubt whether network manager in Ubuntu or Fedora would have managed that and I'm damned sure that Windows would have made a song and dance about it.

MOPHP, thanks once again for that link. I got nano from it. I also found joe, a similar basic editor, in the Zenwalk repository. There's also a nice gtk-based (I think) editor called geany that comes with Zenwalk. I hadn't come across it before but I haven't yet found out how to open it from a terminal, if that's possible, so I haven't been able to do any root editing of system files with it.

I've also managed to get the Sony Vaio Fn keys working - which pleases me no end. Vaio laptop screens are incredibly bright and need to be dimmed in use, but the Fn keys use Windows software drivers. Fortunately, there are GPL Linux ones floating around and by experimenting with a mish-mash of howtos for Ubuntu and Fedora, and learning a bit about where Slackware puts various files in the process, I got the job done. 8)

Edit: - about the wireless. The howto says glibly, 'wpa-supplicant is required,' but wpa-supplicant doesn't come with the default installation. And for some reason Zenwalk doesn't recognise my wired ethernet connection. Still haven't solved that. So I couldn't connect to the internet to download a package I needed to connect to the internet. Catch 22 :wink:

RE: Zenwalk 4.0.

PostPosted: Sun Nov 26, 2006 5:23 pm
by M0PHP
I think the command to run GUI apps as root is something along the lines of gksu or gksudo - can't remember :oops:.

RE: Zenwalk 4.0.

PostPosted: Sun Nov 26, 2006 6:29 pm
by spottedcat
I'd already tried $ gksudo geany. I get the "we trust you have received the usual lecture..." message, but it hangs before anything opens up. Tried # geany, but get "Gtk warning: cannot open display." - as I had half-expected, which is a pity because you can invoke gedit from a root terminal in Gnome. It has a massive moan at you but gedit does open up.

I'll have a look in the Geany help later when I have time. It looks to be more comprehensive than some.

Edit: Just tried $ gksu geany. It works. Thanks for that. Hadn't been able to see the wood for the trees - too indoctrinated by Ubuntu. :oops:

RE: Zenwalk 4.0.

PostPosted: Sun Nov 26, 2006 8:26 pm
by M0PHP
Hehe, no problem spottedcat... I'm learning as I go along too :D

PostPosted: Wed Dec 20, 2006 1:17 pm
by Marrea
Just to say that I have recently installed Zenwalk 4.0 on one of my laptops (replacing Zenwalk 2.8 which I was running previously). I must say each version of this distro seems to improve considerably over the previous.

I was pleasantly surprised to see that encrypted DVDs play straight out of the box too.

Wish they'd offer Grub as an option though. Because I use Grub on all my other distros I always, always forget with Zenwalk to re-run lilo after a kernel upgrade, only remembering once I've switched off the machine, and then end up with 99, 99, 99, 99, 99 ....... when I reboot !!!

PostPosted: Fri Dec 22, 2006 9:44 pm
by Marrea
In spite of running into a slight problem after upgrading Netpkg (now resolved), I continue to be impressed. Nice and easy to encode in mp3 format - just install lame via Netpkg, open up Grip, insert the full path to lame in the configuration encoder executable box and away you go.

And this distro looks really good on my laptop. I've changed the Window Manager style to Galaxy and no matter which application I open they all have a very crisp, attractive appearance. A real pleasure to use.

PostPosted: Fri Dec 22, 2006 10:14 pm
by spottedcat
Unfortunately, I'm getting a couple of minor issues with Zenwalk on my laptop. I can't get touchpad scrolling to work. (It works fine in Dapper and Fedora.) I've tried installing the synaptics driver recommended on the Zenwalk forum and fiddling with xorg.conf but without success.

The other thing is that the fan runs continuously - unlike in Ubuntu and Fedora.

Anyway, I won't get rid of Zenwalk just yet - I've set up sufficient partitions for now. Perhaps I'll try to solve these two some time but I've been somewhat distracted these last few weeks getting to grips with Gentoo. :?

PostPosted: Sun Dec 24, 2006 6:17 pm
by Marrea
Well I have to confess that touchpad scrolling doesn't work in Zenwalk on my laptop either, but then I never use touchpads anyway. Hate the things, far too imprecise ! :D

By the way, spottedcat, I am most impressed that you are venturing into Gentoo. One of these days I hope to get round to it as well.