ClamAv - woody to sarge upgrade ?

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

ClamAv - woody to sarge upgrade ?

Postby youlikeicecream » Tue Aug 09, 2005 2:44 pm

Hiya. Am currently using ClamAv for my ubuntu hoary installation. I have installed Clamav from the debian volatile repository, which I believe is 'woody' only distributions.

I need to upgrade to the 'Sarge' distribution of the Debian base in order to update my clamav installation.

Basically, How do I upgrade from ubuntu Hoary -> Sarge without having to completely re-install and lose everything ?

Much appreciated
Mike :)
youlikeicecream
LXF regular
 
Posts: 721
Joined: Fri Jun 03, 2005 11:40 am
Location: Oxford

RE: ClamAv - woody to sarge upgrade ?

Postby Erin » Tue Aug 09, 2005 8:07 pm

Hmm, 0.83 is available for Hoary and 0.85 is in the backports repository. No need for Debian at all.

Unless you really want Debian, stick with Ubuntu. Just modify your repository list, remove Clam and install the Ubuntu version.

Erin
Just beneath my skin I'm screaming. Faithless::Insomnia.
Dual PIII 550 with Ubuntu [semi-bleeding].
User avatar
Erin
LXF regular
 
Posts: 141
Joined: Thu Apr 07, 2005 7:35 pm
Location: The Olde Smoke south of the River

Postby youlikeicecream » Wed Aug 10, 2005 3:07 am

Thanx for your reply :)

Sorry, my message earlier may have been a little confusing ... I do want to keep Ubuntu, but it is based on the 'woody' debian dist (i thought) which the new version of clamav does not support (as far as I know) ....

I did try to install from the 'sarge' repositories but got a message like

' No public key available' when trying to refresh apt-get.

Then I realised that Ubuntu 'hoary' had clamav within one of the default/commented-out sources in /etc/apt/sources.list

I installed that version but it won't let me update using freshclam ... said my version of clamav needed to be updated ... I decided to install the clamav-data file instead of freshclam, and it does not recognise as many viruses and trojans as freshclam.

I hope this is a better description of the problem.

Mike :)
youlikeicecream
LXF regular
 
Posts: 721
Joined: Fri Jun 03, 2005 11:40 am
Location: Oxford

Postby youlikeicecream » Wed Aug 10, 2005 8:27 am

Hiya, erin.

Added this source

deb http://archive.ubuntu.com/ubuntu/ hoary-backports main universe multiverse restricted

to my /etc/apt/sources.list

marked my upgrades ... clamav update to .86 from .83 ....

your a star, thanx :)

Mike
youlikeicecream
LXF regular
 
Posts: 721
Joined: Fri Jun 03, 2005 11:40 am
Location: Oxford

Postby Erin » Wed Aug 10, 2005 7:57 pm

No worries. Glad to help.

Erin
Just beneath my skin I'm screaming. Faithless::Insomnia.
Dual PIII 550 with Ubuntu [semi-bleeding].
User avatar
Erin
LXF regular
 
Posts: 141
Joined: Thu Apr 07, 2005 7:35 pm
Location: The Olde Smoke south of the River


Return to Help!

Who is online

Users browsing this forum: No registered users and 3 guests

cron