Xorg Transparency Problem

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Xorg Transparency Problem

Postby comcamel » Fri Jul 15, 2005 9:28 am

Well i have been trying to get transparency to work in KDE which i have recently seen in the new magazine which i have bought. After figuring out, that i had put the section in the wrong place, xorg has had problems with it.

Section "Extensions" Option "Composite" "Enable" EndSection

this is the command i mean. When i boot up, i cannot start up the X server, but when i access my logs for it gives the output of sasying something on the lines that it cannot find or doesn't see the extension. I have got Suse 9.3 with the nvidia driver, but i don't suppose i would have to download any extensions or library files, aswell as me typing it in wrong.

Currently i am on holiday and i don't have freqeuent internet access. However i am currently trying to relieve and try again...

Hope you can help thanks comcamel
comcamel
LXF regular
 
Posts: 205
Joined: Thu Apr 07, 2005 5:35 pm

RE: Xorg Transparency Problem

Postby graham » Fri Jul 15, 2005 10:00 am

Your extensions part looks good. This works for me:

Code: Select all
Section "Extensions"
  Option "Composite"      "Enable"
  Option "RENDER"         "Enable"
EndSection


But! You also need to add a couple of lines to the Device section for the nvidia driver. Mine reads:

Code: Select all
Option  "RenderAccel"   "true"
Option  "AllowGLXWithComposite" "true"


My Device section looks like this:

Code: Select all
Section "Device"
  BoardName    "GeForce 6600/GeForce 6600 GT"
  BusID        "1:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  Screen       0
  Option       "Rotate" "off"
  VendorName   "NVidia"
  Option       "NvAGP"  "1"
  Option       "RenderAccel"   "true"
  Option       "AllowGLXWithComposite" "true"
EndSection


Hope that helps!
User avatar
graham
Site admin
 
Posts: 37
Joined: Tue Apr 12, 2005 9:31 am

RE: Xorg Transparency Problem

Postby comcamel » Sat Jul 16, 2005 10:17 pm

i have solved the problem, as looking finally when i had chance, i needed to install the composite manager rpm, which is a bit dodgy as i would expect to be installed. Now i have to sort out the speed issues. As it is slow...

Option "RenderAccel" "true"

this is the code piece i have seen on the internet that will improve speed like you posted, however i didn't know you had to put in the render option line, however since i have got an nvidia card i will find your details, useful! Thanks for the help that will be useful later!

comcamel
comcamel
LXF regular
 
Posts: 205
Joined: Thu Apr 07, 2005 5:35 pm


Return to Help!

Who is online

Users browsing this forum: Exabot [Bot] and 1 guest