Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Mono sound Creative SB Live 24 bit
Goto page 1, 2  Next
 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
fairless



Joined: Sat May 07, 2005 1:31 am
Posts: 27

PostPosted: Sat May 07, 2005 1:44 am    Post subject: Mono sound Creative SB Live 24 bit Reply with quote

I installed Mandriva 2005 LE x86_64 last week on a machine with a MSI K8N Neo4 SLI Platinum Board with on-board Creative SB Live 24 bit sound (driver ca0106).
Everything was detected and worked first time (including my Speedtouch USB modem connection to BT Smile, however the sound is coming out of one channel only i.e. mono (single pair of stero speakers attached). I believe I may have traced the problem through amixer, but can not see how to remove the mono setting and enter left/right volume %s:

[root@earth neil]# amixer -c 0
Simple mixer control 'AC97 in',0 Capabilities: cswitch cswitch-joined cswitch-exclusive Capture exclusive group: 0 Capture channels: Mono Mono: Capture [off]
Simple mixer control 'Analog Center/LFE',0 Capabilities: volume Playback channels: Front Left - Front Right Limits: 0 - 255 Mono: 212 [83%] Front Left: Front Right:
Simple mixer control 'Analog Front',0 Capabilities: volume Playback channels: Front Left - Front Right Limits: 0 - 255 Mono: 204 [80%] Front Left: Front Right:
Simple mixer control 'Analog Rear',0 Capabilities: volume Playback channels: Front Left - Front Right Limits: 0 - 255 Mono: 205 [80%] Front Left: Front Right:
Simple mixer control 'Analog Unknown',0 Capabilities: volume Playback channels: Front Left - Front Right Limits: 0 - 255 Mono: 158 [62%] Front Left: Front Right:
Simple mixer control 'CAPTURE feedback into PLAYBACK',0 Capabilities: volume Playback channels: Front Left - Front Right Limits: 0 - 255 Mono: 197 [77%] Front Left: Front Right:
Simple mixer control 'SPDIF Center/LFE',0 Capabilities: volume Playback channels: Front Left - Front Right Limits: 0 - 255 Mono: 196 [77%] Front Left: Front Right:
Simple mixer control 'SPDIF Front',0 Capabilities: volume Playback channels: Front Left - Front Right Limits: 0 - 255 Mono: 195 [76%] Front Left: Front Right:
Simple mixer control 'SPDIF Out',0 Capabilities: pswitch pswitch-joined Playback channels: Mono Mono: Playback [off]
Simple mixer control 'SPDIF Rear',0 Capabilities: volume Playback channels: Front Left - Front Right Limits: 0 - 255 Mono: 160 [63%] Front Left: Front Right:
Simple mixer control 'SPDIF Unknown',0 Capabilities: volume Playback channels: Front Left - Front Right Limits: 0 - 255 Mono: 142 [56%] Front Left: Front Right:
Simple mixer control 'SPDIF in',0 Capabilities: cswitch cswitch-joined cswitch-exclusive Capture exclusive group: 0 Capture channels: Mono Mono: Capture [off]
Simple mixer control 'SPDIF out',0 Capabilities: cswitch cswitch-joined cswitch-exclusive Capture exclusive group: 0 Capture channels: Mono Mono: Capture [off]
Simple mixer control 'SRC out',0 Capabilities: cswitch cswitch-joined cswitch-exclusive Capture exclusive group: 0 Capture channels: Mono Mono: Capture [off]
Simple mixer control 'i2s in',0 Capabilities: cswitch cswitch-joined cswitch-exclusive Capture exclusive group: 0 Capture channels: Mono Mono: Capture [off]
Simple mixer control 'i2s mixer out',0 Capabilities: cswitch cswitch-joined cswitch-exclusive Capture exclusive group: 0 Capture channels: Mono Mono: Capture [on]

None of the standard controls alsamixer/kmix seem to be able to change the system from mono to stereo. Further system info. follows:

[root@earth neil]# lspci | grep audio
01:0d.0 Multimedia audio controller: Creative Labs SB Audigy LS

[root@earth neil]# lsmod | grep snd
snd-seq-dummy 3332 0
snd-seq-oss 32256 0
snd-seq-midi-event 7552 1 snd-seq-oss
snd-seq 51392 5 snd-seq-dummy,snd-seq-oss,snd-seq-midi-event
snd-seq-device 7952 3 snd-seq-dummy,snd-seq-oss,snd-seq
snd-pcm-oss 50976 0
snd-mixer-oss 17024 1 snd-pcm-oss
snd-ca0106 27972 1
snd-ac97-codec 79184 1 snd-ca0106
snd-pcm 87820 3 snd-pcm-oss,snd-ca0106,snd-ac97-codec
snd-timer 20872 2 snd-seq,snd-pcm
snd-page-alloc 8712 2 snd-ca0106,snd-pcm
snd 49896 11 snd-seq-oss,snd-seq,snd-seq-device,snd-pcm-oss,snd-mixer-oss,snd-ca0106,snd-ac97-codec,snd-pcm,snd-timer
soundcore 8352 1 snd

[root@earth neil]# cat /proc/asound/cards
0 [CA0106 ]: CA0106 - CA0106
MSI K8N Diamond MB [SB0438] at 0xde00 irq 225

[root@earth neil]# cat /proc/asound/devices
19: [0- 3]: digital audio playback
27: [0- 3]: digital audio capture
18: [0- 2]: digital audio playback
26: [0- 2]: digital audio capture
17: [0- 1]: digital audio playback
25: [0- 1]: digital audio capture
16: [0- 0]: digital audio playback
24: [0- 0]: digital audio capture
0: [0- 0]: ctl
1: : sequencer
33: : timer

[root@earth neil]# cat /proc/asound/pcm
00-00: ca0106 : CA0106 : playback 1 : capture 1
00-01: ca0106 : CA0106 : playback 1 : capture 1
00-02: ca0106 : CA0106 : playback 1 : capture 1
00-03: ca0106 : CA0106 : playback 1 : capture 1

[root@earth neil]# cat /proc/asound/oss/devices
0: [0- 0]: mixer
3: [0- 3]: digital audio
12: [0-12]: digital audio
1: : sequencer
8: : sequencer

[root@earth neil]# ls /dev/*dsp* -l
crw-rw---- 1 neil audio 14, 12 May 7 00:41 /dev/adsp
crw-rw---- 1 neil audio 14, 3 May 7 00:41 /dev/dsp

[root@earth neil]# ls /dev/sound/*dsp* -l
lrwxrwxrwx 1 root root 7 May 7 00:41 /dev/sound/adsp -> ../adsp
lrwxrwxrwx 1 root root 6 May 7 00:41 /dev/sound/dsp -> ../dsp

Any suggestions on how to resolve would be appreciated.

Thanks,

Neil
Back to top
View user's profile Send private message
Erin
LXF regular


Joined: Thu Apr 07, 2005 8:35 pm
Posts: 141
Location: The Olde Smoke south of the River

PostPosted: Sat May 07, 2005 8:22 pm    Post subject: RE: Mono sound Creative SB Live 24 bit Reply with quote

SB are almost fully supported for all versions. Try running 'alsamixer' or 'alsamixergui'. I have never used Mandriva so have no idea how it configures anything. You could also try the Alsa site [http://www.alsa-project.net/] and see what it says about limitations on the snd-ca0106/ca0106 module.

Erin
_________________
Just beneath my skin I'm screaming. Faithless::Insomnia.
Dual PIII 550 with Ubuntu [semi-bleeding].
Back to top
View user's profile Send private message
Guest






PostPosted: Sat May 07, 2005 11:53 pm    Post subject: RE: Mono sound Creative SB Live 24 bit Reply with quote

I've run both but they don't give the option to change the left and right volumes, just each mixer of which the "Analog Front" changes the volume coming out of my left speaker. I've spent the week trawling the web including the Alsa and Creative sites, testing various things I've found but can't find anything to get the right speaker to output or a mixer option for individual left/right volume. The only thing I've found which I think could be causing it is the amixer results as above. Each mixer shows mono with no value for left and right. I tried to run something like "amixer -c 0 sset front,0 80%, 80%" which changed the mono value to 80%, but again, did not affect the left and right. I seem to be missing something fundamental which is setting it all as mono.

Regards

Neil Sad
Back to top
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8457
Location: Warrington, UK

PostPosted: Sun May 08, 2005 8:58 am    Post subject: RE: Mono sound Creative SB Live 24 bit Reply with quote

alsamixer lets you control the left/right volumes separately, but the keyboard shortcuts aren't particularly intuitive. IOW I can't remember them Smile It's something like Q to increase keft and W to increase right, but check the manual.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
fairless



Joined: Sat May 07, 2005 1:31 am
Posts: 27

PostPosted: Sun May 08, 2005 10:37 am    Post subject: RE: Mono sound Creative SB Live 24 bit Reply with quote

The man says: The B or = key adjusts the balance of volumes on left and right channels.
M toggles muting for the current channel (both left and right). If the hardware supports it, you can mute left and right independently by using , (or <) and . (or >) respectively.
I've tried all, but don't seem to make any difference. It shows two values for the "Analog Front" mixer which increase decrease using the standard controls, but does not resolve the mono sound that I'm getting.
:cry

Neil
Back to top
View user's profile Send private message
ghjhj
Guest





PostPosted: Sun May 15, 2005 5:42 pm    Post subject: hjhjh Reply with quote

Back to top
fairless



Joined: Sat May 07, 2005 1:31 am
Posts: 27

PostPosted: Thu May 19, 2005 3:46 pm    Post subject: RE: hjhjh Reply with quote

I've managed to fudge stereo by slightly pulling out the jack, however, if I change the balance it either increases or decreases the volume of both and not left/right, thus suggesting I'm still only getting one channel, although now out of both sopeakers. Any other suggestions to resolve this? Many thanks, Neil Confused
Back to top
View user's profile Send private message
Nigel
LXF regular


Joined: Fri Apr 08, 2005 9:03 pm
Posts: 1141
Location: Gloucestershire, UK

PostPosted: Thu May 19, 2005 4:02 pm    Post subject: RE: Mono sound from SB Live Reply with quote

Are you absolutely sure the problem isn't your speaker jack (or socket) ? Do the speakers work OK on anything else (walkman, MP3 player etc) ? If you plug a pair of headphones into the speaker jack do you get stereo from them ?
_________________
Hope this helps,

Nigel.
Back to top
View user's profile Send private message
fairless



Joined: Sat May 07, 2005 1:31 am
Posts: 27

PostPosted: Fri May 20, 2005 1:23 pm    Post subject: RE: Mono sound from SB Live Reply with quote

Hi Nigel, have tried headphones and still only getting sound out of one ear, same thing if I plug in to the front headphone socket. On top of this balance seems to adjust total volume and not left right (whether using my fudge or not). I've managed to adjust left and right volumes on various controls using alsamixergui, but again this does not change the single channel output, or reflect the volumes as one would expect. Does any one know if the Sounblaster ca01056 driver has any major issues, as I have n't found anything mentioned? Cheers Neil
Back to top
View user's profile Send private message
Nigel
LXF regular


Joined: Fri Apr 08, 2005 9:03 pm
Posts: 1141
Location: Gloucestershire, UK

PostPosted: Fri May 20, 2005 7:28 pm    Post subject: RE: Mono sound from SB Live Reply with quote

Hmmm... I have an Soundblaster Audigy in my home box and a Soundblaster pci 128 in the box at work, and both work fine under various versions of SuSE. The Audigy uses the emu10k1_gp module under SuSE 9.2 and I seem to remember that the pci128 uses something very similar (emu<something>). If you do an lsmod from a terminal prompt that will list all the modules you are running - do you have an emu<anything> listed, or is your driver actually reported as ca01056 ? If the latter, you might want to try telling the machine you have a different model SoundBlaster and see what happens.
_________________
Hope this helps,

Nigel.
Back to top
View user's profile Send private message
fairless



Joined: Sat May 07, 2005 1:31 am
Posts: 27

PostPosted: Sat May 21, 2005 3:40 am    Post subject: RE: Mono sound from SB Live Reply with quote

Hi Nigel, no emu shown in lsmod. lsmod |grep snd returned a number of entries.
In harddrake it detects the soundcard as an Audigy LS which I believe is wrong, should be a SB Live 24bit. CAn't see where to change the card, I can however change the driver and have selected emu10k. Since rebooting aumix filed to load and KDE is displaying the following error: Informational artsmessage
Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such file or directory)
The sound server will continue, using the null output device.

Kmix is showing crossed out. lsmod |grep snd no longer returns anything. But lsmod now displays:
emu10k1 67972 0
soundcore 8352 1 emu10k1
ac97_codec 19480 1 emu10k1

alsamixergui now fails with snd_ctl_open failed for default: No such file or directory.
Back to top
View user's profile Send private message
fairless



Joined: Sat May 07, 2005 1:31 am
Posts: 27

PostPosted: Sat May 21, 2005 3:55 am    Post subject: RE: Mono sound from SB Live Reply with quote

Have gone back in to harddrake and this now gives additional driver options including snd-emu10k so have tried that with the same response. Have reset to ca0106 and rebooted and arts is still complaining with:
Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for capture (Invalid argument)
The sound server will continue, using the null output device.
Now have no sound Sad
Neil
Back to top
View user's profile Send private message
fairless



Joined: Sat May 07, 2005 1:31 am
Posts: 27

PostPosted: Sat May 21, 2005 4:03 am    Post subject: RE: Mono sound from SB Live Reply with quote

OK have managed to get sound back; changed the KDE Sound System Audio device from Autodetect to OSS, but still with just a single left channel. An FYI on the KDE Sound System, from previous experience if I select anyother audio device than OSS it generates errors and no sound.

Neil
Back to top
View user's profile Send private message
Nigel
LXF regular


Joined: Fri Apr 08, 2005 9:03 pm
Posts: 1141
Location: Gloucestershire, UK

PostPosted: Sun May 22, 2005 2:01 pm    Post subject: RE: Mono sound from SB Live Reply with quote

This is getting way beyond me. I'm afraid. One more suggestion to try, though... get yourself the latest Knoppix CD and boot from that. Does it detect your soundcard ? If so, what does it think it is, and do you get stereo sound ?

Also, I know it's a daft question, but do you know for certain that this on-board soundcard does actually produce stereo sound ? Does it allegedly do more than just stereo (ie stereo + centre, 4+1, 5+1 etc) ? If so, are you plugging the speakers into the centre outlet rather than the stereo one ?
_________________
Hope this helps,

Nigel.
Back to top
View user's profile Send private message
fairless



Joined: Sat May 07, 2005 1:31 am
Posts: 27

PostPosted: Sun May 22, 2005 5:58 pm    Post subject: RE: Mono sound from SB Live Reply with quote

Hi Nigel, the on board sound apparently supports 2-, 4-, 6- and 8-channel audio, however having tried all the phone jacks on the back panel only the 2-channel mode stereo jack gives sound output. The headphone jack on the front also works, but again only single channel. I'll have a go with knoppix though, good idea, I'm sure I'll have a copy on one of the many Linux Format DVD's I have Smile

Cheers Neil.
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast