Wireless

For discussing Linux compatible (or not) devices

Moderators: ChrisThornett, LXF moderators

RE: Netgear wg111 usb

Postby ladi » Fri Dec 09, 2005 3:44 pm

Hi there,

I run Zenwalk 1.3 and Slackware 10.1 happily with ndiswrapper and a D-Link DWL-G122 wireless USB adapter.

What version of ndiswrapper are you using? I would recommend v1.5 minimum, although I have read that v1.7 is out. You will also need the latest Windows XP drivers for your adapter from the manufacturer's website. What level of encryption are you using?

Let me know the versions you have and I will be quite happy to step you through how I fixed mine. Also, if you'll tell us what you tried, and what problems/errors you encountered, that would help :-)

Ladi
User avatar
ladi
LXF regular
 
Posts: 152
Joined: Fri May 27, 2005 12:26 pm
Location: Ashford, Kent

Netgear wg111

Postby acraigon » Sun Dec 11, 2005 9:52 am

I have managed to get Zenwalk to recognize my card using NDISWrapper.
1 - Compile kernel with wireless
2 - Install NDISWrapper
3 - Install drivers into the NDISWrapper directory
4 - Load the driver ndiswrapper -i net111v2
5 - List to make sure driver is there ndiswrapper -l
6 - modprobe ndiswrapper into kernel
7 - lsmod to check whether everything is ok
8 - setup using iwconfig
acraigon
 
Posts: 26
Joined: Wed May 11, 2005 6:46 pm

Re: RE: Netgear wg111 usb

Postby acraigon » Sun Dec 11, 2005 3:14 pm

Let me know the versions you have and I will be quite happy to step you through how I fixed mine. Also, if you'll tell us what you tried, and what problems/errors you encountered, that would help :-)

[/quote]

I am using version 2.0.1 of Zenwalk and version 1.6 of ndiswrapper. I said that it sees my card using iwconfig but I am unable to connect to the router. I can change various settings with iwconfig and the iwconfig command shows wlan0 with settings which look fine. I have tried connecting to the router using http://192.168.0.1 but cannot connect. I tried downloading xsupplicant but that did not appear to work.
acraigon
 
Posts: 26
Joined: Wed May 11, 2005 6:46 pm

RE: Netgear wg111 usb

Postby RD » Sun Dec 11, 2005 6:51 pm

Hi

turns out after i took the router back to where i bought it from that it was broke :( luckly for me they gave me a brand new fully working one and now i get a full signal all the time :)
RD
LXF regular
 
Posts: 272
Joined: Mon Jul 25, 2005 2:53 am
Location: irc.ixl2.net

RE: Netgear wg111 usb

Postby ladi » Sun Dec 11, 2005 7:58 pm

Hi acraigon,

The steps you have taken look ok, but I suspect that your card does not even have an IP address just yet, unless you assigned a static IP address, which is probably unlikely.

You will need to ensure that there is a DHCP server running on your LAN, preferably on your router/access point. Of course, the DHCP client needs to be running on your machine to start with! You can check to see the status of your wireless card by running ifconfig -a (as root).

I have also found that ndiswrapper 1.5 does not seem to work if you do not broadcast your ESSID. I suspect that will be the same with v1.6 as well. I'm hoping it will be fixed in v1.7, so I can change my ESSID and then switch off broadcasting. There was a document I saw that says how to get around this, but let us verify what the problem is first.

I found this document useful, and it formed the basis of the script below which I use to start my wireless card. Once it's working properly, you can plug it into rc.inet1, so that it starts automatically at boot-up. You may need a similar script to take the interface down neatly at shutdown. Please feel free to check whether it works for you. However, I use wpa_supplicant rather than xsupplicant, which I am not very familiar with. I expect, however, that they serve similar purposes. Consider using wpa_supplicant if you are using WPA.

If you do stick with xsupplicant, remember to comment out the wpa line in my script and replace it with the xsupplicant equivalent. That line tells wpa_supplicant to use ndiswrapper to connect to the AP using the security settings in the wpa_supplicant.conf file.

Let us know how it goes.

========== script follows ==============

#!/bin/bash
#load ndiwapper interface
modprobe ndiswrapper
ndiswrapper -l
# activate wireless interface
ifconfig wlan0 up
# connect to access point with WPA encryption
wpa_supplicant -Dndiswrapper -iwlan0 -c/etc/wpa_supplicant.conf -B
# start dhcp to bring up network and procure IP address
dhcpcd wlan0
ifconfig
echo "wireless configuration completed"
#End of script


========== script ends ==============
User avatar
ladi
LXF regular
 
Posts: 152
Joined: Fri May 27, 2005 12:26 pm
Location: Ashford, Kent

Re: RE: Netgear wg111 usb

Postby acraigon » Mon Dec 12, 2005 8:24 pm

[quote="ladi"]

Let us know how it goes.

Well I have wireless working on Mandrake,Suse and Redhat but still having problems with Zenwalk. I will let you know when I get it working on zenwalk as this is my operating system of choice!
acraigon
 
Posts: 26
Joined: Wed May 11, 2005 6:46 pm

RE: Netgear wg111 usb

Postby weekender » Mon Dec 12, 2005 11:06 pm

Hi,
To answer a previous query - make sure the wifi router is away/above any of those old chunky things called CRT monitors. I have one of those (being poor) and it can seriously affect the signal. Also keep the router away from any DEC phone base stations (>1m) and adjust the aerial - mine is at at 45'.

One last thought - make sure the router is running the latest stable firmware - this made a ral difference with my netgear dg834g now on v3.01.25.

Cheers
weekender
 
Posts: 2
Joined: Mon Dec 12, 2005 10:54 pm

Re: RE: Netgear wg111 usb

Postby acraigon » Sat Dec 24, 2005 11:42 am

ladi wrote:Hi acraigon,

The steps you have taken look ok, but I suspect that your card does not even have an IP address just yet, unless you assigned a static IP address, which is probably unlikely.

You will need to ensure that there is a DHCP server running on your LAN, preferably on your router/access point. Of course, the DHCP client needs to be running on your machine to start with! You can check to see the status of your wireless card by running ifconfig -a (as root).

I have also found that ndiswrapper 1.5 does not seem to work if you do not broadcast your ESSID. I suspect that will be the same with v1.6 as well. I'm hoping it will be fixed in v1.7, so I can change my ESSID and then switch off broadcasting. There was a document I saw that says how to get around this, but let us verify what the problem is first.

I found this document useful, and it formed the basis of the script below which I use to start my wireless card. Once it's working properly, you can plug it into rc.inet1, so that it starts automatically at boot-up. You may need a similar script to take the interface down neatly at shutdown. Please feel free to check whether it works for you. However, I use wpa_supplicant rather than xsupplicant, which I am not very familiar with. I expect, however, that they serve similar purposes. Consider using wpa_supplicant if you are using WPA.

If you do stick with xsupplicant, remember to comment out the wpa line in my script and replace it with the xsupplicant equivalent. That line tells wpa_supplicant to use ndiswrapper to connect to the AP using the security settings in the wpa_supplicant.conf file.

Let us know how it goes.

========== script follows ==============

#!/bin/bash
#load ndiwapper interface
modprobe ndiswrapper
ndiswrapper -l
# activate wireless interface
ifconfig wlan0 up
# connect to access point with WPA encryption
wpa_supplicant -Dndiswrapper -iwlan0 -c/etc/wpa_supplicant.conf -B
# start dhcp to bring up network and procure IP address
dhcpcd wlan0
ifconfig
echo "wireless configuration completed"
#End of script


========== script ends ==============


I have wireless working on Zenwalk now. Thanks for your script very useful.
acraigon
 
Posts: 26
Joined: Wed May 11, 2005 6:46 pm

Previous

Return to Hardware

Who is online

Users browsing this forum: Yahoo [Bot] and 0 guests