Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

wakeonlan not waking
Goto page 1, 2  Next
 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
pk_fox
LXF regular


Joined: Wed Apr 13, 2005 2:38 pm
Posts: 292
Location: Surrey, UK

PostPosted: Sat May 17, 2014 7:52 am    Post subject: wakeonlan not waking Reply with quote

Hi all, I used to be able to wake my HP Proliant server using either Windows or Linux wol clients, however that was when it was running Windows, since installing Linux ( OpenSuse ) I can't wake it up , I've tried wakeonlan / etherwake from my Debian box and EMCO tools from a Windows 7 box ( all of which worked before ) and no worky. , I've checked the MAC address and it hasn't changed ( I have known them to change by something cloning them ) so I'm asking the experts.
_________________
We can't stop here, this is bat country. Hunter S Thompson RIP.
Back to top
View user's profile Send private message
bobthebob1234
LXF regular


Joined: Thu Jan 03, 2008 9:38 pm
Posts: 1369
Location: A hole in a field

PostPosted: Sat May 17, 2014 12:36 pm    Post subject: Reply with quote

Whenever I have used wakeonlan I've had to enable it in the OS

https://help.ubuntu.com/community/WakeOnLan

(ok ubuntu instructions but OpenSuse doesn't seem to have the same level of documentation, but I would hope
Code:
sudo ethtool -s <NIC> wol g
would work on any OS!)
_________________
For certain you have to be lost to find the places that can't be found. Elseways, everyone would know where it was
Back to top
View user's profile Send private message
pk_fox
LXF regular


Joined: Wed Apr 13, 2005 2:38 pm
Posts: 292
Location: Surrey, UK

PostPosted: Sat May 17, 2014 12:56 pm    Post subject: Reply with quote

bobthebob1234 wrote:
Whenever I have used wakeonlan I've had to enable it in the OS

https://help.ubuntu.com/community/WakeOnLan

(ok ubuntu instructions but OpenSuse doesn't seem to have the same level of documentation, but I would hope
Code:
sudo ethtool -s <NIC> wol g
would work on any OS!)


Hi there and thanks but I need to put
Code:
ethtool -s eth0 wol g
in a startup script to make it stick and I'm not familiar with OpenSuse so don't know where to put it
_________________
We can't stop here, this is bat country. Hunter S Thompson RIP.
Back to top
View user's profile Send private message
pk_fox
LXF regular


Joined: Wed Apr 13, 2005 2:38 pm
Posts: 292
Location: Surrey, UK

PostPosted: Sat May 17, 2014 1:44 pm    Post subject: Reply with quote

pk_fox wrote:
bobthebob1234 wrote:
Whenever I have used wakeonlan I've had to enable it in the OS

https://help.ubuntu.com/community/WakeOnLan

(ok ubuntu instructions but OpenSuse doesn't seem to have the same level of documentation, but I would hope
Code:
sudo ethtool -s <NIC> wol g
would work on any OS!)


Hi there and thanks but I need to put
Code:
ethtool -s eth0 wol g
in a startup script to make it stick and I'm not familiar with OpenSuse so don't know where to put it


Edit

I rebooted and ran ethtool eth0 and the output showed that the setting has stuck so it survives a reboot and the green light on the nic is on so I really don't know why it wont boot
_________________
We can't stop here, this is bat country. Hunter S Thompson RIP.
Back to top
View user's profile Send private message
ferrari
LXF regular


Joined: Tue May 03, 2005 12:09 pm
Posts: 129

PostPosted: Sun May 18, 2014 5:07 am    Post subject: Reply with quote

No, any settings made with ethtool will not persist through a reboot. It may be that the settings you 'applied' happen to default already. You can check with
Code:
ethtool <nic>


For example, I get
Code:
 # ethtool ens1
Settings for ens1:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Speed: Unknown!
        Duplex: Unknown! (255)
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: Unknown
        Supports Wake-on: g
        Wake-on: g
        Current message level: 0x000000ff (255)
                               drv probe link timer ifdown ifup rx_err tx_err
        Link detected: no


In any case to make it persistent with openSUSE, you can add the required command to /etc/init.d/after.local and have it execute during the boot process.

There is probably another reason that WOL is not working as expected.
Back to top
View user's profile Send private message
ferrari
LXF regular


Joined: Tue May 03, 2005 12:09 pm
Posts: 129

PostPosted: Sun May 18, 2014 5:16 am    Post subject: Reply with quote

I haven't tried this, but it should also be possible to add the required ethtool options in /etc/sysconfig/network/ifcfg-<eth-id> using 'ETHTOOLS_OPTIONS=' eg
Code:
ETHTOOL_OPTIONS='wol g'
Back to top
View user's profile Send private message
pk_fox
LXF regular


Joined: Wed Apr 13, 2005 2:38 pm
Posts: 292
Location: Surrey, UK

PostPosted: Sun May 18, 2014 11:16 am    Post subject: Reply with quote

ferrari wrote:
I haven't tried this, but it should also be possible to add the required ethtool options in /etc/sysconfig/network/ifcfg-<eth-id> using 'ETHTOOLS_OPTIONS=' eg
Code:
ETHTOOL_OPTIONS='wol g'


The problem is it seems that the nic settings are ok, it's something else stopping it waking up, it worked perfectly when I had windows and esxi on it so it's not a hardware problem

Output from ethtool

Code:

ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
        Link partner advertised pause frame use: Symmetric
        Link partner advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: off
        Supports Wake-on: g
        Wake-on: g
        Current message level: 0x000000ff (255)
                               drv probe link timer ifdown ifup rx_err tx_err
        Link detected: yes

_________________
We can't stop here, this is bat country. Hunter S Thompson RIP.
Back to top
View user's profile Send private message
ferrari
LXF regular


Joined: Tue May 03, 2005 12:09 pm
Posts: 129

PostPosted: Sun May 18, 2014 9:23 pm    Post subject: Reply with quote

Review the advice given here

https://wiki.archlinux.org/index.php/Wake-on-LAN#With_systemd

Also, see my post in the openSUSE thread

https://forums.opensuse.org/showthread.php/498123-Wake-on-Lan-problem?p=2644034#post2644034
Back to top
View user's profile Send private message
pk_fox
LXF regular


Joined: Wed Apr 13, 2005 2:38 pm
Posts: 292
Location: Surrey, UK

PostPosted: Sun Jun 01, 2014 2:27 pm    Post subject: Reply with quote

ferrari wrote:
Review the advice given here

https://wiki.archlinux.org/index.php/Wake-on-LAN#With_systemd

Also, see my post in the openSUSE thread

https://forums.opensuse.org/showthread.php/498123-Wake-on-Lan-problem?p=2644034#post2644034


Edit
One thing I've noticed is, if I power down and then unplug the power cable and reconnect it wol then works - but if I shut it down again using shutdown or poweroff it will not wake unless I go through the same unplug reconnect process which obvously is not ideal.
_________________
We can't stop here, this is bat country. Hunter S Thompson RIP.
Back to top
View user's profile Send private message
ferrari
LXF regular


Joined: Tue May 03, 2005 12:09 pm
Posts: 129

PostPosted: Sun Jun 01, 2014 11:29 pm    Post subject: Reply with quote

I'm not sure what else to advise here. (Perhaps it's time to try another NIC in the machine.)
Back to top
View user's profile Send private message
pk_fox
LXF regular


Joined: Wed Apr 13, 2005 2:38 pm
Posts: 292
Location: Surrey, UK

PostPosted: Mon Jun 02, 2014 6:12 am    Post subject: Reply with quote

ferrari wrote:
I'm not sure what else to advise here. (Perhaps it's time to try another NIC in the machine.)


Why does it work in windows then, and why does disconnecting the power work, the os is obviously leaving the nic in a state where it can't be woken, BTW I'm running Debian on it now. Thanks again for your time.
_________________
We can't stop here, this is bat country. Hunter S Thompson RIP.
Back to top
View user's profile Send private message
pk_fox
LXF regular


Joined: Wed Apr 13, 2005 2:38 pm
Posts: 292
Location: Surrey, UK

PostPosted: Mon Jun 02, 2014 9:57 am    Post subject: Reply with quote

ferrari wrote:
I'm not sure what else to advise here. (Perhaps it's time to try another NIC in the machine.)


Hi there, I have it working,, instead of using the dual port nic of which I believe one port is designated for the integrated lights out utility I fitted another nic and it worked straight away - no ethtool or changes to interfaces file it just worked - so I don't know why wol wont work using the other nic but hey ho, thanks again for your help.
_________________
We can't stop here, this is bat country. Hunter S Thompson RIP.
Back to top
View user's profile Send private message
ferrari
LXF regular


Joined: Tue May 03, 2005 12:09 pm
Posts: 129

PostPosted: Mon Jun 02, 2014 10:09 am    Post subject: Reply with quote

Quote:
Hi there, I have it working,, instead of using the dual port nic of which I believe one port is designated for the integrated lights out utility I fitted another nic and it worked straight away - no ethtool or changes to interfaces file it just worked - so I don't know why wol wont work using the other nic but hey ho, thanks again for your help.


That is good to know. Smile

BTW, you might want to share the make/model, or even better the chipset of the NIC
Code:
/sbin/lspci -nnk
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8464
Location: Warrington, UK

PostPosted: Mon Jun 02, 2014 10:33 am    Post subject: Reply with quote

pk_fox wrote:
Why does it work in windows then, and why does disconnecting the power work


Because the Windows driver is doing some magic with the card's firmware. It may be that you need a firmware file for the card to work correctly in Linux.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
pk_fox
LXF regular


Joined: Wed Apr 13, 2005 2:38 pm
Posts: 292
Location: Surrey, UK

PostPosted: Mon Jun 02, 2014 11:45 am    Post subject: Reply with quote

ferrari wrote:
Quote:
Hi there, I have it working,, instead of using the dual port nic of which I believe one port is designated for the integrated lights out utility I fitted another nic and it worked straight away - no ethtool or changes to interfaces file it just worked - so I don't know why wol wont work using the other nic but hey ho, thanks again for your help.


That is good to know. Smile

BTW, you might want to share the make/model, or even better the chipset of the NIC
Code:
/sbin/lspci -nnk


Code:

lspci -nnk|grep Ethernet
03:04.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5715 Gigabit Ethernet [14e4:1678] (rev a3)
03:04.1 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5715 Gigabit Ethernet [14e4:1678] (rev a3)
07:00.0 Ethernet controller [0200]: Intel Corporation 82574L Gigabit Network Connection [8086:10d3]




It's the Intel one that works.
_________________
We can't stop here, this is bat country. Hunter S Thompson RIP.
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast