Printer probs....

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Printer probs....

Postby DavidMcCrossan » Wed Mar 12, 2014 3:27 pm

I am trying to add my Samsung ML-1670 laser to my system and have installed the relevant Samsung drivers. In on order to effect the addition I have had to specify the ppd file and this I have done. I got an error message from the printer management screen to the effect that I must first add
Code: Select all
rastertosplc
to [/code] /usr/lib/cups/filter/[code] and that is what I am trying to do.
The file resides in [code]/home/david/uld/.386/rastertosplc[/code].
Using Gnome Commander with both directories open to me I can copy the file but am unable to paste it into /usr, even as root.
Can anyone please advise me - I am willing to use the command line but I need a steer, please.

Best regards
David
Semper in Excretam
DavidMcCrossan
LXF regular
 
Posts: 347
Joined: Fri Aug 19, 2005 9:46 am

Postby Dutch_Master » Wed Mar 12, 2014 3:54 pm

The general command structure is:
Code: Select all
cp [options] <source> <destination>

So in your case:
Code: Select all
cp /home/david/uld/.386/rastertosplc /usr/lib/cups/filter/


If your system uses sudo, precede the previous command accordingly :)

Bookmark this: http://ss64.com/bash/ :!:
Dutch_Master
LXF regular
 
Posts: 2471
Joined: Tue Mar 27, 2007 1:49 am

Printer probs....

Postby DavidMcCrossan » Wed Mar 12, 2014 6:05 pm

Thanx DM for your prompt reply.

Code: Select all
cp: cannot stat '/home/david/uld/.386/rasterostplc': No such file or directory
is the reply.

I have wrestled with this all afternoon.

Can you see if I have made any mistake, please?

Best regards

David
Semper in Excretam
DavidMcCrossan
LXF regular
 
Posts: 347
Joined: Fri Aug 19, 2005 9:46 am

Postby Dutch_Master » Wed Mar 12, 2014 7:36 pm

This command
Code: Select all
updatedb && locate rasterostplc | grep /home/
will give you the exact location of the rasterostplc file in the /home directory. Note very carefully where it is, then navigate to it via the cd command:
Code: Select all
cd /home/<path/to/file>
The ls command shows you the contents of that directory. Check the file is there. Then, re-issue the cp command I gave earlier.

You can use the ls command to check contents of another directory, if you provide a path to it:
Code: Select all
ls /usr/lib/cups/filter/
This should now show the rasterostplc file inside it.
Dutch_Master
LXF regular
 
Posts: 2471
Joined: Tue Mar 27, 2007 1:49 am

Postby nelz » Wed Mar 12, 2014 7:45 pm

You have spelled the name differently, rastertosplc vs rasterostplc. Use tab completion instead of typing the paths in full, that way you know it is correct.

Or you can use find
Code: Select all
find ~/uld -name 'raster*'

to find the file.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8577
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Printer probs....

Postby DavidMcCrossan » Thu Mar 13, 2014 3:27 pm

DM and NELZ, wot a pair of stars you are!

I am pretty confident I can do the rest now. I will let you know how I get on.

Best

David
Semper in Excretam
DavidMcCrossan
LXF regular
 
Posts: 347
Joined: Fri Aug 19, 2005 9:46 am

Printer probs....

Postby DavidMcCrossan » Thu Mar 13, 2014 6:32 pm

DM and Nelz, Thank you so much for your expert guidance.

I have copied the file to the right place and verified it.

I still do not have a working printer, but I think I know why.

I now know how to install it correctly and I shall uninstall (having taken good copies of the relevant locations and file names and addresses) so I can easily specify them again.

Altho´ I did go to Specsavers I am now 72 and the 7 strokes and one episode of Thrombosis have left their mark...

Many thanx

David
Semper in Excretam
DavidMcCrossan
LXF regular
 
Posts: 347
Joined: Fri Aug 19, 2005 9:46 am

Printer probs....

Postby DavidMcCrossan » Sat Mar 15, 2014 12:10 pm

Hi Guys!
Sadly there is still work to do.
I managed to copy the file rastertosplc to /usr/lib/cups/filter and verified that it was there as root owner.
The problem is that I could not print any thing. Digging around I found under print queue attributes the statement that ¨filter failed¨.
In case the installation had become corrupted I moved all my various downloads to trash and went to the Samsung site for a fresh (untainted) download. This is a new type, only issued yesterday But I managed to install it. I still get the same filter failed message and I have run out of grunt.
Any ideas anyone, please?
Best regards
David
Semper in Excretam
DavidMcCrossan
LXF regular
 
Posts: 347
Joined: Fri Aug 19, 2005 9:46 am

Postby Dutch_Master » Sat Mar 15, 2014 2:44 pm

Are the permissions correct? Set to
Code: Select all
chmod 644 /usr/lib/cups/filter/rastertosplc


Are you installing the drivers according to the Samsung instructions? Reboot the PC to make sure all relevant services (Cups, lpr) are started correctly.
Dutch_Master
LXF regular
 
Posts: 2471
Joined: Tue Mar 27, 2007 1:49 am

Printer probs....

Postby DavidMcCrossan » Sun Mar 16, 2014 2:53 pm

DM thank you for your continuing support.
Overnight I had a Eureka moment, reasoning that filter was part of the CUPS kit I might as well re-install it. So I did, but it still fails. I have just applied your chmod change and it is still the same.
IT seems to me that there are 2 paths: I should reassess my installation procedure, or I could reinstall Mint 15, which worked perfectly after a bit of tinkering.
It has now been 2 weeks and I am exhausted.....
Best regards
David
Semper in Excretam
DavidMcCrossan
LXF regular
 
Posts: 347
Joined: Fri Aug 19, 2005 9:46 am

Postby wyliecoyoteuk » Sun Mar 16, 2014 10:14 pm

How are you installing?
I have a Samsung printer, and the only filters I can find are rastertosamsungpl and rastertosamsungplc.
try entering http://localhost:631 in a web browser, and adding the printer that way.
On my ubuntu syatem the driver is already available.
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
User avatar
wyliecoyoteuk
LXF regular
 
Posts: 3466
Joined: Sun Apr 10, 2005 10:41 pm
Location: Birmingham, UK

Printer probs....

Postby DavidMcCrossan » Mon Mar 17, 2014 9:56 am

Thanks Wylie, I have installing using localhost:631 and it still does not print. The message I get is ¨filter failed¨
I have looked at
Code: Select all
/usr/lib/cups/filter/rastertosplc
and it is set as root.

I have just noticed DM´s instructions to chmod to 644 so I will try that and see if it works.

Best regards

David
Semper in Excretam
DavidMcCrossan
LXF regular
 
Posts: 347
Joined: Fri Aug 19, 2005 9:46 am

Printer probs....

Postby DavidMcCrossan » Mon Mar 17, 2014 10:19 am

Further to my last I have chmod 644 to rastertosplc and I get the message from job-printer-state-reasons-
Code: Select all
[u´cups-insecure-filter-warning´]

I shall change back to root and do some more head-scratching.

Incidentally, I have also tried
Code: Select all
/home/david/downloads/uld/ and installed [.sh] and then [install.sh] and the same result occurs.

I can´t think of anything else I can do.

I think I will go for a walk to clear me bonce...

Best

David
Semper in Excretam
DavidMcCrossan
LXF regular
 
Posts: 347
Joined: Fri Aug 19, 2005 9:46 am

Printer probs....

Postby DavidMcCrossan » Mon Mar 17, 2014 2:31 pm

I carried a clearout in which I deleted the printer and deleted rastertospic and installed the printer from the archive as:
Code: Select all
cd /home/david/Downloads/uld

then
Code: Select all
sudo  /home/david/Downloads/uld/.install.sh

At the printers setup box in sys settings the dialog allowed me to specify the Samsung printer after I pointed it to the location of the .ppd file and informed me that file rastertosplc need to be installed in :
Code: Select all
/usr/lib/cups/filter
and I duly copied the file from:
Code: Select all
~/uld/i386/rastertosplc
to
Code: Select all
~/cups//filter/

I then checked the file had root owner permission
I still get the same ¨filter failed¨ message and I wonder if the raster file has been properly installed in the /filter dir.
Can anyone shine a light into my gloom, please?
Best
David
Semper in Excretam
DavidMcCrossan
LXF regular
 
Posts: 347
Joined: Fri Aug 19, 2005 9:46 am

Printer probs....

Postby DavidMcCrossan » Tue Mar 18, 2014 3:15 pm

I may be on to something here.

http://localhost:631/admn/printers[code] gets me the CUPS website.
pointing to my printer and then I see, on the top of the page [code]Idle, accepting jobs,stopped, server default[/code]

I can´t help thinking that I must be able to register my printer to Cups, and this might be the reason behind the ¨filter failure¨ message.

Any thoughts?

Best

David
Semper in Excretam
DavidMcCrossan
LXF regular
 
Posts: 347
Joined: Fri Aug 19, 2005 9:46 am

Next

Return to Help!

Who is online

Users browsing this forum: No registered users and 0 guests