Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

xserver problem

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
leke
LXF regular


Joined: Mon Oct 22, 2007 6:45 pm
Posts: 503
Location: Oulu, Finland

PostPosted: Mon Dec 30, 2013 8:53 am    Post subject: xserver problem Reply with quote

I'm running Elementary OS and have the same problem as this:
http://askubuntu.com/questions/159663/how-to-reset-the-xorg-xserver
That is, I'm thrown out of X straight after login of my user account, but not the guest.

I've tried a bunch of stuff including:
recovery mode > fix broken packages,
deleting everything in ~/.config/,
removing the xorg.conf (ok, there wasn't a backup of the old file, so I just copied and removed the current),
this > sudo apt-get install nvidia-current,
loading an older kernel,
sudo dpkg-reconfigure xserver-xorg...

Does anyone have anything else I can try? It's not really so important, as it's the tv computer. I can just reinstall if it's a crazy problem.

Thanks.
_________________
http://truecenterpublishing.com/zenstory/maybe.html
Back to top
View user's profile Send private message
leke
LXF regular


Joined: Mon Oct 22, 2007 6:45 pm
Posts: 503
Location: Oulu, Finland

PostPosted: Mon Dec 30, 2013 9:04 am    Post subject: Reply with quote

also ran sudo nvidia-xconfig to generate a new xorg.conf file (I noticed the original was pretty empty).
_________________
http://truecenterpublishing.com/zenstory/maybe.html
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8450
Location: Warrington, UK

PostPosted: Mon Dec 30, 2013 10:40 am    Post subject: Reply with quote

Look at the log files, /var/log/Xorg.0.log and ~/.xsession-errors. Since it works as another user, this look like a problem with your user configuration. I've seen this type of thing happen because of incorrect file permissions, but the logs should give more of a clue.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
wyliecoyoteuk
LXF regular


Joined: Sun Apr 10, 2005 11:41 pm
Posts: 3440
Location: Birmingham, UK

PostPosted: Mon Dec 30, 2013 12:21 pm    Post subject: Reply with quote

Have you tried creating a new user?
If that works Ok, just copy everything but the hidden files to the new home directory.
_________________
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
Back to top
View user's profile Send private message
leke
LXF regular


Joined: Mon Oct 22, 2007 6:45 pm
Posts: 503
Location: Oulu, Finland

PostPosted: Tue Dec 31, 2013 5:58 pm    Post subject: Reply with quote

I managed to create a new user, but couldn't log in to the gui (same problem as with the existing user).

I also checked out the xsession errors and Xorg.log file. The log file only seemed to mention everything connected. The xsessions did mention problems with the gtk engine module and also something about the passwords file. I couldn't copy the file to my usb stick though because I'm crap at mounting those things.
With pressure from the family to get this thing fixed, I just went ahead and reinstalled the OS.

Thanks for the suggestions though.
_________________
http://truecenterpublishing.com/zenstory/maybe.html
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast