can't use second drive (SOLVED)

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

can't use second drive (SOLVED)

Postby heiowge » Fri Sep 28, 2012 1:53 pm

I've added a 2nd hard disc. Both the new one and the original are seagate 500gb drives.

It appears in dolphin, but I can't seem to do anything with it. I wanted to back up my files, but the paste option is greyed out.

Any suggestions?
Last edited by heiowge on Fri Sep 28, 2012 9:02 pm, edited 1 time in total.
i5 4440 3.1Ghz, Asus H87M-E motherboard, 8GB DDR3, 2GB DDR5 nVidia card, 2x500GB Seagate hd, Coolermaster 750W PSU running Mint 16 MATE and Win7

eeepc 1015PX, 1.66 Ghz Intel atom processor, 2 GB DDR3, 320 GB hd, Mint 14 MATE. Fan needs fixing.
User avatar
heiowge
LXF regular
 
Posts: 1906
Joined: Wed Feb 27, 2008 8:21 pm
Location: Cheshire, UK

Postby el chapulín » Fri Sep 28, 2012 3:23 pm

Looks like a permissions problem. By default *nix system don't just mount a hard disk drive assuming that all users should be able to write to it. Ensure that you've set the mount options correctly in /etc/fstab
el chapulín
 
Posts: 50
Joined: Fri Sep 07, 2012 1:13 pm

Postby heiowge » Fri Sep 28, 2012 6:51 pm

Thanks. Now how do I fix it? :lol:
i5 4440 3.1Ghz, Asus H87M-E motherboard, 8GB DDR3, 2GB DDR5 nVidia card, 2x500GB Seagate hd, Coolermaster 750W PSU running Mint 16 MATE and Win7

eeepc 1015PX, 1.66 Ghz Intel atom processor, 2 GB DDR3, 320 GB hd, Mint 14 MATE. Fan needs fixing.
User avatar
heiowge
LXF regular
 
Posts: 1906
Joined: Wed Feb 27, 2008 8:21 pm
Location: Cheshire, UK

Postby towy71 » Fri Sep 28, 2012 7:13 pm

use the "disk utility"
still looking for that door into summer
User avatar
towy71
Moderator
 
Posts: 4264
Joined: Wed Apr 06, 2005 2:11 pm
Location: wild West Wales

Postby nelz » Fri Sep 28, 2012 8:43 pm

You don't use mount options to set permissions on *nix filesystems, the filesystem ccontains its own ownership details, and the root of it is owned by the user that created it, which has to be root. On a single user system, all you need to do is moutn the drive then do

Code: Select all
sudo chown youruser: /mount/point


It must be mounted when you do this, you are setting ownership of the root of the filesystem, not the mount point. Once you have done this it will be owned by your user wherever you mount it.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8525
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby heiowge » Fri Sep 28, 2012 9:04 pm

Thanks for the info. I logged on here to say I'd fixed it, but thanks anyway.

I needed to do a reinstall, and I found I could set custom mount points, so I set it to:

/media/seconddrive

Then I opened it with admin rights, added my user and set permissions through Nautilus.
i5 4440 3.1Ghz, Asus H87M-E motherboard, 8GB DDR3, 2GB DDR5 nVidia card, 2x500GB Seagate hd, Coolermaster 750W PSU running Mint 16 MATE and Win7

eeepc 1015PX, 1.66 Ghz Intel atom processor, 2 GB DDR3, 320 GB hd, Mint 14 MATE. Fan needs fixing.
User avatar
heiowge
LXF regular
 
Posts: 1906
Joined: Wed Feb 27, 2008 8:21 pm
Location: Cheshire, UK

Postby Nuke » Fri Oct 05, 2012 9:24 am

I am just being picky, but /media is not meant to be a mount point for hard drives. It is meant for the ad hoc mounting of the wide variety of portable media such as CD's, Floppies, external HDs, USB sticks, cameras, digital picture frames, etc.

/mnt is meant for the more fixed things such as other PCs on the network and any internal HDs which are not usually mounted (such as for archiving), and to mount internal HDs temporarily when using a recovery distro.

For a permanently mounted internal HD, it should just be part of the main tree, not through /media or /mnt any more that your first HD is. Unlike a Windows environment, there is no need to be normally conscious of it being a second HD. I have three internal HDs and mount them as something like /home/nuke/data1, ~/data2 etc. [actually it is more complex than that as each HD has four partitions, so I also have mount points like ~/archive, ~/copy_of_my_laptop_home, /windows_XP and /windows_games]
Unsolved mysteries of the Universe, No 13 :-
How many remakes of Anna Karenina does the World need?
User avatar
Nuke
LXF regular
 
Posts: 217
Joined: Wed Feb 09, 2011 12:11 pm
Location: Chepstow, UK

Postby Ram » Fri Oct 05, 2012 10:40 am

if you use /media to mount the drive it is then visible to all users on their desktops without doing anything else.

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
User avatar
Ram
LXF regular
 
Posts: 1679
Joined: Thu Apr 07, 2005 9:44 pm
Location: Guisborough

Postby nelz » Fri Oct 05, 2012 11:29 am

Ram wrote:if you use /media to mount the drive it is then visible to all users on their desktops without doing anything else.


The same is true of /mnt. /media is intended for removable devices, particularly automounted ones.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8525
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby Ram » Fri Oct 05, 2012 1:09 pm

nelz wrote:
Ram wrote:if you use /media to mount the drive it is then visible to all users on their desktops without doing anything else.


The same is true of /mnt. /media is intended for removable devices, particularly automounted ones.


With /mnt you usually have to do extra work to display them on the desktop automatically where /media as you say is meant for removable devices but if used just displays them on the desktop.

I've got nfs shares, some in /mnt I have to navigate to them. Some in /media already waiting on the desktop to use once logged in. Just something I found by accident.

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
User avatar
Ram
LXF regular
 
Posts: 1679
Joined: Thu Apr 07, 2005 9:44 pm
Location: Guisborough

Postby el chapulín » Fri Oct 05, 2012 1:10 pm

nelz wrote:You don't use mount options to set permissions on *nix filesystems[etc]

I, perhaps wrongly assumed, it was an NTFS volume, the OP dual boots with windows and didn't specify either way.
el chapulín
 
Posts: 50
Joined: Fri Sep 07, 2012 1:13 pm

Postby nelz » Fri Oct 05, 2012 9:49 pm

Ram wrote:With /mnt you usually have to do extra work to display them on the desktop automatically where /media as you say is meant for removable devices but if used just displays them on the desktop.


I expect that depends on your desktop. KDE allows you to specify which are displayed, but I don't use desktop icons so it doesn't affect me.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8525
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby Ram » Fri Oct 05, 2012 10:19 pm

nelz wrote:
Ram wrote:With /mnt you usually have to do extra work to display them on the desktop automatically where /media as you say is meant for removable devices but if used just displays them on the desktop.


I expect that depends on your desktop. KDE allows you to specify which are displayed, but I don't use desktop icons so it doesn't affect me.


Using gnome, no option I've seen, like that of kde. As I said that's an additional step albeit a small one.

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
User avatar
Ram
LXF regular
 
Posts: 1679
Joined: Thu Apr 07, 2005 9:44 pm
Location: Guisborough


Return to Help!

Who is online

Users browsing this forum: Alex01UK and 0 guests