IceWM and the little black window startup problem

Share your how-tos and guides with other users

Moderators: ChrisThornett, LXF moderators

IceWM and the little black window startup problem

Postby Farcry » Wed May 18, 2011 9:43 pm

Firstly, I'm ashamed to say it has taken me since LXF 103 to pursue Mike Saunders's strong recommendation to try IceWM. But he's so right and it is a cracking little window manager (even doing tiling as well!).

Next, there is one irritating problem with IceWM which does seem to be a timing/race bug (in icewmtray?) going back ages (eg see http://sourceforge.net/tracker/index.ph ... tid=100031). It's also been reported in the Arch Linux forums at https://bbs.archlinux.org/viewtopic.php?id=65608 and https://bbs.archlinux.org/viewtopic.php?id=78459.

What happens is that every so often the programs in the startup file get loaded, but their icons don't appear in the system tray. Instead a little indestructible black window appears. On restarting X, it always seems to correct itself. (For me it seems to happen after a power-on.)

The solution from the second Arch thread above is to put a "sleep 1" before every command in the startup file which puts an icon in the system tray. For example:
Code: Select all
sleep 1; parcellite &
sleep 1; xpad -N &
sleep 1; nm-applet --sm-disable &
sleep 1; trayclock &
sleep 1; conky &


However, I've actually found it better to create an additional script (say, called sleepy) and call it at the end of startup thus:
Code: Select all
sleep 4 && ${0%/*}/sleepy &

Every program that puts an icon in the system tray is called in sleepy, without any other sleeps being required.

Hope this might help someone else who is frustrated by such a silly problem in an otherwise excellent piece of software.
Mike - have you encountered this and come up with a better solution?!
;)
Farcry
 
Posts: 24
Joined: Wed Jul 18, 2007 11:24 pm

Return to Hints and tips

Who is online

Users browsing this forum: No registered users and 0 guests