Raspberry Pi

For discussing Linux compatible (or not) devices

Moderators: ChrisThornett, LXF moderators

Postby Dutch_Master » Wed Feb 29, 2012 6:13 pm

Coverage on the BBC News at 6 today. Great! :D
Dutch_Master
LXF regular
 
Posts: 2460
Joined: Tue Mar 27, 2007 1:49 am

Postby Dutch_Master » Tue Apr 17, 2012 3:27 am

And the first (pre-)orders have now been delivered, directly from the Foundation. Those ordered at Farnell et all can expect them too in the not so distant future I assume. Maybe send one over to Mike, so he can tinker with it? And port MikeOS too :P ;) Hmmm, there's a thought: if Mike re-writes his assembler articles for use on the RPi and submits them to the Foundation, who knows he might have inspired the next Linus! ;) Or RMS :shock: :roll: :mrgreen:
Dutch_Master
LXF regular
 
Posts: 2460
Joined: Tue Mar 27, 2007 1:49 am

Postby Dutch_Master » Thu Aug 02, 2012 1:49 am

Just a quick update: recently both vendors have lifted the 'one-per-person' limit imposed so far, so order the amount you want w/o restrictions! That said, at least one reseller advises you to contact them in advance if you want to order a large number ;)
Dutch_Master
LXF regular
 
Posts: 2460
Joined: Tue Mar 27, 2007 1:49 am

Postby leke » Thu Aug 02, 2012 7:21 am

I've had a little time to play with my pi, and noticed the hdmi video doesn't 'work' that often. The analogue video works 100% of the time though.
I have a feeling it's my tv though because I've had issues connecting things to it in the past.
User avatar
leke
LXF regular
 
Posts: 507
Joined: Mon Oct 22, 2007 5:45 pm
Location: Oulu, Finland

Postby Ram » Thu Aug 02, 2012 7:27 am

leke wrote:I've had a little time to play with my pi, and noticed the hdmi video doesn't 'work' that often. The analogue video works 100% of the time though.
I have a feeling it's my tv though because I've had issues connecting things to it in the past.


In what way ?

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
User avatar
Ram
LXF regular
 
Posts: 1682
Joined: Thu Apr 07, 2005 9:44 pm
Location: Guisborough

Postby leke » Thu Aug 02, 2012 7:32 am

Ram wrote:
leke wrote:I've had a little time to play with my pi, and noticed the hdmi video doesn't 'work' that often. The analogue video works 100% of the time though.
I have a feeling it's my tv though because I've had issues connecting things to it in the past.


In what way ?

the os boots, but the tv says 'no signal'. I hear it's because there may be some problems identifying the tv settings.
User avatar
leke
LXF regular
 
Posts: 507
Joined: Mon Oct 22, 2007 5:45 pm
Location: Oulu, Finland

Postby Ram » Thu Aug 02, 2012 7:47 am

Ah, that not something I've experienced. I get over scanning if I leave to TV set to auto detect the resolution - just have to change the TV to 16:9.

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
User avatar
Ram
LXF regular
 
Posts: 1682
Joined: Thu Apr 07, 2005 9:44 pm
Location: Guisborough

Postby nelz » Thu Aug 02, 2012 8:11 am

If you use the new Raspbian release, the config program that runs on first boot includes an option to disable the overscan.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8552
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby leke » Thu Aug 02, 2012 8:38 am

nelz wrote:If you use the new Raspbian release, the config program that runs on first boot includes an option to disable the overscan.

I'm using raspbian, but if I'm not using it for the first time, where would the option for turning off the overscan be? I really should look into what overscan means as well :D
I'll also try and disable it on the tv and play with some of the other settings. Previously, I was playing with them after the pi had booted, but realise now I should change them before boot occurs.
User avatar
leke
LXF regular
 
Posts: 507
Joined: Mon Oct 22, 2007 5:45 pm
Location: Oulu, Finland

Postby Ram » Thu Aug 02, 2012 8:59 am

leke wrote:
nelz wrote:If you use the new Raspbian release, the config program that runs on first boot includes an option to disable the overscan.

I'm using raspbian, but if I'm not using it for the first time, where would the option for turning off the overscan be? I really should look into what overscan means as well :D
I'll also try and disable it on the tv and play with some of the other settings. Previously, I was playing with them after the pi had booted, but realise now I should change them before boot occurs.


Over scan = zoomed picture so say you're running gnome 2, the top & bottom panels would be off the screen.

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
User avatar
Ram
LXF regular
 
Posts: 1682
Joined: Thu Apr 07, 2005 9:44 pm
Location: Guisborough

Postby nelz » Thu Aug 02, 2012 10:22 am

Code: Select all
sudo raspi-config
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8552
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby SiriusHardware » Tue Sep 25, 2012 9:30 pm

For the HDMI problem, there are a vast number of preset HDMI modes which you can force the Pi to run in:

In the small partition on the card (readable / writable by Windows as well) there is a file, config.txt - this is more or less the equivalent of the BIOS setup page on a more conventional computer. If you are a Linux newcomer (as I am) you may find it easier to put the card into a card reader on a Windows PC and use that to locate/edit config.txt.

There's a huge list of the possible settings which can be used in config.txt over on the raspberry pi Wiki on elinux - hope it's OK to post the link here?

http://elinux.org/RPi_config.txt

You could try adding / changing the HDMI mode setting to

hdmi_mode=19

Which equates to 720p, 50Hz.

Maybe your TV does not support 1080? Some of the first wave of 'HD ready' TVs didn't support resolutions higher than 720.

Other settings can be changed to adjust the HDMI signal drive level.
SiriusHardware
 
Posts: 77
Joined: Tue Sep 25, 2012 6:41 pm

Postby leke » Wed Sep 26, 2012 4:38 pm

SiriusHardware wrote:For the HDMI problem, there are a vast number of preset HDMI modes which you can force the Pi to run in:

In the small partition on the card (readable / writable by Windows as well) there is a file, config.txt - this is more or less the equivalent of the BIOS setup page on a more conventional computer. If you are a Linux newcomer (as I am) you may find it easier to put the card into a card reader on a Windows PC and use that to locate/edit config.txt.

There's a huge list of the possible settings which can be used in config.txt over on the raspberry pi Wiki on elinux - hope it's OK to post the link here?

http://elinux.org/RPi_config.txt

You could try adding / changing the HDMI mode setting to

hdmi_mode=19

Which equates to 720p, 50Hz.

Maybe your TV does not support 1080? Some of the first wave of 'HD ready' TVs didn't support resolutions higher than 720.

Other settings can be changed to adjust the HDMI signal drive level.
Hi, thanks for the suggestion. I found this info a little while back, but forgot to mark the problem as solved :oops:
Sorry about that, and thanks again :)
User avatar
leke
LXF regular
 
Posts: 507
Joined: Mon Oct 22, 2007 5:45 pm
Location: Oulu, Finland

Previous

Return to Hardware

Who is online

Users browsing this forum: Yahoo [Bot] and 0 guests