Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

LXFDVD143. Video goes berzerk (viking state qualifier)

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Hardware
View previous topic :: View next topic  
Author Message
gustaf4711



Joined: Wed Mar 23, 2011 1:54 pm
Posts: 3
Location: Drammen Norway

PostPosted: Wed Mar 23, 2011 2:11 pm    Post subject: LXFDVD143. Video goes berzerk (viking state qualifier) Reply with quote

The debian was installed onto a SCSI disc in a 2004 Dell desktop.
Installation messages displayed properly in a simple VGA-style.
All terminated normally.

Upon restart, debian starts to inform of its progress in quite a small but still readable font.

Then some process starts and the display goes into an incompatible mode represented by broad flickering and well separated lines of varying colours.

Does anyone have a hint? The motherboard features an embedded Intel 82845 graphics driver. Intel.com hints that all Linux distros should have the proper Intel-driver included ...
Back to top
View user's profile Send private message
PCNetSpec
LXF regular


Joined: Sun Feb 21, 2010 3:50 pm
Posts: 631
Location: Cornwall UK

PostPosted: Wed Mar 23, 2011 2:34 pm    Post subject: Reply with quote

Have you tried the old trick of adding:

nomodeset

or

i915 modeset=0

as a kernel boot parameter ?

More info on Kernel ModeSetting (KMS) here:
http://wiki.debian.org/KernelModesetting
_________________
WARNING: You are logged into reality as 'root'... logging in as 'insane' is the only safe option.
Linux in the UK
The Linux Community Forum
Back to top
View user's profile Send private message
gustaf4711



Joined: Wed Mar 23, 2011 1:54 pm
Posts: 3
Location: Drammen Norway

PostPosted: Thu Mar 24, 2011 1:55 pm    Post subject: Reply with quote

Thank you PCNetSpec for your suggestion.

Being a beginner I do not know how to handle your suggestion. Therefore:

1. Into which (bootstrap?) file do I enter the nomodeset or "i915 modeset=0" commands?

2. Since the VDU becomes unreadable during the standard bootstrap, I would have to break out of it into a console-mode in order to be able to set the kernel parameter, I guess. Is that possible?

Ch

P.S. On the web I found this not-very-promising post:

http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/the-dreaded-82845g-intel-integrated-graphics-does-any-linux-work-with-it-802465/
Back to top
View user's profile Send private message
PCNetSpec
LXF regular


Joined: Sun Feb 21, 2010 3:50 pm
Posts: 631
Location: Cornwall UK

PostPosted: Thu Mar 24, 2011 5:56 pm    Post subject: Reply with quote

OK, you need to edit a line at the GRUB menu screen at bootup, instructions here for GRUB2 (Ubuntu):
https://help.ubuntu.com/community/Grub2#Editing%20Menus%20During%20Boot

and add a space after quiet splash then the i915 modeset=0 (or nomodeset)

so the end reads:

quiet splash i915 modeset=0

It should be *similar* in Debian and/or GRUB legacy. (though it might be the Esc key rather than Shift)

remember, this will NOT survive a reboot, so you will have to add it permanently to GRUB after booting and update-grub

Which version of Debian ? .. or GRUB ?

[EDIT]
Or you could use a working LiveCD (or Recovery Mode root prompt) to navigate (on you hard drive) to:
/etc/modprobe.d/i915-kms.conf
and change its contents from:

options i915 modeset=1
to:
options i915 modeset=0

Save the file, and reboot.

as explained here:
http://wiki.debian.org/KernelModesetting
_________________
WARNING: You are logged into reality as 'root'... logging in as 'insane' is the only safe option.
Linux in the UK
The Linux Community Forum
Back to top
View user's profile Send private message
gustaf4711



Joined: Wed Mar 23, 2011 1:54 pm
Posts: 3
Location: Drammen Norway

PostPosted: Wed Mar 30, 2011 4:43 am    Post subject: Reply with quote

Thanks PCNetSpec! Your advice solved my problem.

To break out of Debian 6 while it booted I used ctrl+alt +F2. I then edited the /etc/modprobe.d into
options i915 modeset=0
and the graphics output became acceptable.
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast