Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

FreeNAS falls off the network.

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Other OS
View previous topic :: View next topic  
Author Message
nerdmaster



Joined: Thu Jul 14, 2005 11:18 am
Posts: 52

PostPosted: Tue Aug 03, 2010 6:40 pm    Post subject: FreeNAS falls off the network. Reply with quote

Wondering if anyone here has any experience with FreeNAS?

I've recently set up a FreeNAS box for storage vut have started having a few issues with it. I've found that it has started periodically dropping off the network and starts responding after anywhere up to a few minutes.

My box is an HP ML110 G5 server (dual core xeon) with 2Gb RAM installed.
The network adapter I'm using on the LAN is an Intel Pro/1000 (CT, I believe)
The server is running 0.7.2 embedded on a USB stick (connected directly to the internal USB port on the mainboard)

The services running are SMB/CIFS, iSCSI target (currently not in use due to an unrelated VMware issue), NFS and DAAP
only 16% of the RAM is in use

There are 5 machines normally connected. 1 connected via gigabit ethernet (my main PC), 1 connected by 10/100 (router, doesn't really talk to it) and 3 wireless hosts. 1 Connectes to it fairly often, one occasionally and the other never connects to it.
There is also a VMware host that connects directly through a second interface (OPT1) via a crossover cable. As I've encountered an issue which appears to be VMware related I am unable to test how effective this is (that being said I think that interface, the onboard, is a little dodgy and I may replace it)

Here are the most recent log entries.

system:
Aug 2 18:08:03 freenas smbd[5780]: [2010/08/02 18:08:03.799422, 0] lib/util_sock.c:474(read_fd_with_timeout)
Aug 2 18:08:03 freenas smbd[5780]: [2010/08/02 18:08:03.799630, 0] lib/util_sock.c:1432(get_peer_addr_internal)
Aug 2 18:08:03 freenas smbd[5780]: getpeername failed. Error was Socket is not connected
Aug 2 18:08:03 freenas smbd[5780]: read_fd_with_timeout: client 0.0.0.0 read error = Socket is not connected.

Daemon:
Aug 2 18:08:03 freenas smbd[5780]: [2010/08/02 18:08:03.799422, 0] lib/util_sock.c:474(read_fd_with_timeout)
Aug 2 18:08:03 freenas smbd[5780]: [2010/08/02 18:08:03.799630, 0] lib/util_sock.c:1432(get_peer_addr_internal)
Aug 2 18:08:03 freenas smbd[5780]: getpeername failed. Error was Socket is not connected
Aug 2 18:08:03 freenas smbd[5780]: read_fd_with_timeout: client 0.0.0.0 read error = Socket is not connected.

I can provide additional info/logs if needed.

I've found that this occurs quite often, it stops responding and starts responding again later. Ping reports the host as unreachable for a varying amount of time (usually a minute or 2) and starts responding again.


dan@MORDOR:~$ ping 192.168.1.150
PING 192.168.1.150 (192.168.1.150) 56(84) bytes of data.
From 192.168.1.3 icmp_seq=9 Destination Host Unreachable
From 192.168.1.3 icmp_seq=10 Destination Host Unreachable
From 192.168.1.3 icmp_seq=11 Destination Host Unreachable
From 192.168.1.3 icmp_seq=13 Destination Host Unreachable
From 192.168.1.3 icmp_seq=14 Destination Host Unreachable
From 192.168.1.3 icmp_seq=16 Destination Host Unreachable
From 192.168.1.3 icmp_seq=17 Destination Host Unreachable
From 192.168.1.3 icmp_seq=19 Destination Host Unreachable
From 192.168.1.3 icmp_seq=20 Destination Host Unreachable
From 192.168.1.3 icmp_seq=22 Destination Host Unreachable
From 192.168.1.3 icmp_seq=23 Destination Host Unreachable
64 bytes from 192.168.1.150: icmp_seq=24 ttl=64 time=2002 ms
64 bytes from 192.168.1.150: icmp_seq=25 ttl=64 time=994 ms
64 bytes from 192.168.1.150: icmp_seq=26 ttl=64 time=0.042 ms
64 bytes from 192.168.1.150: icmp_seq=27 ttl=64 time=0.053 ms

Could anyone please help? I really want to like FreeNAS due to the embedded boot support and built in DAAP server but this network issue means that I will not be able to rely on it until resolved. DAAP music cutting out mid song and file transfers failing mean that in its current state it's not fit for use. I'd like to avoid moving back to OpenFiler as the USB option enables me to use softRAID for all storage volumes (really want to avoid using onboard RAID)
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Other OS All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast