Kpackage and Apt-Get Bothers

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Kpackage and Apt-Get Bothers

Postby rebdownunder » Sun Sep 04, 2005 5:33 am

Hi, All,
A few days ago, I installed Simply Mepis 3.3 from live CD onto my system. It is an old IBM Aptiva AMD K6 II (450mhz)) with 192meg RAM showing (256meg installed), a 4 gig HD (Mepis), and a 10gig HD split into 2 drives (Windows Me and Data), CD-ROM drive, and Floppy. The install went well, and overall, I"m happy with it so far. But, and here's the problem, I opened Kpackage to look for updates, and the update check timed out. I then tried apt-get update. It timed out, too. I've edited the source.list file to take out the non-U.S. sites, and changed the ftp.debian sites from us to just debian. Nothing has helped; I still can not update with Kpackage or apt-get. Anyone have any ideas?

Thanks,

Steve
rebdownunder
 
Posts: 15
Joined: Tue Aug 09, 2005 7:14 am
Location: Fayetteville, North Carolina

RE: Kpackage and Apt-Get Bothers

Postby fingers99 » Sun Sep 04, 2005 2:48 pm

I'm not sure if you can use it with mepis, but apt-spy is a great way of building a sources.list which suits your location.

But how do you mean "timed out"?

Could it be that the supplied sources-list is simply out of date? You might try asking on one of the mepis forums.
fingers99
LXF regular
 
Posts: 143
Joined: Thu Apr 07, 2005 6:15 pm

RE: Kpackage and Apt-Get Bothers

Postby rebdownunder » Mon Sep 05, 2005 1:29 am

Hi, fingers99,
Here's the errors:
root@1[stevesmith]# apt-get update
Err ftp://ftp.wa.au.debian.org testing/main Packages
Could not connect to ftp.wa.au.debian.org:21 (1.0.0.0), connection timed out
Err http://ftp.at.debian.org testing/main Packages
Could not connect to ftp.at.debian.org:80 (1.0.0.0), connection timed out

I have checked the Mepis forums; they're all stumped. I showed my sources.list to a friend of mine, and he wrote me a new one. It's still happening. I'm starting to wonder if maybe a port that apt-get needs to use is blocked? How would I check that?

Thanks,

Steve
rebdownunder
 
Posts: 15
Joined: Tue Aug 09, 2005 7:14 am
Location: Fayetteville, North Carolina

RE: Kpackage and Apt-Get Bothers

Postby fingers99 » Mon Sep 05, 2005 3:26 am

I've heard of something similar to what you suggest with proxies, but I interpret (and I may well be wrong) that the time outs are happening on two different ports of two different servers outside your system.

Are these the only two that time out?
fingers99
LXF regular
 
Posts: 143
Joined: Thu Apr 07, 2005 6:15 pm

RE: Kpackage and Apt-Get Bothers

Postby rebdownunder » Tue Sep 06, 2005 8:38 am

Hi, fingers,
I got it worked out (somewhat). It seems to be DNS errors; if I replace the URLs with IP addresses, things work, except one or two sites. One of the sites I'm still having probs with is the mepis site, but I've talked to others in mepis forums, and they say they're not having any probs at all.
rebdownunder
 
Posts: 15
Joined: Tue Aug 09, 2005 7:14 am
Location: Fayetteville, North Carolina


Return to Help!

Who is online

Users browsing this forum: No registered users and 1 guest