A problem with x11 graphics

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

A problem with x11 graphics

Postby comcamel » Sun May 01, 2005 9:58 pm

well i have got SuSE 9.2 and it has got with it i think atleast x11 display however when trying to install Xdesktopwaves

http://xdesktopwaves.sourceforge.net/

i couldn't install it as it requires Xshape extension which i cannot find on the internet, how can i get these or Xdesktopwave workin. Thanks
comcamel
LXF regular
 
Posts: 205
Joined: Thu Apr 07, 2005 5:35 pm

RE: A problem with x11 graphics

Postby Rhakios » Mon May 02, 2005 12:19 am

If you do xdpyinfo in a console, it will tell you the extensions you have installed, e.g.

Code: Select all
number of extensions:    31
    BIG-REQUESTS
    DAMAGE
    DOUBLE-BUFFER
    DPMS
    Extended-Visual-Information
    GLX
    LBX
    MIT-SCREEN-SAVER
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    NV-CONTROL
    NV-GLX
    RANDR
    RENDER
    SECURITY
    SHAPE
    SYNC
    TOG-CUP
    X-Resource
    XC-APPGROUP
    XC-MISC
    XFIXES
    XFree86-Bigfont
    XFree86-DGA
    XFree86-Misc
    XFree86-VidModeExtension
    XInputExtension
    XKEYBOARD
    XTEST
    XVideo
    XVideo-MotionCompensation


You will notice that the SuSE 9.2 on my machine comes with SHAPE.

Having just tried it out, I find it will compile on my system. However, I did install the xorg update from here:

ftp://ftp.mirrorservice.org/sites/ftp.s ... 386/suse92

so that might be why it works for me. In any event, as with any compiling you will need to make sure you have the necessary devel files installed, xorg-x11-devel in the case of the above upgrade.

I would advise that you check for SHAPE with xdpyinfo first and if it is there, then make sure you have your X servers devel files installed and try compiling then rather than going straight for the upgrade, but it's up to you.
Bye, Rhakios
User avatar
Rhakios
Moderator
 
Posts: 7634
Joined: Wed Apr 06, 2005 11:18 pm
Location: Midlands, UK

RE: A problem with x11 graphics

Postby Guest » Mon May 02, 2005 12:44 pm

got it working now thanks for thy links
Guest
 


Return to Help!

Who is online

Users browsing this forum: No registered users and 3 guests