ToDoList - Programming Academy

Code junkies hangout here

Moderators: ChrisThornett, LXF moderators

ToDoList - Programming Academy

Postby Cheemag » Sat Jan 23, 2010 3:22 pm

OK I've typed in the highlighted lines in the special edition booklet as
they appear. Is this supposed to compile: (?)

Code: Select all
using System;
using System.IO;
var contents=File.ReadAllText("todo.txt");
contents=File.ReadAllText("someotherfile.txt");
contents="Hello World";
Console.WriteLine(File.ReadAllText("todo.txt"));


Gives:

2 Errors
! .. Line Description

Using the CD that came with the booklet, you could have warned users
that the keyboard wasn't set up!
Regards,

Cheemag.

Linux Mint-8 on a key-drive.
PCLinuxOS 2009-2.
Windows XP Home SP2
User avatar
Cheemag
 
Posts: 7
Joined: Mon Jan 18, 2010 5:17 pm
Location: English Region, EU

Postby Judda » Sat Jan 23, 2010 5:03 pm

Is that the complete program, as it's missing a lot of code & {}.

You should take a look at the code listing on the disk for the ToDoList.
Judda
 
Posts: 9
Joined: Sun Jan 10, 2010 9:41 pm

Postby Cheemag » Sun Jan 24, 2010 12:00 pm

Judda wrote:Is that the complete program, as it's missing a lot of code & {}.


That's all the highlighted bits within the section "Reading from a File" to the end of that section. I assumed that you just string all the highlighted bits together and run the thing. (?)

You should take a look at the code listing on the disk for the ToDoList.


I'll see if I can find it.

How do I switch off Mono's annoying and distracting suggestions system when trying to type code into the IDE?
Regards,

Cheemag.

Linux Mint-8 on a key-drive.
PCLinuxOS 2009-2.
Windows XP Home SP2
User avatar
Cheemag
 
Posts: 7
Joined: Mon Jan 18, 2010 5:17 pm
Location: English Region, EU

Postby Judda » Sun Jan 24, 2010 5:30 pm

"How do I switch off Mono's annoying and distracting suggestions system when trying to type code into the IDE?"

I thought this is one of mono's greatest features.

If you read them, you'll learn quite a bit - well I do anyway.

To turn off: edit>preferences>text editor>general>untick "Enable code completion">OK
Judda
 
Posts: 9
Joined: Sun Jan 10, 2010 9:41 pm

Postby Cheemag » Mon Jan 25, 2010 3:17 pm

Judda wrote:"How do I switch off Mono's annoying and distracting suggestions system when trying to type code into the IDE?"

I thought this is one of mono's greatest features.

If you read them, you'll learn quite a bit - well I do anyway.

To turn off: edit>preferences>text editor>general>untick "Enable code completion">OK


Thank you.
Regards,

Cheemag.

Linux Mint-8 on a key-drive.
PCLinuxOS 2009-2.
Windows XP Home SP2
User avatar
Cheemag
 
Posts: 7
Joined: Mon Jan 18, 2010 5:17 pm
Location: English Region, EU


Return to Programming

Who is online

Users browsing this forum: No registered users and 1 guest