Complete beginner needs modem help!

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Complete beginner needs modem help!

Postby bsa03itg » Fri Sep 02, 2005 2:57 pm

Hello. I'm entirely new to Linux, and am not particularly great with computers in general (any technical terms I've learnt have all been in the space of a week!)

I was enticed by Debian 3.1 on the cover CD of September's magazine. and decided to have a go at installing it over WinXP. I've managed to get to get to the GUI, and I've had a look around KDE and it looks brilliant.

However, my modem doesn't work. I've searched the internet for hours looking for help. I've discovered that my modem is a winmodem, and that apparently I can install a driver called slmodem to make it work. But it is just so complicated! There is swathes of information but it's technical. I had a go at installing slmodem, following the advice on the following webpage: http://www.laclinux.com/ftp/lac/systems ... ADME.modem
Things seemed to be going ok until I reached a point when I needed to find a file /etc/modprobe.d/slmodem, which didn't exist.
I've a feeling I need to have a source code or something, but I don't understand that!

Here is some info that may englighten anyone who is able/willing to help:

IBM Thinkpad G40
OS: Debian 3.1
Kernel: 2.6.8
Modem: Agere Systems AC'97 (COM3 - does this help?)
lspci gives the following:
0000:00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 modem controller (rev 01) (prog-if 00[Generic])
Subsystem: IBM: unknown device 0544
Flags:busmaster medium devsel. latency 0, IRQ 11 I/O ports at 2400 [size=256] I/O ports at 2000 [size=128]
Capabilities: [SO] Power Management version 2

I hope someone can help get this modem going? http://pctelcompdb.sourceforge.net/view ... ?id_no=144 suggests that it should work.
I'd really hate to go back to Windows having looked at Debian Linux! Someone please help because I am almost converted!

Thanks, Ian Goodson


P.S. In KDE when I click on kPPP, nothing happens. No window opens or anything. Is this because my modem isn't configured?
bsa03itg
 
Posts: 2
Joined: Sat Aug 27, 2005 12:05 pm

Postby bigjohn » Sun Sep 04, 2005 3:12 am

Well I can't really help, because I've never used linux on dial up - BB only here chap!

But, if you know what the modem model is, then you might look at http://linmodems.org/ and have a good dig round - too identify the modem exactly - then you should be able to get it working (theoretically). If it ain't supported then ?????

that link you posted, well it's only the notes that I didn't quite follow.

It's saying get the driver from the listed ftp site, then unpack it (something like # tar -xzvf /home/bsa03itg/nameofmodemdriverfile.tar.bz2) which creates the directory(ies).

then you'd change directory with the command #cd /home/bsa03itg/nameofmodemdriver which is the directory created when you unpacked as above. The terminal prompt would then change from say bsa03itg @ localhost, to bsa03itg @ localhost nameofmodemdirver # (the # indicates that you're logged in as root, which although the linked instructions show $ i.e. user account, not root, you often have to be root to do the unpack - I'm presuming that you're alright changing between user and root). then "do" $ make

It's then telling you to do # make install

# cp scripts/debian/slmodemd /etc/init.d


Then it wants you to put
alias char-major-212 slamr
alias char-major-213 slusb

In a Debian system, put the above lines in the file
/etc/modutils/slmodem (for Linux 2.4) or in
/etc/modprobe.d/slmodem (for Linux 2.6) and do


So you still have to make sure with the uname -rcommand which kernel version you have, 2.4 or 2.6, obviously to put those 2 lines into the respective file, means either knowing about using text editors under linux (probably as root) or being able to log in graphically as root and then you should be able to open the file with kwrite and just add the lines, save and quit.

It's then saying to do# update-modules, so it doesn't seem to indicate that it minds whether you're in the user account, but with a terminal open and logged in as root or still in the root graphical log in, where you can just open a terminal and do that command.

It then says to do this command
# /usr/sbin/update-rc.d slmodemd defaults 90

To start service slmodemd now, do

# /etc/init.d/slmodemd start

Whether that will allow you to just click kppp I can't say (remember I don't "do" dialup :D), but if kppp just looks for a running modem, then you should be able to put in the dial up number, user name and password.

By chopping out all of the redhat related crap from "their" instructions, and emboldening them, it breaks it down into a smaller number of commands/instruciton and less technical that you may have suspected.

In fact, if the modem driver _IS_ the right one for your machine, then the only pain is getting a copy of it to your /home directory without net access.

Sorry I can't be of proper help, but I already pointed out why! Hopefully it's a little more understandable laid out like that (one of my pet hates is linux documentation - which is why I've now moved to using gentoo, it was a bugger to install, but it's bliss to manage - and their documentation is considerably better than most).
"What the large print giveth, the small print taketh away". Tom Waits
User avatar
bigjohn
LXF regular
 
Posts: 393
Joined: Tue Apr 12, 2005 10:19 pm
Location: UK - South Coast

Postby lisLinux » Sun Sep 04, 2005 6:22 am

Ian,
If you're sure it is a winModem you have, the easy way out would be to buy an external modem.
Which works with windows aswell in case you deside to use that for time to time.
But you might want to try to configure it before you get rid of the winModem. Did you ?

If not:
In Debian 3.1 go to applications => system tools => networking => make yourself root => in networksettings choose "add" => forward => in connectiontype choose modem (PPP)
maybe you'll need to install vwdial but the "wizard" will tell you that.
Take it from there.

greetz,
Lis
User avatar
lisLinux
 
Posts: 4
Joined: Sun Aug 28, 2005 10:57 am
Location: the Netherlands

Postby fingers99 » Sun Sep 04, 2005 2:44 pm

There's an answer to this on Debian Help which suggests that everything needed is available as a deb. If so, using apt-get would be the easiest and best way of doing it.
fingers99
LXF regular
 
Posts: 143
Joined: Thu Apr 07, 2005 6:15 pm

Postby towy71 » Sun Sep 04, 2005 2:50 pm

It might be that you haven't got kppp installed too :-)
still looking for that door into summer
User avatar
towy71
Moderator
 
Posts: 4266
Joined: Wed Apr 06, 2005 2:11 pm
Location: wild West Wales

Postby bsa03itg » Mon Sep 05, 2005 4:50 pm

Thanks for all your advice

Big John : thanks for spelling the instructions out for me, it makes it a bit easier.

However, (and perhaps some one else can help out) I've unpacked slmodem using
# tar -xzvf /home/bsa03itg/nameofmodemdriverfile.tar.gz

as was suggested, but when I look for the file /etc/modprobe.d/slmodem I'm told that it doesn't exist.

Does any one know why this might be?
bsa03itg
 
Posts: 2
Joined: Sat Aug 27, 2005 12:05 pm

Postby fingers99 » Mon Sep 05, 2005 4:52 pm

I'm guessing that it doesn't exist before you compile it.
fingers99
LXF regular
 
Posts: 143
Joined: Thu Apr 07, 2005 6:15 pm


Return to Help!

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests