Missing modules (Was: Audit at boot)

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Missing modules (Was: Audit at boot)

Postby alloydog » Fri Aug 19, 2005 9:27 am

What is the audit that goes on just after boot-up?

Code: Select all
Uncompressing Linux...  Ok, booting the kernel
[19*somenumberhere*]   audit(*somenumberhere*) initializing


With the 2.6.7 kernel, the audit lasted about 1½ to 3 seconds, but after updating to 2.6.12-686-6, it now lasts for just over 90 seconds!

Any ideas?
Last edited by alloydog on Wed Aug 31, 2005 8:36 am, edited 1 time in total.
User avatar
alloydog
LXF regular
 
Posts: 600
Joined: Thu Apr 07, 2005 7:32 pm

RE: Audit at boot

Postby mugstar » Fri Aug 19, 2005 11:58 am

I think it's to do with SELinux, some security-related thingy. (That's a bit useless and vague, I know...) Fedora 4 uses it, and it has to be disabled in order to install nvidia drivers. Other than that I couldn't tell you much, I'm afraid.
mugstar
LXF regular
 
Posts: 184
Joined: Mon Apr 11, 2005 12:43 am
Location: Scotland

RE: Audit at boot

Postby alloydog » Fri Aug 19, 2005 6:01 pm

Hmm, how would I disable it?
User avatar
alloydog
LXF regular
 
Posts: 600
Joined: Thu Apr 07, 2005 7:32 pm

RE: Audit at boot

Postby Rhakios » Fri Aug 19, 2005 8:11 pm

If you are using grub, I expect you would disable it with the
selinux=0
option. Presumably something similar would do for lilo.
Bye, Rhakios
User avatar
Rhakios
Moderator
 
Posts: 7634
Joined: Wed Apr 06, 2005 11:18 pm
Location: Midlands, UK

Postby mugstar » Fri Aug 19, 2005 10:26 pm

To disable it before you install the nvidia module in FC4 you do `/usr/sbin/setenforce 0` as root, and `/usr/sbin/setenforce 1` to re-enable it. Other than that, I dunno anything about it :oops:
mugstar
LXF regular
 
Posts: 184
Joined: Mon Apr 11, 2005 12:43 am
Location: Scotland

Postby alloydog » Mon Aug 22, 2005 9:51 am

Hmm, I don't think it is any 'security' type thingy, as I have just installed Ubuntu 5.04, with the 2.6.10 kernel, on an old 500 MHz PC, and it takes less than two seconds.
I thionk it is checking modules or something.
User avatar
alloydog
LXF regular
 
Posts: 600
Joined: Thu Apr 07, 2005 7:32 pm

Postby alloydog » Wed Aug 31, 2005 8:46 am

I think I now know why the audit is so long. It is a system check, rather than a security check.
Straight after the audit, there are two error messages:
Code: Select all
FATAL: Error inserting fan (/lib/modules/2.6.12-8-686/kernel/drivers/acpi/fan.ko): No such device
FATAL: Error inserting thermal (/lib/modules/2.6.12-8-686/kernel/drivers/acpi/thermal.ko): No such device


A qucik find shows that the modules are there.

Why is the system looking for them when acpi is supposed to be disabled? I have noacpi and acpi=off in the kernel line of menu.lst.
User avatar
alloydog
LXF regular
 
Posts: 600
Joined: Thu Apr 07, 2005 7:32 pm


Return to Help!

Who is online

Users browsing this forum: No registered users and 0 guests