Vlans, Dhcp, Squid, and monmotha 2.3.8-pre9

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Vlans, Dhcp, Squid, and monmotha 2.3.8-pre9

Postby Acidus » Wed Aug 10, 2005 11:14 am

Debian Sarge - Kernel 2.6.12.3

While im using the script, my dhcp clients gets "no DHCPOFFERS received"
msg, but in my server syslog file i can see the DHCPDISCOVER msg from the client, and the DCHPOFFER to that request.

Anyone using monmotha over here? any help, would be great. thnxs in adv!.

/network/intefaces
auto eth0 eth1 vlan2 vlan3 vlan4 vlan5

#iface eth0 inet dhcp

##############################
# VLANS
##############################
iface eth0 inet static
address 10.100.200.213
netmask 255.255.255.0
network 10.100.200.0
broadcast 10.100.200.255
vlan_raw_device eth0

iface vlan2 inet static
address 10.2.0.1
netmask 255.255.0.0
network 10.2.0.0
broadcast 10.2.255.255
vlan_raw_device eth0

iface vlan3 inet static
address 10.3.0.1
netmask 255.255.0.0
network 10.3.0.0
broadcast 10.3.255.255
vlan_raw_device eth0

iface vlan4 inet static
address 10.4.0.1
netmask 255.255.0.0
network 10.4.0.0
broadcast 10.4.255.255

vlan_raw_device eth0
iface vlan5 inet static
address 10.5.0.1
netmask 255.255.0.0
network 10.5.0.0
broadcast 10.5.255.255
vlan_raw_device eth0

##############################
# INTERNET
##############################

iface eth1 inet static
address 192.168.0.1
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.99

--------------------------------------------------
Script(partial)
# Main Options
IPTABLES="/sbin/iptables"
TCP_ALLOW="22"
UDP_ALLOW="68 6112 6119 4000"
INET_IFACE="eth1"
LAN_IFACE="eth0 vlan2 vlan3 vlan4 vlan5"
INTERNAL_LAN="10.100.200.0/24 10.2.0.0/16 10.3.0.0/16 10.4.0.0/16
10.5.0.0/16"
MASQ_LAN="10.100.200.0/24 10.2.0.0/16 10.3.0.0/16 10.4.0.0/16 10.5.0.0/16"
SNAT_LAN=""
DROP="TREJECT"
DENY_ALL=""
DENY_HOSTWISE_TCP=""
DENY_HOSTWISE_UDP=""
BLACKHOLE=""
BLACKHOLE_DROP="DROP"
ALLOW_HOSTWISE_TCP=""
ALLOW_HOSTWISE_UDP=""
TCP_FW=""
UDP_FW=""
MANGLE_TOS_OPTIMIZE="FALSE"
DHCP_SERVER="TRUE"
BAD_ICMP="5 9 10 15 16 17 18"
ENABLE="Y"

# Flood Params
LOG_FLOOD="2/s"
SYN_FLOOD="20/s"
PING_FLOOD="1/s"
ALLOW_OUT_TCP=""
PROXY="10.100.200.213:8080"
MY_IP="10.100.200.213"
Acidus
 
Posts: 1
Joined: Wed Aug 10, 2005 11:09 am

Return to Help!

Who is online

Users browsing this forum: Rojj and 3 guests