OpenSUSE10.3 released

Community announcements - software releases, LUG meetings etc.

Moderators: ChrisThornett, LXF moderators

Postby nordle » Thu Oct 18, 2007 9:57 pm

I'm still in windows, (hdparm -d ??), anyway, your drives appear to have the correct settings and should be super fast, >30MB/sec

Does /var/log/messages or syslog etc tell you anything vaguely appropriate?
I think, therefore I compile
User avatar
nordle
LXF regular
 
Posts: 1500
Joined: Fri Apr 08, 2005 9:56 pm

Postby Marrea » Fri Oct 19, 2007 9:37 am

I thought hdparm –d /dev/hxx was the command to use to check whether DMA was on or not, and it would come back with either using_dma=0 (off) or using_dma=1 (on). And then if you discovered it was off, you used hdparm –d1 /dev/hxx to turn it on. And then to make it permanent you add a line at the bottom of the hdparm.conf file. I’m sure that’s what I did some time ago in one of my Ubuntu installs. But my SUSE 10.3 is obviously not responding to the command properly.

I'm on a different machine at the moment but will have a look at /var/log/messages and syslog when I'm back on the laptop.
User avatar
Marrea
LXF regular
 
Posts: 1877
Joined: Fri Apr 08, 2005 9:32 pm
Location: Chilterns, West Hertfordshire

Postby nelz » Fri Oct 19, 2007 10:52 am

Use hdparm -i /dev/hdX or just hdparm /dev/hdX
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8577
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby Rhakios » Fri Oct 19, 2007 12:34 pm

nelz wrote:Use hdparm -i /dev/hdX or just hdparm /dev/hdX



Erm, shouldn't that be /dev/sdX nowadays?

However, looking back at Marrea's post, it seems she already knows that :oops:
Bye, Rhakios
User avatar
Rhakios
Moderator
 
Posts: 7634
Joined: Wed Apr 06, 2005 11:18 pm
Location: Midlands, UK

Postby nelz » Fri Oct 19, 2007 12:54 pm

I was just following on from the /dev/hxx in Marrea's post. Having said that, PATA devices can still be /dev/dhX, it depends on whether you use the older or newer (and still marked experimental) ATA drivers.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8577
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby Marrea » Fri Oct 19, 2007 4:54 pm

Results from hdparm -i /dev/sda and hdparm -i /dev/sr0 are as in my post of yesterday at 08:59 PM.

Results from hdparm /dev/sda etc below.

Code: Select all
hdparm /dev/sda
/dev/sda:
IO_support    =  0 (default 16-bit)
HDIO_GET_UNMASKINTR failed: Inappropriate ioctl for device
HDIO_GET_DMA failed: Inappropriate ioctl for device
HDIO_GET_KEEPSETTINGS failed: Inappropriate ioctl for device
readonly      =  0 (off)
readahead     = 256 (on)
geometry      = 2432/255/63, sectors = 39070080, start = 0

hdparm /dev/sr0
/dev/sr0:
IO_support    =  0 (default 16-bit)
HDIO_GET_UNMASKINTR failed: Inappropriate ioctl for device
HDIO_GET_DMA failed: Inappropriate ioctl for device
HDIO_GET_KEEPSETTINGS failed: Inappropriate ioctl for device
readonly      =  0 (off)
readahead     = 256 (on)
HDIO_GETGEO failed: Inappropriate ioctl for device

hdparm /dev/cdrom
/dev/cdrom:
IO_support    =  0 (default 16-bit)
HDIO_GET_UNMASKINTR failed: Inappropriate ioctl for device
HDIO_GET_DMA failed: Inappropriate ioctl for device
HDIO_GET_KEEPSETTINGS failed: Inappropriate ioctl for device
readonly      =  0 (off)
readahead     = 256 (on)
HDIO_GETGEO failed: Inappropriate ioctl for device

hdparm /dev/hda
/dev/hda: No such file or directory

hdparm /dev/dvd
/dev/dvd: No such file or directory

hdparm /dev/hdc
/dev/hdc: No such file or directory


This is how menu.lst describes the hard drive:

Code: Select all
###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3 - 2.6.22.9-0.4
   root (hd0,0)
   kernel /boot/vmlinuz-2.6.22.9-0.4-default root=/dev/disk/by-id/scsi-SATA_IC25N020ATCS04-_CSH204DMJ155PF-part1 vga=0x317 resume=/dev/sda2 splash=silent showopts brokenmodules=pata_ali
   initrd /boot/initrd-2.6.22.9-0.4-default


And this is from Xubuntu on the same laptop:

Code: Select all
hdparm /dev/hda3
/dev/hda3:
 multcount    =  0 (off)
 IO_support   =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 readahead    = 256 (on)
 geometry     = 38760/16/63, sectors = 17302005, start = 21768075


hdparm /dev/hdc
/dev/hdc:
 IO_support   =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 readahead    = 256 (on)
 HDIO_GETGEO failed: Inappropriate ioctl for device



All I'm really trying to find out is if there is any way of turning DMA on for my DVD drive in SUSE. Are the errors I'm getting perhaps something to do with hdparm not being compatible with drives which are labelled as sdx rather than hdx?
User avatar
Marrea
LXF regular
 
Posts: 1877
Joined: Fri Apr 08, 2005 9:32 pm
Location: Chilterns, West Hertfordshire

Postby nelz » Sat Oct 20, 2007 7:07 pm

If you are using drives through the SCSI layer, you may need sdparm instead.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8577
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby Marrea » Sat Oct 20, 2007 8:34 pm

Well, I'd been thinking that myself and was actually looking at that sdparm site last night. However, I couldn't see any command which tells you whether you have DMA enabled or not. I am in Fedora 7 on a five year old Evesham desktop at the moment, where the hard drive is shown as sda and my DVD ROM is /dev/scd0, and the hdparm commands don't seem to work properly on those either. Fortunately you can download sdparm from Fedora's Add/Remove Software, which I have just done. As far as I can see, the command sdparm -a /dev/sda [or /dev/scd0] doesn't seem to reveal anything about DMA.

I have xine and libdvdcss installed in Fedora. xine-check reported:

[ hint ] Your DVD drive seems not to be attached via ATAPI.
This might be due to the use of an ide-scsi emulation.
If you really have a SCSI DVD drive, your SCSI controller is likely
to do perfect DMA, so there's no reason to worry about this.
However, if you're using ide-scsi, there is a chance that DMA is
disabled for the DVD drive. Moreover, I don't know how to enable
DMA in that case, so you probably have to live with some performance
loss. (FIXME: check for /proc/ide, provide solution)


plus various OUCHES !! about missing plugins. However, DVDs play perfectly OK in xine in spite of these warnings.

In my googling about sdparm and dma I came across
http://ubuntuforums.org/showthread.php?t=61075
where mlord suggests that "If your disk is showing up as /dev/sda, then DMA is already enabled. No need to fiddle with it."

However the OP there says he has a SATA drive, whereas I don't. I am getting more and more confused about this by the minute. :?
User avatar
Marrea
LXF regular
 
Posts: 1877
Joined: Fri Apr 08, 2005 9:32 pm
Location: Chilterns, West Hertfordshire

Postby Marrea » Fri Nov 09, 2007 8:09 pm

Well, I have finally given up on SUSE10.3 on my HP laptop. I have replaced it this evening with Gutsy Gibbon, which so far seems to be much better suited to the hardware. However, OOo Writer (2.3) has just crashed on me, so I hope that is not going to be a regular occurrence!
User avatar
Marrea
LXF regular
 
Posts: 1877
Joined: Fri Apr 08, 2005 9:32 pm
Location: Chilterns, West Hertfordshire

Previous

Return to Announcements

Who is online

Users browsing this forum: No registered users and 0 guests